Bug 9286 - automount cannot mount "generic" filesystems
Summary: automount cannot mount "generic" filesystems
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: autofs (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-09 22:43 UTC by jhorva
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-02 22:37:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description jhorva 2000-02-09 22:43:44 UTC
My Redhat 6.1 installation on an i386 fails to automount remote Windoze
filesystems of type smbfs. The auto.XXXX file looks like this:

shared
-fstype=smbfs,uid=nt,gid=users,filemod=664,dirmod=775,login=itsme,passwd=se
cret	://windoze/shared

When attempting to access the directory, I get a message in syslog:

Feb  9 17:38:34 sporty automount[15703]: cannot find mount method for
filesystem smbfs

My snooping around yields a potential problem at line 43 in file
daemon/mount.c in the autofs-3.1.3 source package. Seems to be a simple
logic problem. Note my comment in the snippet of code below:

...
  mod = open_mount(modstr = fstype, NULL);
  if ( !mod ) {
    for ( ngp = not_generic ; *ngp ; ngp++ ) {
      if ( !strcmp(fstype, *ngp) ) break;
    }
    if ( ! *ngp ) /*<<<<< (Joe Horvath 2/9/00) should read: if ( *ngp ) */
      mod = open_mount(modstr = "generic", NULL);
    if ( !mod ) {
      syslog(LOG_ERR, "cannot find mount method for filesystem %s",
fstype);
      return -1;
    }
  }
...

Thanks...Joe Horvath
jhorva@us.ibm.com

Comment 1 Nalin Dahyabhai 2000-02-10 14:10:59 UTC
This is due to an inconsistency between autofs and the mount command, which is
fixed in Raw Hide and our just-released beta.  If you upgrade your autofs,
mount, and samba-client packages to the newer versions, and change the fstype
to "smb", all should be well.  Here's the relevant snippet from my map file:
tmp		-fstype=smb,uid=nalin,gid=nalin	://blade/tmp

Comment 2 Nalin Dahyabhai 2000-02-10 14:11:59 UTC
Whoops, the inconsistency is between autofs and the various versions of Samba
2.0.x, where the smbmount command changed both names and options, and then
changed back due to complaints about this sort of thing....

Comment 3 Nalin Dahyabhai 2000-03-02 22:37:59 UTC
This should work correctly with autofs-3.1.4-4 from Raw Hide if you set the
fstype to "smb".  Please reopen this bug if you continue to have difficulties
after upgrading.


Note You need to log in before you can comment on or make changes to this bug.