Bug 929373 - storage warnings are not visible enough
Summary: storage warnings are not visible enough
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: RejectedBlocker
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-03-30 03:42 UTC by Robert Lightfoot
Modified: 2014-02-21 21:57 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-21 21:57:47 UTC
Type: Bug


Attachments (Terms of Use)
tty1 screenshot at crash (12.19 KB, image/png)
2013-04-01 23:41 UTC, Robert Lightfoot
no flags Details
tty2 screenshot - running top at crash (16.12 KB, image/png)
2013-04-01 23:41 UTC, Robert Lightfoot
no flags Details
tty3 screenshot at crash (15.52 KB, image/png)
2013-04-01 23:42 UTC, Robert Lightfoot
no flags Details
tty4 screenshot at crash (16.46 KB, image/png)
2013-04-01 23:43 UTC, Robert Lightfoot
no flags Details
tty5 screenshot at crash (15.73 KB, image/png)
2013-04-01 23:43 UTC, Robert Lightfoot
no flags Details
tty7 screenshot - Gui Screen at crash (35.08 KB, image/png)
2013-04-01 23:46 UTC, Robert Lightfoot
no flags Details

Description Robert Lightfoot 2013-03-30 03:42:14 UTC
Description of problem:
Select XFCE-x8664 Install with no Swap Specified

Version-Release number of selected component (if applicable):


How reproducible:
repeated 2x and did not occur when swap was present

Steps to Reproduce:
1. boot installer
2. choose an HD layout with no swap
3. Choose XFCE to install
  
Actual results:
crash at package xml-common

Expected results:
successful install

Additional info:

Comment 1 Chris Lumens 2013-04-01 14:24:41 UTC
How much memory do you have?

Comment 2 Robert Lightfoot 2013-04-01 16:19:40 UTC
Standard Test Default 1024MB with 12GB HD. and 1.98GB for swap

Comment 3 Chris Lumens 2013-04-01 18:26:43 UTC
When you had no swap specified (despite what you say in comment #2), did anaconda give you a warning indicating you had no swap and that might cause problems?

Comment 4 Robert Lightfoot 2013-04-01 23:40:05 UTC
Yes Sorry Chris it was a 12.28GB HD with 1024 of Memory.  /boot was 500mb and /was 11.78gb and no swap.  There was no warning popup except that on the main trunk of anaconda gui the partitioning PushButton Text read "warning checking software partitioning" or something close to that.  The Begin Install Pushbutton was not greyed out and pressing it started the install.

Comment 5 Robert Lightfoot 2013-04-01 23:41:04 UTC
Created attachment 730516 [details]
tty1 screenshot at crash

Comment 6 Robert Lightfoot 2013-04-01 23:41:50 UTC
Created attachment 730517 [details]
tty2 screenshot - running top at crash

Comment 7 Robert Lightfoot 2013-04-01 23:42:21 UTC
Created attachment 730518 [details]
tty3 screenshot at crash

Comment 8 Robert Lightfoot 2013-04-01 23:43:08 UTC
Created attachment 730520 [details]
tty4 screenshot at crash

Comment 9 Robert Lightfoot 2013-04-01 23:43:34 UTC
Created attachment 730521 [details]
tty5 screenshot at crash

Comment 10 Robert Lightfoot 2013-04-01 23:46:00 UTC
Created attachment 730522 [details]
tty7 screenshot - Gui Screen at crash

Comment 11 Robert Lightfoot 2013-04-01 23:47:51 UTC
Chris you now have a screenshot of every tty at crash

Comment 12 Robert Lightfoot 2013-04-03 08:40:42 UTC
Just tested and gnome install faults at some point.

Comment 13 Robert Lightfoot 2013-04-03 11:43:55 UTC
testing KDE and it has yet to fail, but it is installing very slowly.

Comment 14 Adam Williamson 2013-04-03 16:28:39 UTC
Discussed at 2013-04-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-04-03/f19alpha-blocker-review-4.2013-04-03-16.01.log.txt . Rejected as a blocker: this is essentially a self-inflicted OOM situation, and that doesn't hit any of the Alpha criteria. It would be nice to have a warning about potential OOM when installing with no swap and low system RAM, but it's not a blocker issue.

Comment 15 Robert Lightfoot 2013-04-04 02:02:19 UTC
with 2048 MB Ram to VM this issue does not occur ; Also does not occur at 1536 MB ;

Comment 16 Robert Lightfoot 2013-04-04 03:59:16 UTC
Turns Out 1280MB is also enough.  This should probablt be tested again once closer to final and make sure that no swap install meets memory requirements established.   yadda yadda yadda

Comment 17 Chris Lumens 2013-04-04 17:23:49 UTC
If I try to reproduce this, I see a message on the hub saying "Warning checking storage configuration" and then if I go into the storage spoke again, I see the usual bar along the bottom that tells me I've not created a swap partition.

So, there is a message for this.  It's just not visible enough.  I'm going to treat this bug as a request to make the message more visible.

Comment 18 Chris Lumens 2014-02-21 21:57:47 UTC
I believe 769a583f7ec94e96d7e49e63360fff0970f3ff3c on master fixes this.  It was also being tracked by bug 975840.


Note You need to log in before you can comment on or make changes to this bug.