Bug 9296 - ping gives wrong exit status
Summary: ping gives wrong exit status
Status: CLOSED DUPLICATE of bug 6633
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netkit-base   
(Show other bugs)
Version: 6.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-10 11:29 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 14:24:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-02-10 11:29:07 UTC
netkit-base-0.10-37 on RH61:

192.168.100.103 is on the air and 192.168.100.105 is switched off.

ping -c 1 192.168.100.103 ; echo $?
0
ping -c 1 192.168.100.105 ; echo $?
0

Both give exit status 0, but the ping to the machine that is switched off
should give '1' as exit status.

Richard.

Comment 1 Jeff Johnson 2000-02-10 14:24:59 UTC
*** This bug has been marked as a duplicate of 6633 ***


Note You need to log in before you can comment on or make changes to this bug.