Bug 9311 - consolehelper/userhelper are broken
consolehelper/userhelper are broken
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: usermode (Show other bugs)
6.2
All Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-10 12:15 EST by Brian Ryner
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-28 17:23:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace of gnorpm-auth session (35.78 KB, text/plain)
2000-02-10 14:05 EST, Brian Ryner
no flags Details

  None (edit)
Description Brian Ryner 2000-02-10 12:15:03 EST
If I select GnoRPM from the Gnome menu (or run gnorpm-auth from a
terminal), I'm prompted for the root password; I enter it, but then gnorpm
never comes up.  gnorpm-auth does not crash, it terminates normally, just
without starting gnorpm.
Comment 1 Brian Ryner 2000-02-10 12:19:59 EST
Changing component and description, because this also happens with other
programs that use consolehelper/userhelper, such as up2date.
Comment 2 Brian Ryner 2000-02-10 14:05:59 EST
Created attachment 111 [details]
Strace of gnorpm-auth session
Comment 3 Nalin Dahyabhai 2000-02-10 14:54:59 EST
I'm unable to reproduce this here with the versions from Piglet.  Which
versions of the usermode and gnorpm packages do you have installed?  What are
the contents of the /etc/security/console.apps/gnorpm-auth and
/etc/pam.d/gnorpm-auth files?  Have they been modified at all?
Comment 4 Brian Ryner 2000-02-10 16:16:59 EST
I'm also using the piglet versions:

usermode-1.19-2
gnorpm-0.9-14

/etc/pam.d/gnorpm-auth:

#%PAM-1.0
auth       sufficient	/lib/security/pam_rootok.so
auth       required	/lib/security/pam_pwdb.so
session    optional	/lib/security/pam_xauth.so
account    required	/lib/security/pam_permit.so

/etc/security/console.apps/gnorpm-auth:

USER=root
PROGRAM=/usr/bin/gnorpm
SESSION=true
FALLBACK=true
Comment 5 Brian Ryner 2000-02-10 16:23:59 EST
Reassigning to nalin@redhat.com.
Comment 6 Jeremy Katz 2000-02-13 00:00:59 EST
Are you trying to run the app locally or over a remote connection with an
exported DISPLAY, either via ssh or telnet?  I am able to perfectly replicate
what you describe when running something using userhelper over an ssh session
with exported DISPLAY, but it works fine when running to :0.  This behavior also
exists in Red Hat Linux 6.0
Comment 7 Brian Ryner 2000-02-13 00:01:59 EST
Nope, this is local, DISPLAY=:0.
Comment 8 Brian Ryner 2000-02-13 14:42:59 EST
I just found this out-- the userhelper program is exiting with error 1.  In the
manpage, it says that this means "The authentication password was incorrect",
but this doesn't make that much sense in this case.  If I enter the wrong
password, the dialog pops up again.  It's only after I enter the correct
password that it exits with this error code.
Comment 9 Brian Ryner 2000-02-13 14:58:59 EST
Furthermore, the call which appears to be failing is:

retval = pam_open_session(pamh, 0);

at userhelper.c, line 611.
Comment 10 Brian Ryner 2000-02-15 01:17:59 EST
Ok, I just completely rebooted and now (viola!) this works.  But I don't know
whether it should be marked WORKSFORME, considering that it was doing this
consistently for me for quite awhile.

Note You need to log in before you can comment on or make changes to this bug.