Bug 9371 - All apps started within KPanel start within a terminal
Summary: All apps started within KPanel start within a terminal
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-12 01:50 UTC by mikecra
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-15 03:33:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description mikecra 2000-02-12 01:50:19 UTC
All applications started by KPanel start within a terminal window.

Comment 1 Jay Kulpinski 2000-02-14 04:22:59 UTC
This seems to be related to the kdebase-1.1.2-boolterm.patch file.
Most of the files in /usr/share/applnk have "Terminal=0" or
"Terminal=1" when they should probably have "Terminal=false" or
"Terminal=true".  Also, I can't tell if this part of the patch
is correct - should it use 'config.readBoolEntry( "Terminal", false )'
instead?

@@ -1839,7 +1839,7 @@

     QString exec = config->readEntry( "Exec" );
     QString name = config->readEntry( "Name" );
-    QString term = config->readEntry( "Terminal" );
+    bool bterm = config->readEntry( "Terminal" );
     QString termOptions = config->readEntry( "TerminalOptions" );
     QString icon = config->readEntry( "Icon", "" );
     QString miniicon = config->readEntry( "MiniIcon", "" );

Comment 2 Bill Nottingham 2000-02-15 03:33:59 UTC
fixed in rawhide.


Note You need to log in before you can comment on or make changes to this bug.