Bug 9381 - sysfont in initsripts
sysfont in initsripts
Status: CLOSED WONTFIX
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-12 12:19 EST by Alec Voropay
Modified: 2014-03-16 22:12 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-21 08:22:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alec Voropay 2000-02-12 12:19:11 EST
Could you move the 'console font setting' task into
separate 'subsystem' as it done for keyboard :
/etc/rc.d/init.d/keytable

 It's not a good idea to set up _console_font_ from
/etc/sysconfig/i18n

Could you make :
/etc/rc.d/init.d/sysfont
and
/etc/sysconfig/sysfont
for :
SYSFONT=
UNIMAP=
SYSFONTACM=
Comment 1 Bill Nottingham 2000-02-12 14:49:59 EST
Why is it not a good idea?
Comment 2 Alec Voropay 2000-02-17 11:31:59 EST
1) Unification. Why you did 'init.d/keytable' ?
The 'init.d/sysfont' should be as subsystem too.

2) The locale settings (i18n) are very different
from console/font/keyboard settings.

3) The /etc/profile.d/*.sh files executed on EVERY
shell's start. I do not need i386 hardware console
initialization when I connected to the host by telnet
or xterm/pty .

4) I can always reset my keyboard by issuing :
$ /etc/rc.d/init.d/keyboard restart
How I can reset my console font ?
Comment 3 Alec Voropay 2000-02-21 08:22:59 EST
See bug IDs:
 <a href="http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=9519">9519</a>
 <a href="http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=9523">9523</a>
Comment 4 Bill Nottingham 2001-01-30 17:10:38 EST
The current lang.sh only does any font tweaking if on the console.

It *is* set in rc.sysinit, thought, because it's needed for translations.

Note You need to log in before you can comment on or make changes to this bug.