Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 9394 - fetchmailconf-5.2.5-1 fails to write .fetchmailrc
fetchmailconf-5.2.5-1 fails to write .fetchmailrc
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: fetchmail (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-13 02:51 EST by Hardy Mayer
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-07-17 17:41:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fetchmailconf script (version 1.21) to fix this bug (1.42 KB, patch)
2000-02-18 16:37 EST, Hardy Mayer
no flags Details | Diff

  None (edit)
Description Hardy Mayer 2000-02-13 02:51:47 EST
fetchmailconf
After updating from
 fetchmailconf-5.2.3-2.i386.rpm
 fetchmail-5.2.3-2.i386.rpm
to
 fetchmail-5.2.5-1.i386.rpm
 fetchmailconf-5.2.5-1.i386.rpm

I get the following errors when trying to use fetchmailconf:


Exception in Tkinter callback
Traceback (innermost last):
  File "/var/tmp/python/python-root/usr/lib/python1.5/lib-tk/Tkinter.py",
line 764, in __call__
    return apply(self.func, args)
  File "/usr/bin/fetchmailconf", line 758, in save
    fm.write(`self.configuration`)
  File "/usr/bin/fetchmailconf", line 56, in __repr__
    str = str + repr(site)
  File "/usr/bin/fetchmailconf", line 185, in __repr__
    return self.dump(TRUE)
  File "/usr/bin/fetchmailconf", line 119, in dump
    str = str + (" via " + str(self.via) + "\n");
TypeError: call of non-function (type string)



In addition, fetchmail-5.2.5-1 invoked with the option fetchmail -k
repeatedly fetched the same message from my pop3 server, whereas
fetchmail-5.2.3-2 left the message on the server and did not fetch it
again (I was running fetchmail -k via cron, since fetchmailconf did not
offer the option to leave messages on the server).

I reverted to fetchmail-5.2.3-2.i386.rpm  fetchmailconf-5.2.3-2.i386.rpm
and everything went back to normal.

Regards,
--
Hardy
			  -------****-------
Meinhard E. Mayer, Research Professor of Physics and Mathematics
Department of Physics and Astronomy, Frederick Reines Hall
U. C., Irvine CA 92697-4575
In California: Tel: (949) 824-5543; UCI-FAX: (949) 824-2174
Home: 759-3378 E-fax: (734) 448-5140
URL: http://www-swiss.ai.mit.edu/~hardy/hardy.html
     http://www.ps.uci.edu/physics/mayer.html
Comment 1 Hardy MAyer 2000-02-16 12:29:59 EST
Same problem appears in the Raw Hide 20000212 versions:
241303 Feb 11 20:19 fetchmail-5.2.7-2.i386.rpm
 24400 Feb 11 20:19 fetchmailconf-5.2.7-2.i386.rpm
Comment 2 Bernhard Rosenkraenzer 2000-02-18 07:07:59 EST
Fixed in 5.2.8
Comment 3 Hardy MAyer 2000-02-18 14:11:59 EST
The fetchmailconf bug was not fixed in version 1.21 of the script.
I found a kludge which fixes it (replacing one line in the script).
Here are the diffs, which you can use in a patch, until the official patch is
released:
------------------------------------------------------------------------------
*** /usr/bin/fetchmailconf	Mon Feb 14 16:21:07 2000
--- /home/hardy/fetchmailconf	Fri Feb 18 11:10:56 2000
***************
*** 116,122 ****
  	else:             str = str + "skip"
  	str = str + (" " + self.pollname)
  	if self.via:
! 	    str = str + (" via " + str(self.via) + "\n");
  	if self.protocol != ServerDefaults.protocol:
  	    str = str + " with proto " + self.protocol
  	if self.port != defaultports[self.protocol] and self.port != 0:
--- 116,122 ----
  	else:             str = str + "skip"
  	str = str + (" " + self.pollname)
  	if self.via:
! 	    str = str + (" via \"%s\"\n" % (self.via,));
  	if self.protocol != ServerDefaults.protocol:
  	    str = str + " with proto " + self.protocol
  	if self.port != defaultports[self.protocol] and self.port != 0:
----------------------------------------------------------------------------

The "multiple-fetch" bug in fetchmail has been fixed in 5.2.8
Comment 4 Hardy Mayer 2000-02-18 16:37:59 EST
Created attachment 125 [details]
Patch to fetchmailconf script (version 1.21) to fix this bug
Comment 5 Hardy Mayer 2000-02-24 12:12:59 EST
Eric Raymond has come up with a different fix of the fetchmailconf script in
fetchmail-5.3.0-1.i386.rpm, which you can find at:
ftp://ftp.ccil.org/pub/esr/fetchmail/
if you are not willing ro wait for the "official" RH release.
Comment 6 Nalin Dahyabhai 2000-07-17 17:41:43 EDT
Red Hat Linux 6.2 included 5.3.1.  Did this not fix the problem?

Note You need to log in before you can comment on or make changes to this bug.