Bug 9417 - Kernel-sources-2.2.15-2.5.0 does not build correct modules
Kernel-sources-2.2.15-2.5.0 does not build correct modules
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Cristian Gafton
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-14 02:35 EST by Hardy MAyer
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-14 18:44:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
here is my .config file used in building this kernel (16.31 KB, text/plain)
2000-02-14 02:37 EST, Hardy MAyer
no flags Details

  None (edit)
Description Hardy MAyer 2000-02-14 02:35:44 EST
Because of problems with previous versions of the RedHat kernel sources
I used to build my customized kernels and modules directly from the
kernel sources distributed by kernel.org (starting from 2.0.36 up to
2.2.14), which correctly built the sound modules, my dual ethernet card
modules, and all the file systems (vfat, ntfs).

When I tried to rebuild the 2.2.15-2.5.0 kernel (after running make
xconfig, make dep, make clean, make bzImage, etc.) I got a kernel which did
not insert the modules for my two ethernet cards, the vfat and ntfs file
systems and the sound modules.

If needed I can send you  my .config file and the messages log.
I guess I will wait for the official release of the kernel-2.2.15 patch and
live with the properly working 2.2.14 kernel until then.
Comment 1 Hardy MAyer 2000-02-14 02:37:59 EST
Created attachment 115 [details]
here is my .config file used in building this kernel
Comment 2 Hardy MAyer 2000-02-14 18:44:59 EST
I finally succeeded rebuilding the kernel from the Kernel-sources-2.2.15-2.5.0,
by doing the following:  1. I made a "distclean" (presumably that got rid of
some extraneous stuff left over from the packaging of the rpm). Then I removed
the EXTRA-VERSION line from the Makefile, so that my kernel is just 2.2.15.
2. I then remade the sym-link
/usr/src/linux/includes/linux -> /usr/include/linux (just in case this was still
linked to the linux-2.2.14 include tree).
3. To be on the safe side, I replaced the gcc-2.95.2-3 (from the Raw Hide 1.0
dist) by the egcs-1.1.2-27 from 6.1.92 (though I doubt this was the cause of my
previous module-problems).

Lo and behold, the kernel built and the modules loaded correctly (both from a
new boot-disk, and from the NT+linux loader).

I suggest to "gafton@redhat" to make sure that the rpm package does not contain
any extraneous stuff.

Note You need to log in before you can comment on or make changes to this bug.