Bug 9451 - rawhide-release-20000212-1 missing libreadline.so.3?
rawhide-release-20000212-1 missing libreadline.so.3?
Status: CLOSED NOTABUG
Product: Red Hat Raw Hide
Classification: Retired
Component: readline (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
:
: 10517 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-14 21:09 EST by dunwoody
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-14 22:14:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dunwoody 2000-02-14 21:09:57 EST
I installed rawhide-release-20000212-1, including readline-4.0-1, and
I got a bunch of missing rpm dependencies on the older libreadline.so.3 .
Perhaps this is included an a compatibility rpm that I missed?
Comment 1 Bill Nottingham 2000-02-14 22:14:59 EST
Nope; the dependencies will be resolved when the various packages
are recompiled against readline-4.0; workaround is to either recompile
those you need, or don't install readline-4.
Comment 2 Riley H Williams 2000-02-15 13:00:59 EST
I was going to report this bug, but see that it's already been given some
attention...
Comment 3 Jonathan Kamens 2000-02-15 14:58:59 EST
What about third-party applications linked against readline?  Recompiling isn't
always an option, and third-party applications shouldn't just break when a new
RedHat version is installed.  I think you need to provide a compat-readline RPM
with the old library in it.
Comment 4 Robert Walsh 2000-02-19 22:04:59 EST
Two things.

First, I agree with jik@kamens.brookline.ma.us: provide a compat-readline.

Second, here's a list of RPMs on my machine that have a missing dependency on
readline now that I've (force) upgraded to readline-4.0-1.  Some of these are
from Powertools.  Most worked OK when I made a symlink from libreadline.so.3 to
libreadline.so.4 and from libhistory.so.3 to libhistory.so.4.  Others (most
notably samba and cdcd) didn't.  Perhaps you can use this as a basis for what
needs to be recompiled for the next Rawhide release?

Unsatisfied dependencies for R-base-0.64.2-3: libreadline.so.3
Unsatisfied dependencies for amanda-2.4.1p1-3: libreadline.so.3
Unsatisfied dependencies for amanda-client-2.4.1p1-3: libreadline.so.3
Unsatisfied dependencies for amanda-server-2.4.1p1-3: libreadline.so.3
Unsatisfied dependencies for bc-1.05a-5: libreadline.so.3
Unsatisfied dependencies for cdcd-0.4.6-2: libreadline.so.3
Unsatisfied dependencies for cdecl-2.5-10: libreadline.so.3
Unsatisfied dependencies for ext2ed-0.1-20: libreadline.so.3
Unsatisfied dependencies for ftp-0.16-3: libreadline.so.3
Unsatisfied dependencies for fvwm2-2.2.4-4: libreadline.so.3
Unsatisfied dependencies for git-4.3.19-2: libreadline.so.3
Unsatisfied dependencies for gnome-games-1.0.51-4: libreadline.so.3
Unsatisfied dependencies for gnuplot-3.7.1-2: libreadline.so.3
Unsatisfied dependencies for guile-1.3-8: libreadline.so.3
Unsatisfied dependencies for libgtop-examples-1.0.6-1: libreadline.so.3
Unsatisfied dependencies for librep-0.10-2: libreadline.so.3
Unsatisfied dependencies for mico-2.2.7-1: libreadline.so.3
Unsatisfied dependencies for mico-devel-2.2.7-1: egcs-c++ >= 1.1.1,
libreadline.so.3
Unsatisfied dependencies for mysql-3.20.32a-1: libreadline.so.3
Unsatisfied dependencies for mysql-client-3.20.32a-1: libreadline.so.3
Unsatisfied dependencies for pilot-link-0.9.3-2: libreadline.so.3
Unsatisfied dependencies for postgresql-6.5.3-6: libhistory.so.3,
libreadline.so.3
Unsatisfied dependencies for postgresql-devel-6.5.3-6: libhistory.so.3,
libreadline.so.3
Unsatisfied dependencies for postgresql-odbc-6.5.3-6: libhistory.so.3,
libreadline.so.3
Unsatisfied dependencies for postgresql-server-6.5.3-6: libhistory.so.3,
libreadline.so.3
Unsatisfied dependencies for postgresql-tcl-6.5.3-6: libhistory.so.3,
libreadline.so.3
Unsatisfied dependencies for python-1.5.2-13: libreadline.so.3
Unsatisfied dependencies for samba-2.0.6-8: libreadline.so.3
Unsatisfied dependencies for samba-client-2.0.6-8: libreadline.so.3
Unsatisfied dependencies for samba-common-2.0.6-8: libreadline.so.3
Unsatisfied dependencies for sawmill-0.23-1: libreadline.so.3
Unsatisfied dependencies for units-1.55-5: libreadline.so.3
Comment 5 Bill Nottingham 2000-04-03 12:51:59 EDT
*** Bug 10517 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.