Bug 9505 - noarch isn't noarch
Summary: noarch isn't noarch
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 6.1
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-16 23:08 UTC by Kjetil T. Homme
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-08 19:30:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kjetil T. Homme 2000-02-16 23:08:10 UTC
I built termcap-10.2.7-5.src.rpm on Solaris, but when I tried to install it
on Intel Red Hat 6.1, I was told:

# rpm -U
/local/src/RPM/RPMS/noarch/termcap-10.2.7-5.noarch.rpm
package termcap-10.2.7-5 is for a different operating system

So noarch isn't really noarch?

Comment 1 Jeff Johnson 2000-02-17 13:15:59 UTC
No, "noarch" is noarch, but you will need to configure rpm to say that
noarch is compatible with your platform arch. This should have happened
with the line that looks like
	arch_compat: sparc: noarch
but may have failed because uname(2) on your box is returning different
information, or because rpm cannot find its configuration file.

What does "rpm --showrc" say on your platform?

What does "uname -a" say on your platform?

Comment 2 Jeff Johnson 2000-03-08 19:30:59 UTC
This problem appears to be resolved. Please reopen if I'm wong.

Comment 3 Pavel Roskin 2001-01-10 21:44:48 UTC
I believe that noarch should be compatible with all other architectures by
definition. No explicit statements in the RPM config files should be required.


Note You need to log in before you can comment on or make changes to this bug.