Bug 950796 - [abrt] initial-setup-0.3.4-3.fc19: parser.py:715:readKickstart:KickstartError: The following problem occurred on line 0 of the kickstart file:
Summary: [abrt] initial-setup-0.3.4-3.fc19: parser.py:715:readKickstart:KickstartError...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: initial-setup
Version: 19
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Vratislav Podzimek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f44a6ec91091f0231c5feaa497e...
: 964982 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-04-10 23:08 UTC by Michal Ambroz
Modified: 2013-05-30 03:38 UTC (History)
5 users (show)

Fixed In Version: initial-setup-0.3.5-1.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-05-30 03:38:27 UTC


Attachments (Terms of Use)
File: backtrace (1.16 KB, text/plain)
2013-04-10 23:08 UTC, Michal Ambroz
no flags Details
File: core_backtrace (420 bytes, text/plain)
2013-04-10 23:08 UTC, Michal Ambroz
no flags Details
File: dso_list (66 bytes, text/plain)
2013-04-10 23:08 UTC, Michal Ambroz
no flags Details
File: environ (169 bytes, text/plain)
2013-04-10 23:08 UTC, Michal Ambroz
no flags Details

Description Michal Ambroz 2013-04-10 23:08:09 UTC
Description of problem:


Version-Release number of selected component:
initial-setup-0.3.4-3.fc19

Additional info:
cmdline:        python -m initial_setup
executable:     /usr/lib/python2.7/site-packages/initial_setup/__main__.py
kernel:         3.9.0-0.rc4.git0.1.fc19.x86_64
runlevel:       unknown
uid:            0
ureports_counter: 1

Truncated backtrace:
parser.py:715:readKickstart:KickstartError: The following problem occurred on line 0 of the kickstart file:

Unable to open input kickstart file: curl#37 - "Couldn't open file /root/anaconda-ks.cfg"


Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/lib/python2.7/site-packages/initial_setup/__main__.py", line 66, in <module>
    parser.readKickstart("/root/anaconda-ks.cfg")
  File "/usr/lib/python2.7/site-packages/pykickstart/parser.py", line 715, in readKickstart
    raise KickstartError, formatErrorMsg(0, msg=_("Unable to open input kickstart file: %s") % e.strerror)
KickstartError: The following problem occurred on line 0 of the kickstart file:

Unable to open input kickstart file: curl#37 - "Couldn't open file /root/anaconda-ks.cfg"


Local variables in innermost frame:
reset: True
self: <pyanaconda.kickstart.AnacondaKSParser instance at 0x1ad2248>
f: '/root/anaconda-ks.cfg'
e: URLGrabError(14, 'curl#37 - "Couldn\'t open file /root/anaconda-ks.cfg"')
cd: '/root'

Comment 1 Michal Ambroz 2013-04-10 23:08:12 UTC
Created attachment 733915 [details]
File: backtrace

Comment 2 Michal Ambroz 2013-04-10 23:08:14 UTC
Created attachment 733916 [details]
File: core_backtrace

Comment 3 Michal Ambroz 2013-04-10 23:08:16 UTC
Created attachment 733917 [details]
File: dso_list

Comment 4 Michal Ambroz 2013-04-10 23:08:18 UTC
Created attachment 733918 [details]
File: environ

Comment 5 Vratislav Podzimek 2013-04-11 13:13:18 UTC
Can you please check if the /root/anaconda-ks.cfg file exists on the system?

Comment 6 John Reiser 2013-04-14 22:24:20 UTC
Description of problem:
Boot Fedora 19 Alpha TC6 i686 XFCE Live spin on system with Radeon 9250 graphics card [RV280],

Version-Release number of selected component:
initial-setup-0.3.4-3.fc19

Additional info:
cmdline:        python -m initial_setup
executable:     /usr/lib/python2.7/site-packages/initial_setup/__main__.py
kernel:         3.9.0-0.rc6.git2.1.fc19.i686
runlevel:       unknown
uid:            0
ureports_counter: 1

Truncated backtrace:
parser.py:715:readKickstart:KickstartError: The following problem occurred on line 0 of the kickstart file:

Unable to open input kickstart file: curl#37 - "Couldn't open file /root/anaconda-ks.cfg"


Traceback (most recent call last):
  File "/usr/lib/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/lib/python2.7/site-packages/initial_setup/__main__.py", line 66, in <module>
    parser.readKickstart("/root/anaconda-ks.cfg")
  File "/usr/lib/python2.7/site-packages/pykickstart/parser.py", line 715, in readKickstart
    raise KickstartError, formatErrorMsg(0, msg=_("Unable to open input kickstart file: %s") % e.strerror)
KickstartError: The following problem occurred on line 0 of the kickstart file:

Unable to open input kickstart file: curl#37 - "Couldn't open file /root/anaconda-ks.cfg"


Local variables in innermost frame:
reset: True
self: <pyanaconda.kickstart.AnacondaKSParser instance at 0x9738d8c>
f: '/root/anaconda-ks.cfg'
e: URLGrabError(14, 'curl#37 - "Couldn\'t open file /root/anaconda-ks.cfg"')
cd: '/root'

Comment 7 John Reiser 2013-04-16 15:32:43 UTC
Description of problem:
boot Fedora-19-Alpha-RC3 XFCE Live spin on system with Radeon 9250 [RV280] video graphics card.  Default user is not auto-logged in.  Choose "Other..." and login as root with empty password.  (Trying 'liveuser' demands a password but each password fails.)

Version-Release number of selected component:
initial-setup-0.3.4-3.fc19

Additional info:
cmdline:        python -m initial_setup
executable:     /usr/lib/python2.7/site-packages/initial_setup/__main__.py
kernel:         3.9.0-0.rc6.git2.3.fc19.i686
runlevel:       unknown
uid:            0
ureports_counter: 1

Truncated backtrace:
parser.py:715:readKickstart:KickstartError: The following problem occurred on line 0 of the kickstart file:

Unable to open input kickstart file: curl#37 - "Couldn't open file /root/anaconda-ks.cfg"


Traceback (most recent call last):
  File "/usr/lib/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/lib/python2.7/site-packages/initial_setup/__main__.py", line 66, in <module>
    parser.readKickstart("/root/anaconda-ks.cfg")
  File "/usr/lib/python2.7/site-packages/pykickstart/parser.py", line 715, in readKickstart
    raise KickstartError, formatErrorMsg(0, msg=_("Unable to open input kickstart file: %s") % e.strerror)
KickstartError: The following problem occurred on line 0 of the kickstart file:

Unable to open input kickstart file: curl#37 - "Couldn't open file /root/anaconda-ks.cfg"


Local variables in innermost frame:
reset: True
self: <pyanaconda.kickstart.AnacondaKSParser instance at 0x992fe4c>
f: '/root/anaconda-ks.cfg'
e: URLGrabError(14, 'curl#37 - "Couldn\'t open file /root/anaconda-ks.cfg"')
cd: '/root'

Comment 8 John Reiser 2013-05-18 22:59:47 UTC
Description of problem:
Boot Fedora-LIVE-XFCE-i686-19-Beta-1.iso (RC2) from USB.  Click on arrow of drop-down for User, select Other, type 'root' then OK.

Version-Release number of selected component:
initial-setup-0.3.4-3.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        python -m initial_setup
executable:     /usr/lib/python2.7/site-packages/initial_setup/__main__.py
kernel:         3.9.2-301.fc19.i686
runlevel:       unknown
uid:            0

Truncated backtrace:
parser.py:715:readKickstart:KickstartError: The following problem occurred on line 0 of the kickstart file:

Unable to open input kickstart file: curl#37 - "Couldn't open file /root/anaconda-ks.cfg"


Traceback (most recent call last):
  File "/usr/lib/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/lib/python2.7/site-packages/initial_setup/__main__.py", line 66, in <module>
    parser.readKickstart("/root/anaconda-ks.cfg")
  File "/usr/lib/python2.7/site-packages/pykickstart/parser.py", line 715, in readKickstart
    raise KickstartError, formatErrorMsg(0, msg=_("Unable to open input kickstart file: %s") % e.strerror)
KickstartError: The following problem occurred on line 0 of the kickstart file:

Unable to open input kickstart file: curl#37 - "Couldn't open file /root/anaconda-ks.cfg"


Local variables in innermost frame:
reset: True
self: <pyanaconda.kickstart.AnacondaKSParser instance at 0xa4114ec>
f: '/root/anaconda-ks.cfg'
e: URLGrabError(14, 'curl#37 - "Couldn\'t open file /root/anaconda-ks.cfg"')
cd: '/root'

Comment 9 Vratislav Podzimek 2013-05-21 09:19:18 UTC
*** Bug 964982 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2013-05-22 12:55:05 UTC
initial-setup-0.3.5-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/initial-setup-0.3.5-1.fc19

Comment 11 Fedora Update System 2013-05-22 22:40:00 UTC
Package initial-setup-0.3.5-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing initial-setup-0.3.5-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8877/initial-setup-0.3.5-1.fc19
then log in and leave karma (feedback).

Comment 12 Sander Salazar 2013-05-29 10:53:11 UTC
Description of problem:
I just booted the F19 Beta KDE Live CD

Version-Release number of selected component:
initial-setup-0.3.4-3.fc19

Additional info:
reporter:       libreport-2.1.4
cmdline:        python -m initial_setup
executable:     /usr/lib/python2.7/site-packages/initial_setup/__main__.py
kernel:         3.9.2-301.fc19.x86_64
runlevel:       unknown
uid:            0

Truncated backtrace:
parser.py:715:readKickstart:KickstartError: The following problem occurred on line 0 of the kickstart file:

Unable to open input kickstart file: curl#37 - "Couldn't open file /root/anaconda-ks.cfg"


Traceback (most recent call last):
  File "/usr/lib64/python2.7/runpy.py", line 162, in _run_module_as_main
    "__main__", fname, loader, pkg_name)
  File "/usr/lib64/python2.7/runpy.py", line 72, in _run_code
    exec code in run_globals
  File "/usr/lib/python2.7/site-packages/initial_setup/__main__.py", line 66, in <module>
    parser.readKickstart("/root/anaconda-ks.cfg")
  File "/usr/lib/python2.7/site-packages/pykickstart/parser.py", line 715, in readKickstart
    raise KickstartError, formatErrorMsg(0, msg=_("Unable to open input kickstart file: %s") % e.strerror)
KickstartError: The following problem occurred on line 0 of the kickstart file:

Unable to open input kickstart file: curl#37 - "Couldn't open file /root/anaconda-ks.cfg"


Local variables in innermost frame:
reset: True
self: <pyanaconda.kickstart.AnacondaKSParser instance at 0x20fb638>
f: '/root/anaconda-ks.cfg'
e: URLGrabError(14, 'curl#37 - "Couldn\'t open file /root/anaconda-ks.cfg"')
cd: '/root'

Comment 13 Fedora Update System 2013-05-30 03:38:27 UTC
initial-setup-0.3.5-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.