Bug 9517 - Russian Text Mode Installation Does Not Work
Summary: Russian Text Mode Installation Does Not Work
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: installer   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact:
URL:
Whiteboard:
Keywords:
: 9523 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-17 13:34 UTC by John Lynn Roseman
Modified: 2013-05-06 17:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-14 11:28:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description John Lynn Roseman 2000-02-17 13:34:20 UTC
When booting from CD-ROM, if text mode installation is
chosen and Russian language is selected, then all screen
messages appear as garbage.  Apparently the console fonts
are not loaded (Cyr_a8x16 in the file /etc/fonts.cgz in
initrd.img).

This problem does not occur when booting from diskette
with bootnet.img.

This problem also existed in RedHat 6.1.

Comment 1 Jay Turner 2000-02-17 15:55:59 UTC
*** Bug 9523 has been marked as a duplicate of this bug. ***

Comment 2 Erik Troan 2000-02-18 19:24:59 UTC
Fixed in internal build.

Comment 3 John Lynn Roseman 2000-03-07 12:47:59 UTC
The original bug was fixed, but Russian text installation still produces
garbage.  Now at least the installer works consistently -- booting from diskette
also produces garbage (booting from diskette worked before this "fix").

The existence of this problem can easily be verified by booting Rawhide
of Feb 28 in text mode from CD or diskette and selecting Russian as the
installation language.

The problem now is that a Cyrillic font is loaded (Cyr_a8x16), but the
screenmap (ACM) does not work.  The font that is loaded is in Alternative
encoding, but the text is written in KOI-8.

If there are any questions about this problem, feel free to mail me.

Comment 4 John Lynn Roseman 2000-03-14 11:28:59 UTC
This problem can be easily fixed by replacing the Cyrillic font file
(Cyr_a8x16) in the /etc/fonts.cgz archive in initrd.img on the boot diskette.
This file was correct in the Red Hat 6.1 distribution, but has a broken
ACM map in the newest Rawhide.


Note You need to log in before you can comment on or make changes to this bug.