This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 955 - Kickstart installation doesent allow more than 128M of swap
Kickstart installation doesent allow more than 128M of swap
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-24 23:07 EST by ahoyer
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-10 13:57:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description ahoyer 1999-01-24 23:07:18 EST
When using the kickstart option, if you need more than 128M
of swap, the kickstart setup will fail.  More than 1 swap
partition isn't allowed either.
Comment 1 Matt Wilson 1999-03-13 16:34:59 EST
128M is a hard kernel swap limit for i386 under 2.0.x kernels.
Looking at the code, multiple swap partitions should work by doing
more than one "part swap --size 32" line.  What error do you get?
Comment 2 Matt Wilson 1999-03-13 17:11:59 EST
Also, swap partitions up to 2 GB are supported in the next release of
Red Hat Linux.
Comment 3 ahoyer 1999-03-13 20:12:59 EST
The idea behind the problem is that I need 256M of swap.  Reading the
howto's it says that that one can have multiple 128M swap partitions
or files to add up to a max of 2 Gb or something like that. So more
than one "part swap --size 128" didn't work for me.
Comment 4 Matt Wilson 1999-04-01 01:01:59 EST
Dave can you please verify?
Comment 5 David Lawrence 1999-06-30 12:21:59 EDT
I have verified that on both 5.2 and 6.0 the installer ignores more
than one swap partition line in the ks.cfg file. This has been
assigned to a developer for further review.
Comment 6 Jay Turner 2000-02-10 13:56:59 EST
This issue is resolved in the current release.

Note You need to log in before you can comment on or make changes to this bug.