Bug 958747 - gnome-shell doesn't group applications correctly in the overview
gnome-shell doesn't group applications correctly in the overview
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity high
: beta
: ---
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-02 06:42 EDT by Vitezslav Humpa
Modified: 2013-05-13 03:44 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-08 22:13:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitezslav Humpa 2013-05-02 06:42:57 EDT
Description of problem:
With gnome-shell overview's 'Show Applications' 'All' tab, applications are not grouped as expected. This means, some are left outside of a category group, some are present in the 'Sundry' category. I.e. Nautilus, Boxes, Cheese, Documents or contacts are all left ungrouped while all seems fine with their respective desktop files. This is also the case of all of KDE applications present.

This is in contrast with the 'Applications' extension that is a part of gnome-shell classic, where all applications are grouped correctly. 

Version-Release number of selected component (if applicable):
gnome-shell-3.8.1-2.el7.x86_64

How reproducible:
Spawn overview, hit 'Show Applications' button in dash and go to the 'All' tab.
  
Actual results:
Applications misgrouped as described.

Expected results:
Applications grouped in the same way as i.e. in the classic mode's menu.
Comment 1 Matthias Clasen 2013-05-08 22:13:46 EDT
The overview intentionally shows the applications in a flat grid.
So, this is not a bug - it could be a feature request to improve the handling of 'app folders', and allow users to create their own and tag apps.
Comment 2 Florian Müllner 2013-05-09 12:20:38 EDT
(In reply to comment #1)
> it could be a feature request to improve the handling of 'app folders', and 
> allow users to create their own and tag apps.

There will likely be a GSoC project this summer which'll cover at least some of those.
Comment 3 Vladimir Benes 2013-05-10 04:45:19 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > it could be a feature request to improve the handling of 'app folders', and 
> > allow users to create their own and tag apps.
> 
> There will likely be a GSoC project this summer which'll cover at least some
> of those.

This is RHEL7 bug, I don't think we can pull in anything that will be done during GSoc. I think we need to have all icons single or grouped. Nothing more nothing less. This bug in my opinion speaks only about consistency.
Comment 4 Florian Müllner 2013-05-10 10:16:48 EDT
(In reply to comment #3)
> I think we need to have all icons single or grouped. Nothing
> more nothing less. This bug in my opinion speaks only about consistency.

Hmm, that's not how I read the report. If this is *only* about classic mode, we can easily change the default folders to match the submenus in the applications menu.
Comment 5 Vitezslav Humpa 2013-05-10 10:46:37 EDT
This is an issue relating generally to the Overview, not specific to the Classic mode. It only gets more obvious with the Classic mode in contrast with the panel Applications menu categories that is not available in the standard mode.

In any way, the problem here is the inconsistency of grouping in the overview. Either there should no grouping at all as Mathias proposed, or the grouping should be done for all applications. Having only 'Utilities' and 'Sundry' apps grouped with the others out in the plain is definitely not right. That is the problem behind this bug.
Comment 6 Florian Müllner 2013-05-10 13:06:24 EDT
(In reply to comment #5)
> Either there should no grouping at all as Mathias proposed

That's not what I read into comment #1 - there's a mention of "improving app-folders" there, which wouldn't make any sense if the post were meant as a suggestion to remove folders. All I read there is "it's working as designed" ...


> Having only 'Utilities' and 'Sundry' apps grouped with the others out 
> in the plain is definitely not right.

No, there is definitively no UI rule that mandates that all applications must be presented at the same hierarchy level. Even if there was, we would by no means be the first offender - for instance in the classic Windows start menu, each menu (including the toplevel one) could contain both launchers and submenus; on Android, applications can be grouped in folders or not ...

The default setup is far from arbitrary, the responsible designer has put quite some thought into it. You can disagree with the outcome, which is OK - we definitively need to make it easier for users to modify the grouping - but please don't imply that anything but your own preference is "definitively wrong".
Comment 7 Vitezslav Humpa 2013-05-13 03:44:56 EDT
I am sorry, but we may have misunderstood each other here. I am definitely agreeing with design concepts behind this. What I mean is the inconsistency in the *default RHEL7 installation* right here and now. Not necessarily even in F19, not upstream and definitely not as an issue with how the grid is designed in general.

If you install RHEL7 right now, you can see most of the applications flat in the grid with only utilities and sundry apps grouped. That is the default state right now, it can't be customized yet and this *default* is what I think should changed to either no groups or all groups to be somehow consistent by default.

Note You need to log in before you can comment on or make changes to this bug.