Bug 9594 - CPU Load on SMP System
CPU Load on SMP System
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
6.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Preston Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-19 18:15 EST by Hal Burgiss
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-23 15:22:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hal Burgiss 2000-02-19 18:15:28 EST
Some time back I noticed system load spikes while the system was pretty
much at idle in X. This is an SMP system running XFree86 3.3.6 (Rawhide),
WindowMaker .61 on RH6.1 (fully updated) with 128M RAM, kernel 2.2.15pre9
ATM. At regular intervals (every 3.5 minutes or so) I started noticing
these spikes. Didn't pay much attention at first, and just thought
something normal going on in the background.  But it is so regular I
started trying to see what it was.  The spikes last only for a few seconds
(5-10) and there is a brief pause between the 2 spikes. Watching this in
xosview, each CPU spikes to 100% usage then bounces around 25-75% range for
a few seconds, then a slight pause, then an identical spike on the other
CPU. Then the cycle repeats.

These snippets were captured while I was sitting watching top, nothing else
significant going on:


Normal (between spikes):

  PID USER  PRI  NI  SIZE RSS SHARE STAT LIB %CPU %MEM  TIME COMMAND
  703 hal   14   0   428  260   200 S     0  1.3  0.2  59:15 wmsysmon
17541 hal   12   0  1036 1036   820 R     0  1.1  0.8   0:02 top
  654 root  18   0 65068  52M  2664 S     0  0.3 41.5 125:31 X
    1 root   0   0   124   68    52 S     0  0.0  0.0   0:20 init
    2 root   0   0     0    0     0 SW    0  0.0  0.0   0:15 kflushd
    3 root   0   0     0    0     0 SW    0  0.0  0.0   0:06 kupdate
    4 root   0   0     0    0     0 SW    0  0.0  0.0   0:00 kpiod
    5 root   0   0     0    0     0 SW    0  0.0  0.0   0:04 kswapd
[...]
  666 hal    1   0  2456 2292  1044 S     0  0.0  1.7   1:55 wmaker
  708 hal    0   0   400  348   172 S     0  0.0  0.2   2:31 wmtime
  701 hal    0   0   268  148   112 S     0  0.0  0.1   3:06 asload
  710 hal    1   0   228  228    80 S     0  0.0  0.1   1:33 asmixer
  712 hal    0   0   932  844   152 S     0  0.0  0.6   3:49 wmglobe
  713 hal    0   0   368  368   188 S     0  0.0  0.2   2:27 mount.app
  706 hal    0   0   484  364   276 S     0  0.0  0.2   4:03 wmmail
  707 hal    0   0   480  340   272 S     0  0.0  0.2   6:13 wmWeather
  708 hal    2   0   348  284   228 S     0  0.0  0.2  28:19 wmnet
 4668 hal    4   0   824  824   664 S     0  0.0  0.6  16:50 wmSMPmon
  730 hal    1   0  1264 1264   540 S     0  0.0  0.9   0:05 Eterm
 1270 hal    1   0  1208 1208   984 S     0  0.0  0.9  16:08 rxvt
[...]


First spike hits CPU 0:

  PID USER  PRI  NI SIZE  RSS SHARE STAT LIB %CPU %MEM  TIME COMMAND
  654 root  12   0 65068  52M  2664 S     0 21.9 41.5 125:22 X
  708 hal    7   0   348  284   228 S     0 11.2  0.2  28:16 wmnet
  741 hal    3   0   648  588   424 S     0  5.5  0.4  15:43 rxvt
 1270 hal    2   0  1208 1208   984 S     0  3.5  0.9  16:07 rxvt
  706 hal    2   0   484  364   276 S     0  2.9  0.2   4:02 wmmail
 4668 hal    1   0   824  824   664 S     0  2.9  0.6  16:47 wmSMPmon
  703 hal    2   0   428  260   200 S     0  2.7  0.2  59:14 wmsysmon
10576 hal    1   0   948  948   736 S     0  2.5  0.7   8:53 wmbp6
  700 hal    1   0   400  236   172 S     0  1.9  0.1   2:58 wmtime
17541 hal    3   0  1036 1036   820 R     0  1.1  0.8   0:01 top
  666 hal    1   0  2456 2292  1044 S     0  0.5  1.7   1:53 wmaker
 1234 hal    0   0   344  204   124 D     0  0.5  0.1   1:22 wmlm
13558 hal    1   0  2020 2020  1512 S     0  0.5  1.5   0:00 Eterm
  701 hal    0   0   268  148   112 S     0  0.3  0.1   3:05 asload


a few seconds later CPU 1:

   PID USER  PRI  NI  SIZE RSS SHARE STAT LIB %CPU %MEM  TIME COMMAND
  654 root  15   0 65068  52M  2664 S     0 17.5 41.5 125:29 X
  708 hal   12   0   348  284   228 S     0 12.1  0.2  28:17 wmnet
10576 hal    4   0   948  948   736 S     0  3.7  0.7   8:53 wmbp6
  741 hal    3   0   648  588   424 S     0  2.7  0.4  15:44 rxvt
  703 hal    2   0   428  260   200 S     0  1.7  0.2  59:14 wmsysmon
  706 hal    3   0   484  364   276 S     0  1.7  0.2   4:03 wmmail
 4668 hal    3   0   824  824   664 S     0  1.7  0.6  16:48 wmSMPmon
17541 hal    4   0  1036 1036   820 R     0  1.7  0.8   0:02 top
 1234 hal    1   0   344  204   124 S     0  1.1  0.1   1:22 wmlm
 1270 hal    1   0  1208 1208   984 S     0  0.9  0.9  16:08 rxvt
  666 hal    1   0  2456 2292  1044 S     0  0.5  1.7   1:54 wmaker
  707 hal    1   0   480  340   272 S     0  0.3  0.2   6:12 wmWeather
  472 root   0   0   512  312   228 S     0  0.1  0.2   0:02 sendmail

The behavior is the same whether top is run from within X, or from a text
console with X running on another tty.
Comment 1 Preston Brown 2000-02-23 15:22:59 EST
Is this effecting your performance adversely in any significant way?  Are you
running a screensaver?

Finding the problem based on these details is going to be next to impossible,
and I'm not sure it's truly a problem anyway.
Comment 2 Hal Burgiss 2000-02-23 19:11:59 EST
No screensaver. Well I am getting random lockups. Have no idea if
there is a correlation or not, but since this is the only unusual
behavior I can find, thought I'd persue it. At the very least, I find
it quite curious indeed that xosview shows 100% CPU usage every 3.5
minutes for no apparent good reason. The same apps on my UP box, do
not do this.

The only other info I can add is pretty much all the offending
processes match this pattern with netstat:

Proto RefCnt Flags   Type     State      I-Node PID/Program name  Path
unix  1     [ ]     STREAM   CONNECTED   18462  5893/rxvt      @000000ca

Any Unix Domain socket with refcnt=1, no flags showing, STREAM, etc
seems to be a culprit. What that means, I have no idea since these are
pretty much all X apps anyway. xfs, pump are not showing wild CPU
fluctuations, for instance.

unix  0   [ ACC ] STREAM   LISTENING   646    542/xfs     /tmp/.font-unix/fs-1
unix  0   [ ACC ] STREAM   LISTENING   267    239/pump    /var/run/pump.sock
Comment 3 Hal Burgiss 2000-02-23 19:12:59 EST
No screensaver. Well I am getting random lockups. Have no idea if
there is a correlation or not, but since this is the only unusual
behavior I can find, thought I'd persue it. At the very least, I find
it quite curious indeed that xosview shows 100% CPU usage every 3.5
minutes for no apparent good reason. The same apps on my UP box, do
not do this.

The only other info I can add is pretty much all the offending
processes match this pattern with netstat:

Proto RefCnt Flags   Type     State      I-Node PID/Program name  Path
unix  1     [ ]     STREAM   CONNECTED   18462  5893/rxvt      @000000ca

Any Unix Domain socket with refcnt=1, no flags showing, STREAM, etc
seems to be a culprit. What that means, I have no idea since these are
pretty much all X apps anyway. xfs, pump are not showing wild CPU
fluctuations, for instance.

unix  0   [ ACC ] STREAM   LISTENING   646    542/xfs     /tmp/.font-unix/fs-1
unix  0   [ ACC ] STREAM   LISTENING   267    239/pump    /var/run/pump.sock

Note You need to log in before you can comment on or make changes to this bug.