Bug 960659 - False positive reported for man page
False positive reported for man page
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-07 11:25 EDT by Jiri Hladky
Modified: 2013-05-09 03:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-08 08:00:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
rpm file where the warning is being reported (131.87 KB, application/x-rpm)
2013-05-07 11:25 EDT, Jiri Hladky
no flags Details
man page for which rpmlint reports a problem (2.22 KB, application/gzip)
2013-05-07 11:27 EDT, Jiri Hladky
no flags Details

  None (edit)
Description Jiri Hladky 2013-05-07 11:25:09 EDT
Created attachment 744787 [details]
rpm file where the warning is being reported

Description of problem:

$rpmlint -i /home/jhladky/rpmbuild/RPMS/x86_64/hwloc-1.7-0.fc18.x86_64.rpm
hwloc.x86_64: W: manual-page-warning /usr/share/man/man1/hwloc-info.1.gz 151: warning: macro `.' not defined
This man page may contain problems that can cause it not to be formatted as
intended.

Line 151 of the man page reads:
.TP

I don't see any problem here.

Version-Release number of selected component (if applicable):
rpmlint version 1.4 Copyright (C) 1999-2007 Frederic Lepied, Mandriva


How reproducible:
$rpmlint -i /home/jhladky/rpmbuild/RPMS/x86_64/hwloc-1.7-0.fc18.x86_64.rpm
hwloc.x86_64: W: manual-page-warning /usr/share/man/man1/hwloc-info.1.gz 151: warning: macro `.' not defined
This man page may contain problems that can cause it not to be formatted as
intended.

1 packages and 0 specfiles checked; 0 errors, 1 warnings.

I will upload the rpm file.

Thanks
Jirka
Comment 1 Jiri Hladky 2013-05-07 11:27:40 EDT
Created attachment 744788 [details]
man page for which rpmlint reports a problem
Comment 2 Ville Skyttä 2013-05-08 08:00:44 EDT
(In reply to comment #0)
> Line 151 of the man page reads:
> .TP

It doesn't read that in the man page attached in comment 1, that one has:

    $ zcat hwloc-info.1.gz | sed -ne 151p
    ..\" **************************

There's one extra "." at the beginning of that line.
Comment 3 Jiri Hladky 2013-05-09 03:16:15 EDT
Thanks for looking into it! Not sure what went wrong but I have apparently checked the wrong file.

Jirka

Note You need to log in before you can comment on or make changes to this bug.