Bug 960883 - uvcvideo: WARNING: at drivers/usb/core/urb.c:327 usb_submit_urb+0x3be/0x3d0()
uvcvideo: WARNING: at drivers/usb/core/urb.c:327 usb_submit_urb+0x3be/0x3d0()
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:c13e4276114c599b880deab4c9c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 05:03 EDT by José Matos
Modified: 2014-05-20 08:18 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 16:57:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (86.46 KB, text/plain)
2013-05-08 05:03 EDT, José Matos
no flags Details

  None (edit)
Description José Matos 2013-05-08 05:03:30 EDT
Description of problem:
At startup after an initial crash

Additional info:
reporter:       libreport-2.1.4
WARNING: at drivers/usb/core/urb.c:327 usb_submit_urb+0x3be/0x3d0()
Hardware name: HP EliteBook 8530p
URB ffff88013347c780 submitted while active
Modules linked in: fuse ebtable_nat ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat lockd bnep iptable_mangle bluetooth sunrpc nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables snd_hda_codec_hdmi snd_hda_codec_analog hp_wmi uvcvideo ppdev sparse_keymap iTCO_wdt iTCO_vendor_support snd_hda_intel videobuf2_vmalloc videobuf2_memops snd_hda_codec videobuf2_core videodev media snd_hwdep snd_seq acpi_cpufreq mperf coretemp microcode arc4 iwldvm mac80211 snd_seq_device iwlwifi joydev cfg80211 serio_raw rfkill snd_pcm parport_pc sdhci_pci sdhci r592 mmc_core memstick snd_page_alloc snd_timer lpc_ich tpm_tis mfd_core snd tpm_infineon e1000e hp_accel soundcore lis3lv02d tpm tpm_bios video mei parport input_polldev ptp pps_core wmi vhost_net tun macvtap macvlan kvm_intel kvm pata_pcmcia hid_logitech_dj radeon firewire_ohci firewire_core yenta_socket crc_itu_t i2c_algo_bit drm_kms_helper ttm ata_generic drm pata_acpi i2c_core uinput
Pid: 1300, comm: knotify4 Not tainted 3.9.0-301.fc19.x86_64 #1
Call Trace:
 [<ffffffff8145fd00>] ? usb_submit_urb+0x340/0x3d0
 [<ffffffff8105cd86>] warn_slowpath_common+0x66/0x80
 [<ffffffff8105cdec>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffff813f0e4c>] ? __pm_runtime_resume+0x5c/0x80
 [<ffffffff81181baf>] ? kmem_cache_alloc_trace+0x1cf/0x230
 [<ffffffff8145fd7e>] usb_submit_urb+0x3be/0x3d0
 [<ffffffffa05e4e71>] uvc_status_start+0x21/0x30 [uvcvideo]
 [<ffffffffa05de24b>] uvc_v4l2_open+0x9b/0x140 [uvcvideo]
 [<ffffffffa053f585>] v4l2_open+0xc5/0x120 [videodev]
 [<ffffffff8119dbec>] chrdev_open+0x9c/0x180
 [<ffffffff811979bb>] do_dentry_open+0x1eb/0x280
 [<ffffffff8119db50>] ? cdev_put+0x30/0x30
 [<ffffffff81197a81>] finish_open+0x31/0x40
 [<ffffffff811a75b9>] do_last+0x4d9/0xe40
 [<ffffffff81294e41>] ? selinux_file_alloc_security+0x41/0x70
 [<ffffffff811a7fd0>] path_openat+0xb0/0x4d0
 [<ffffffff811a4352>] ? final_putname+0x22/0x50
 [<ffffffff811a456b>] ? putname+0x2b/0x40
 [<ffffffff811a8a68>] do_filp_open+0x38/0x80
 [<ffffffff811b4e60>] ? __alloc_fd+0x80/0x120
 [<ffffffff81198d39>] do_sys_open+0xe9/0x1c0
 [<ffffffff81198e31>] sys_open+0x21/0x30
 [<ffffffff8164d819>] system_call_fastpath+0x16/0x1b

Potential duplicate: bug 879462
Comment 1 José Matos 2013-05-08 05:03:40 EDT
Created attachment 745124 [details]
File: dmesg
Comment 2 Josh Boyer 2013-05-08 13:16:46 EDT
Adding Laurent to CC.

José if you can recreate this easily, can you get the output of a usbmon trace?
Comment 3 José Matos 2013-05-08 16:48:40 EDT
I have no idea how I got this as I have not used the inboard camera for a long time.

I have tested it now with usbmon and really got an output when using the camera, so in a sense I am quite surprised how I got this error. :-(

Sorry not to be able to help more.
Comment 4 Laurent Pinchart 2013-05-09 07:28:21 EDT
usbmon won't help much here. We need to add a couple of printk's to the status URB submission paths in the uvcvideo driver and find out how the URB gets submitted a second time.
Comment 5 Martin Kho 2013-05-13 09:23:30 EDT
Hi,

I also see this warning everytime (!) I log in into KDE. FYI: I've found two reports [1][2] with the same problem but with different applications (pegasus driver and imon). May be these can be of help.

Martin Kho

[1] http://comments.gmane.org/gmane.linux.network/263373
[2] https://lkml.org/lkml/2013/4/22/455
Comment 6 Martin Kho 2013-05-17 18:30:08 EDT
Hi,

In bug report #885419 I mentioned that amarok triggered this issue for me in Fedora 18 KDE. It does the same in Fedora 19 KDE. So as a workaround I'm closing amarok before I reboot.

Martin Kho
Comment 7 Martin Kho 2013-05-21 12:29:51 EDT
Hi,

FYI: After the following packages were updated I didn't see this issue anymore. No idea which one was crucial.

Martin Kho

libwayland-client-1.1.90-0.1.20130515.fc19.x86_64
wayland-devel-1.1.90-0.1.20130515.fc19.x86_64
glusterfs-api-3.4.0-0.4.beta1.fc19.x86_64
libdrm-2.4.45-1.fc19.x86_64
libdb-5.3.21-11.fc19.x86_64
sqlite-3.7.16.2-2.fc19.x86_64
mozjs17-17.0.0-3.fc19.x86_64
libwayland-server-1.1.90-0.1.20130515.fc19.x86_64
libwayland-server-devel-1.1.90-0.1.20130515.fc19.x86_64
polkit-0.111-1.fc19.x86_64
sqlite-devel-3.7.16.2-2.fc19.x86_64
libdb-utils-5.3.21-11.fc19.x86_64
libdrm-devel-2.4.45-1.fc19.x86_64
libcacard-1.4.1-2.fc19.x86_64
libwayland-client-devel-1.1.90-0.1.20130515.fc19.x86_64
libwayland-cursor-1.1.90-0.1.20130515.fc19.x86_64
java-1.7.0-openjdk-1.7.0.19-2.3.9.9.fc19.x86_64
xkeyboard-config-2.8-3.fc19.noarch
wayland-1.1.90-0.1.20130515.fc19.x86_64
libdb4-4.8.30-10.fc19.x86_64
squashfs-tools-4.3-0.14.git8ce5585e.fc19.x86_64
icoutils-0.30.0-3.fc19.x86_64
pcre-8.32-6.fc19.x86_64
libvisio-0.0.27-1.fc19.x86_64
wpa_supplicant-2.0-3.fc19.x86_64
xorg-x11-drv-synaptics-1.7.1-2.fc19.x86_64
Comment 8 Martin Kho 2013-05-24 13:21:43 EDT
Hi,

Based on my experience with the same issue in Fedora 18, it looks like the lbdrm update did the trick.

Martin Kho
Comment 9 gcarter 2013-05-28 20:35:51 EDT
Description of problem:
Running Firefox

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.4
cmdline:        BOOT_IMAGE=/vmlinuz-3.9.4-300.fc19.x86_64 root=/dev/mapper/fedora_shiva-root ro rd.lvm.lv=fedora_shiva/root rd.dm=0 rd.lvm.lv=fedora_shiva/swap rd.md=0 rd.luks=0 vconsole.keymap=us rhgb quiet LANG=en_US.UTF-8
kernel:         3.9.4-300.fc19.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: at drivers/usb/core/urb.c:327 usb_submit_urb+0x3be/0x3d0()
Hardware name: Scorpius
URB ffff8807ef1dda80 submitted while active
Modules linked in: fuse ip6table_filter ip6_tables ebtable_nat ebtables bnep bluetooth mmc_block acpi_cpufreq mperf coretemp kvm_intel snd_hda_codec_hdmi rtsx_pci_sdmmc mmc_core iTCO_wdt iTCO_vendor_support snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm arc4 kvm ath9k ath9k_common ath9k_hw crc32_pclmul crc32c_intel ath mac80211 cfg80211 rtsx_pci_ms memstick mxm_wmi rfkill ghash_clmulni_intel tpm_tis uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media microcode snd_page_alloc snd_timer snd joydev tpm_infineon serio_raw r8169 rtsx_pci soundcore i2c_i801 lpc_ich mei mfd_core mii tpm tpm_bios wmi video binfmt_misc uinput radeon i2c_algo_bit drm_kms_helper ttm drm hid_logitech_dj i2c_core
Pid: 4073, comm: kphononplayer Not tainted 3.9.4-300.fc19.x86_64 #1
Call Trace:
 [<ffffffff81460500>] ? usb_submit_urb+0x3b0/0x3d0
 [<ffffffff8105cda6>] warn_slowpath_common+0x66/0x80
 [<ffffffff8105ce0c>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffff813f158c>] ? __pm_runtime_resume+0x5c/0x80
 [<ffffffff81181fcf>] ? kmem_cache_alloc_trace+0x1cf/0x230
 [<ffffffff8146050e>] usb_submit_urb+0x3be/0x3d0
 [<ffffffffa02a3e71>] uvc_status_start+0x21/0x30 [uvcvideo]
 [<ffffffffa029d24b>] uvc_v4l2_open+0x9b/0x140 [uvcvideo]
 [<ffffffffa0266585>] v4l2_open+0xc5/0x120 [videodev]
 [<ffffffff8119e00c>] chrdev_open+0x9c/0x180
 [<ffffffff81197ddb>] do_dentry_open+0x1eb/0x280
 [<ffffffff8119df70>] ? cdev_put+0x30/0x30
 [<ffffffff81197ea1>] finish_open+0x31/0x40
 [<ffffffff811a7a19>] do_last+0x4d9/0xe40
 [<ffffffff811a8430>] path_openat+0xb0/0x4d0
 [<ffffffff811a47b2>] ? final_putname+0x22/0x50
 [<ffffffff811a49cb>] ? putname+0x2b/0x40
 [<ffffffff811a8e3f>] ? user_path_at_empty+0x5f/0x90
 [<ffffffff811a8ec8>] do_filp_open+0x38/0x80
 [<ffffffff811b52d0>] ? __alloc_fd+0x80/0x120
 [<ffffffff81199159>] do_sys_open+0xe9/0x1c0
 [<ffffffff81199251>] sys_open+0x21/0x30
 [<ffffffff8164e3d9>] system_call_fastpath+0x16/0x1b
Comment 10 Martin Kho 2013-05-29 08:51:36 EDT
Hi,

Hurray! Got some updates - i.a. xorg family - and the warning is back from holiday :-)

Closing Amarok before reboot still works around it.

Martin Kho
Comment 11 Alexander Wigen 2013-07-05 05:51:59 EDT
Description of problem:
Not sure how this happened

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.5
cmdline:        BOOT_IMAGE=/vmlinuz-3.9.8-300.fc19.x86_64 root=/dev/mapper/vg_alex--ultraboo-lv_root ro rd.md=0 rd.dm=1 SYSFONT=True rd.luks=1 rd.lvm.lv=vg_alex-ultraboo/lv_root rd.lvm.lv=vg_alex-ultraboo/lv_home KEYTABLE=us-acentos LANG=en_US.UTF-8 rhgb quiet elevator=deadline
kernel:         3.9.8-300.fc19.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: at drivers/usb/core/urb.c:327 usb_submit_urb+0x3be/0x3d0()
Hardware name: 900X3C/900X3D/900X4C/900X4D
URB ffff8802106a6b40 submitted while active
Modules linked in: ebtable_nat iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi xt_CHECKSUM tun bridge stp llc nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables rfcomm bnep dm_crypt snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec acpi_cpufreq snd_hwdep mperf arc4 coretemp snd_seq iTCO_wdt uvcvideo iTCO_vendor_support kvm_intel videobuf2_vmalloc snd_seq_device videobuf2_memops iwldvm videobuf2_core kvm mac80211 videodev samsung_laptop snd_pcm media btusb crc32_pclmul crc32c_intel iwlwifi ghash_clmulni_intel bluetooth r8169 microcode cfg80211 snd_page_alloc tpm_tis snd_timer tpm_infineon mii joydev snd lpc_ich rfkill mei soundcore mfd_core tpm i2c_i801 tpm_bios uinput binfmt_misc i915 i2c_algo_bit drm_kms_helper drm i2c_core wmi video
Pid: 1698, comm: LVAP0 thread Not tainted 3.9.8-300.fc19.x86_64 #1
Call Trace:
 [<ffffffff81460a00>] ? usb_submit_urb+0x3b0/0x3d0
 [<ffffffff8105cc56>] warn_slowpath_common+0x66/0x80
 [<ffffffff8105ccbc>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffff813f1a3c>] ? __pm_runtime_resume+0x5c/0x80
 [<ffffffff8118228f>] ? kmem_cache_alloc_trace+0x1cf/0x230
 [<ffffffff81460a0e>] usb_submit_urb+0x3be/0x3d0
 [<ffffffffa046de71>] uvc_status_start+0x21/0x30 [uvcvideo]
 [<ffffffffa046724b>] uvc_v4l2_open+0x9b/0x140 [uvcvideo]
 [<ffffffffa02fe585>] v4l2_open+0xc5/0x120 [videodev]
 [<ffffffff8119e32c>] chrdev_open+0x9c/0x180
 [<ffffffff811980fb>] do_dentry_open+0x1eb/0x280
 [<ffffffff8119e290>] ? cdev_put+0x30/0x30
 [<ffffffff811981c1>] finish_open+0x31/0x40
 [<ffffffff811a7d39>] do_last+0x4d9/0xe40
 [<ffffffff811650e7>] ? page_add_new_anon_rmap+0xc7/0x1d0
 [<ffffffff811a8750>] path_openat+0xb0/0x4d0
 [<ffffffff8115b0d1>] ? handle_mm_fault+0x291/0x660
 [<ffffffff811a91e8>] do_filp_open+0x38/0x80
 [<ffffffff811b55f0>] ? __alloc_fd+0x80/0x120
 [<ffffffff81199479>] do_sys_open+0xe9/0x1c0
 [<ffffffff811e95cb>] compat_sys_open+0x1b/0x20
 [<ffffffff816505ec>] sysenter_dispatch+0x7/0x21
Comment 12 weber 2013-08-20 23:40:19 EDT
Description of problem:
Após o update do Sistema Operacional, foi atualizado o Kernel com a versão mais atual.

Ao inicializar o primeiro sistema que aparece na inicialização do grub, é gerado kernel panic.

Version-Release number of selected component:
kernel

Additional info:
reporter:       libreport-2.1.6
cmdline:        BOOT_IMAGE=/vmlinuz-3.9.5-301.fc19.x86_64 root=/dev/mapper/fedora_kermit-root ro rd.lvm.lv=fedora_kermit/swap rd.md=0 rd.dm=0 rd.lvm.lv=fedora_kermit/root rd.luks=0 vconsole.font=latarcyrheb-sun16 vconsole.keymap=br-abnt2 rhgb quiet
kernel:         3.9.5-301.fc19.x86_64
runlevel:       N 5
type:           Kerneloops

Truncated backtrace:
WARNING: at drivers/usb/core/urb.c:327 usb_submit_urb+0x3be/0x3d0()
Hardware name: Aspire 4745
URB ffff88012f6ca6c0 submitted while active
Modules linked in: ebtable_nat xt_CHECKSUM bridge stp llc bnep bluetooth nf_conntrack_netbios_ns nf_conntrack_broadcast ipt_MASQUERADE ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables acpi_cpufreq mperf snd_hda_codec_hdmi coretemp snd_hda_codec_realtek kvm_intel snd_hda_intel snd_hda_codec kvm arc4 brcmsmac snd_hwdep snd_seq snd_seq_device snd_pcm cordic brcmutil mac80211 crc32c_intel cfg80211 snd_page_alloc uvcvideo snd_timer snd videobuf2_vmalloc acer_wmi sparse_keymap rfkill soundcore videobuf2_memops videobuf2_core videodev media iTCO_wdt microcode iTCO_vendor_support atl1c mei lpc_ich mfd_core intel_ips bcma i2c_i801 serio_raw wmi uinput binfmt_misc usb_storage i915 i2c_algo_bit drm_kms_helper drm i2c_core video
Pid: 1561, comm: knotify4 Not tainted 3.9.5-301.fc19.x86_64 #1
Call Trace:
 [<ffffffff81460700>] ? usb_submit_urb+0x310/0x3d0
 [<ffffffff8105cc26>] warn_slowpath_common+0x66/0x80
 [<ffffffff8105cc8c>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffff813f17dc>] ? __pm_runtime_resume+0x5c/0x80
 [<ffffffff8118200f>] ? kmem_cache_alloc_trace+0x1cf/0x230
 [<ffffffff814607ae>] usb_submit_urb+0x3be/0x3d0
 [<ffffffffa0216e71>] uvc_status_start+0x21/0x30 [uvcvideo]
 [<ffffffffa021024b>] uvc_v4l2_open+0x9b/0x140 [uvcvideo]
 [<ffffffffa01b7585>] v4l2_open+0xc5/0x120 [videodev]
 [<ffffffff8119e0bc>] chrdev_open+0x9c/0x180
 [<ffffffff81197e8b>] do_dentry_open+0x1eb/0x280
 [<ffffffff8119e020>] ? cdev_put+0x30/0x30
 [<ffffffff81197f51>] finish_open+0x31/0x40
 [<ffffffff811a7ac9>] do_last+0x4d9/0xe40
 [<ffffffff81295531>] ? selinux_file_alloc_security+0x41/0x70
 [<ffffffff811a84e0>] path_openat+0xb0/0x4d0
 [<ffffffff81290ec9>] ? avc_has_perm_flags+0xc9/0x180
 [<ffffffff811a4a7b>] ? putname+0x2b/0x40
 [<ffffffff811a8f78>] do_filp_open+0x38/0x80
 [<ffffffff811b5380>] ? __alloc_fd+0x80/0x120
 [<ffffffff81199209>] do_sys_open+0xe9/0x1c0
 [<ffffffff81199301>] sys_open+0x21/0x30
 [<ffffffff8164e799>] system_call_fastpath+0x16/0x1b
Comment 13 Josh Boyer 2013-09-18 16:46:00 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 14 gcarter 2013-09-18 16:54:47 EDT
Seems Resolved as of Fedora 19
Comment 15 Josh Boyer 2013-09-18 16:57:52 EDT
Thank you for letting us know.

Note You need to log in before you can comment on or make changes to this bug.