Bug 961049 - Running packstack from a Fedora machine with RHEL targets fails
Running packstack from a Fedora machine with RHEL targets fails
Status: CLOSED ERRATA
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Unspecified
low Severity unspecified
: ---
: Havana
Assigned To: Martin Magr
Nir Magnezi
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 11:49 EDT by Terry Wilson
Modified: 2013-12-19 19:02 EST (History)
10 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.7.dev806.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:02:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 50585 None None None Never

  None (edit)
Description Terry Wilson 2013-05-08 11:49:12 EDT
Description of problem:

When running packstack from a Fedora machine, but targeting RHEL VMs, installation fails because copyPuppetModules() in packstack/plugins/puppet_950.py checks whether the *local machine* is Fedora, and if so doesn't copy over the create_resources puppet module (as it is included in Puppet 2.7 which exists on Fedora, as opposed to Puppet 2.6 which RHEL has).

Commenting out these two lines:

    if platform.linux_distribution()[0] == "Fedora":
        tar_opts += "--exclude create_resources "

works around the problem, but what really needs to happen is that each target host needs to be checked for either being Fedora or more specifically for having an available puppet package with version >= 2.7.

Version-Release number of selected component (if applicable):

all

How reproducible:

Very.

Steps to Reproduce:
1. Install packstack on a Fedora instance
2. Set any of the target hosts in the answer file to the IP of a RHEL instance
3. Run packstack
  
Actual results:

Mysql fails to install because create_resources doesn't exist.

Expected results:

Installation succeeds.
Comment 5 Scott Lewis 2013-11-19 11:54:54 EST
Auto adding >= MODIFIED bugs to beta
Comment 8 Pádraig Brady 2013-12-18 08:34:28 EST
Note the latest built Fedora package usable on Fedora 19, is the Fedora 20 build at:
http://kojipkgs.fedoraproject.org/packages/openstack-packstack/2013.2.1/0.23.dev934.fc20/


In general one can see the latest RDO package at:
http://repos.fedorapeople.org/repos/openstack/openstack-havana/fedora-19/
Comment 9 Nir Magnezi 2013-12-18 09:14:51 EST
Thank you Pádraig!
Moving this bug from RHOS to RDO since there are no RHOS packages packaged for Fedora.
Comment 11 errata-xmlrpc 2013-12-19 19:02:35 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.