Bug 961100 - [RFE] Foreman should use an organization/environment name instead of label when displaying information in the UI
[RFE] Foreman should use an organization/environment name instead of label wh...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Organizations and Locations (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
Katello QA List
: FutureFeature, Reopened, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 15:30 EDT by Og Maciel
Modified: 2017-02-13 10:54 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-13 10:54:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
environments (36.68 KB, image/png)
2013-05-08 15:30 EDT, Og Maciel
no flags Details

  None (edit)
Description Og Maciel 2013-05-08 15:30:40 EDT
Created attachment 745387 [details]
environments

Description of problem:

Foreman displays organization's labels (my guess to handle i18n?) in the UI for orgs and environments. That works fine but if the organization name or environment name created via katello have i18n characters, then their respective labels become a massive GUID. When you search for your organization in Foreman, it is really hard to know which organization to select (see attached screenshot).

Version-Release number of selected component (if applicable):

* candlepin-0.8.5-1.el6.noarch
* candlepin-selinux-0.8.5-1.el6.noarch
* candlepin-tomcat6-0.8.5-1.el6.noarch
* elasticsearch-0.19.9-7.el6.noarch
* foreman-1.1stable-30.3849429.el6.noarch
* foreman-postgresql-1.1stable-30.3849429.el6.noarch
* katello-1.4.2-1.git.222.82e7958.el6.noarch
* katello-all-1.4.2-1.git.222.82e7958.el6.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-1.el6.noarch
* katello-cli-1.4.2-1.git.37.40869e0.el6.noarch
* katello-cli-common-1.4.2-1.git.37.40869e0.el6.noarch
* katello-common-1.4.2-1.git.222.82e7958.el6.noarch
* katello-configure-1.4.3-1.el6.noarch
* katello-configure-foreman-1.4.3-1.el6.noarch
* katello-glue-candlepin-1.4.2-1.git.222.82e7958.el6.noarch
* katello-glue-elasticsearch-1.4.2-1.git.222.82e7958.el6.noarch
* katello-glue-pulp-1.4.2-1.git.222.82e7958.el6.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-repos-1.4.2-1.el6.noarch
* katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
* pulp-rpm-plugins-2.1.1-0.10.beta.el6.noarch
* pulp-selinux-2.1.1-0.10.beta.el6.noarch
* pulp-server-2.1.1-0.10.beta.el6.noarch

How reproducible:


Steps to Reproduce:
1. Install katello and foreman side by side
2. Using the Katello UI, create the Organization "São Paulo" with default environment "Amanhã"
3. Login to Foreman UI and select the appropriate page to see Organizations or Environments
  
Actual results:

The name of the organization is made up of "KT_" and a GUID

Expected results:

The name of the organization displayed should be KT_São Paulo or something similar

Additional info:
Comment 1 Dmitri Dolguikh 2013-05-29 12:39:12 EDT
This is default katello behaviour: if an entity's name is not ascii, its label will be uuid, rather than the name with spaces substituted by "_"s. The user should specify an ascii label in such a case.
Comment 2 Og Maciel 2013-05-29 12:50:13 EDT
I don't agree with the resolution. This is a major usability issue
Comment 3 Mike McCune 2013-05-29 18:03:36 EDT
OK, so I spoke to Og a bit more about this and came up with a feature request for Foreman:

We need to get the interaction between Katello and Foreman as smooth, clean and user friendly as possible.  One of these issues would be making sure our objects are named clearly and support I18N charsets if possible.

If all names in Foreman require ASCII then Foreman, like Katello should consider a name/label scheme like we did in Katello. We could adjust our integration to instead name the Orgs & Environments in Foreman with the Name field in Katello but then also pop

We added this because various subsystems, like yum, required that objects be named with ASCII characters only.  More information can be found here on our design:

https://fedorahosted.org/katello/wiki/ObjectLabelDesign

Going to re-open this and propose for a future release where we can determine the best way to get Foreman and Katello using I18N object names+labels working well together.

Mik
Comment 4 Dominic Cleal 2013-05-30 04:18:07 EDT
(In reply to Mike McCune from comment #3)
> If all names in Foreman require ASCII then Foreman, like Katello should
> consider a name/label scheme like we did in Katello. We could adjust our
> integration to instead name the Orgs & Environments in Foreman with the Name
> field in Katello but then also pop

I don't think names do require ASCII generally.  The only place I can think of that does leak into external systems is the environment name, which is shared with Puppet.  We could use a name/label scheme for this, and have discussed doing so in the past.  Definitely a valid RFE.

Note You need to log in before you can comment on or make changes to this bug.