Bug 961162 - foreman breaks `katello-configure --reset-data=YES`
foreman breaks `katello-configure --reset-data=YES`
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Ivan Necas
Hayk Hovsepyan
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-08 22:00 EDT by Corey Welton
Modified: 2014-01-27 08:40 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-18 17:18:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Welton 2013-05-08 22:00:11 EDT
Description of problem:
User cannot reset database - foreman throws a big stink, and user ends up with an unusable system, presumably requiring a complete reinstall.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Install katello+foreman and reasonably populate it with data
2. katello-configure --reset-data=YES
3. View results
  
Actual results:
[root@se-rhelbox ~]# katello-configure --reset-data=YES
Starting Katello configuration
The top-level log file is [/var/log/katello/katello-configure-20130508-214813/main.log]
Creating Foreman database user: |====================================================================================================              |
  Failed, please check [/var/log/katello/katello-configure/create-postgresql-foreman-database.log]
  Report errors using # katello-debug tool.
err: /Stage[main]/Foreman::Config/Exec[foreman_config]: Failed to call refresh: /usr/bin/ruby193-ruby /usr/share/foreman/script/foreman-config -k oauth_active -v 'true'                              -k foreman_url -v 'se-rhelbox.usersys.redhat.com'                              -k katello_url -v 'https://se-rhelbox.usersys.redhat.com/katello'                              -k token_duration -v '60'                              -k manage_puppetca -v false                              -k oauth_consumer_key -v 'foreman'                              -k oauth_consumer_secret -v 'zaVOyLVKGMUkRLOplr9eQ0NEyYYy53qL'                              -k oauth_map_users -v 'true'                              -k administrator -v 'root@localhost.localdomain'                              -k signo_sso -v true returned 1 instead of one of [0] at /usr/share/katello/install/puppet/modules/foreman/manifests/config.pp:141
Katello configuration: |===========================================================================================================================|

[root@se-rhelbox ~]# service katello status
katello is not running.


Expected results:
A clean reset

Additional info:
It may be too early to actually expect this to work. But consider this a tracker to assure that things do actually work.
Comment 1 Ivan Necas 2013-05-10 10:03:12 EDT
Any logs available?
Comment 3 Og Maciel 2013-05-10 10:20:15 EDT
Thanks to @inecas, this is how I worked around this:

  $ rm /var/lib/foreman/foreman_db_migrate_done

then re-ran katello-configure
Comment 6 Sam Kottler 2013-05-23 19:41:35 EDT
Moving to ON_QA for drop 2.
Comment 7 Hayk Hovsepyan 2013-06-05 07:15:19 EDT
Verified in revision:
Katello-Katello-Installation-RegisterRHNClassic-1.1-3.noarch
pulp-rpm-plugins-2.1.1-1.el6sat.noarch
katello-configure-1.4.3-12.el6sat.noarch
openldap-2.4.23-31.el6.x86_64
katello-common-1.4.2-8.el6sat.noarch
katello-glue-elasticsearch-1.4.2-8.el6sat.noarch
candlepin-selinux-0.8.9-1.el6_4.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-agent-1.4.2-4.el6sat.noarch
Katello-Katello-Installation-Satellite6Latest-1.0-7.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
Katello-Katello-Configuration-KatelloClient-1.1-45.noarch
katello-cli-common-1.4.2-6.el6sat.noarch
foreman-postgresql-1.1.10002-44.noarch
python-ldap-2.3.10-1.el6.x86_64
katello-certs-tools-1.4.2-2.el6sat.noarch
pulp-server-2.1.1-1.el6sat.noarch
pulp-selinux-2.1.1-1.el6sat.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
signo-katello-0.0.15-1.el6sat.noarch
katello-glue-candlepin-1.4.2-8.el6sat.noarch
katello-selinux-1.4.3-3.el6sat.noarch
katello-1.4.2-8.el6sat.noarch
katello-configure-foreman-1.4.3-12.el6sat.noarch
candlepin-0.8.9-1.el6_4.noarch
candlepin-tomcat6-0.8.9-1.el6_4.noarch
katello-foreman-all-1.4.2-8.el6sat.noarch
candlepin-cert-consumer-cfseserver1.usersys.redhat.com-1.0-1.noarch
signo-0.0.15-1.el6sat.noarch
apr-util-ldap-1.3.9-3.el6_0.1.x86_64
katello-cli-1.4.2-6.el6sat.noarch
foreman-1.1.10002-44.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
ruby193-rubygem-net-ldap-0.2.2-7.el6_4.noarch
ruby193-rubygem-ldap_fluff-0.1.7-3.el6sat.noarch
candlepin-scl-1-5.el6_4.noarch
elasticsearch-0.19.9-8.el6sat.noarch
katello-glue-pulp-1.4.2-8.el6sat.noarch
katello-all-1.4.2-8.el6sat.noarch
katello-qpid-client-key-pair-1.0-1.noarch
pulp-rpm-handlers-2.1.1-1.el6sat.noarch


After reseting data katello works OK.
Comment 8 Mike McCune 2013-07-18 17:18:49 EDT
mass move to CLOSED:CURRENTRELEASE since MDP1 has been released.

Note You need to log in before you can comment on or make changes to this bug.