Bug 961214 - RHEV-M can't list RHEV-H advanced images in upgrade drop-down list.
RHEV-M can't list RHEV-H advanced images in upgrade drop-down list.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: rhev-hypervisor (Show other bugs)
3.2.0
Unspecified Unspecified
high Severity high
: ---
: 3.2.0
Assigned To: Mike Burns
Artyom
node
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 03:02 EDT by cshao
Modified: 2016-02-10 15:09 EST (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 10:00:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
no advanced image (21.82 KB, image/png)
2013-05-09 03:02 EDT, cshao
no flags Details
3.2 cluster (23.87 KB, image/png)
2013-05-09 03:02 EDT, cshao
no flags Details
engine.log (25.87 KB, text/plain)
2013-05-09 03:03 EDT, cshao
no flags Details

  None (edit)
Description cshao 2013-05-09 03:02:20 EDT
Created attachment 745557 [details]
no advanced image

Description of problem:
If the host is in maintenance mode in RHEV-M side, user can reinstall/upgrade the host by click the iso which stored in upgrade drop-down list. 

But actually, in cluster 3.1, RHEV-M only list the base build image. advanced images can't be listed in upgrade drop-down list.
In cluster 3.2, all images can't be listed in upgrade drop-down list.

There are some RHEV-H advanced images store in folder /usr/share/rhev-hypervisor.

# ll /usr/share/rhev-hypervisor
total 733232
-rw-r--r-- 1 root root 187695104 Mar 19 04:39 rhevh-6.4-20130318.1.el6_4.iso
-rw-r--r-- 1 root root 187695104 May  2 08:12 rhevh-6.4-20130501.0.el6_4.iso
lrwxrwxrwx 1 root root        76 May  9 21:56 rhevh-adv-latest-6.iso -> /usr/share/rhev-hypervisor/rhev-hypervisor-advanced-6.4-20130508.1.el6ev.iso
lrwxrwxrwx 1 root root        57 May  9 21:56 rhevh-latest-6.iso -> /usr/share/rhev-hypervisor/rhevh-6.4-20130501.0.el6_4.iso
lrwxrwxrwx 1 root root        57 May  9 21:56 rhev-hypervisor6.iso -> /usr/share/rhev-hypervisor/rhevh-6.4-20130501.0.el6_4.iso
-rw-r--r-- 1 root root 187695104 Apr  9 02:41 rhev-hypervisor-advanced-6.4-20130404.0.el6ev.iso
-rw-r--r-- 1 root root 187695104 May  8 22:52 rhev-hypervisor-advanced-6.4-20130508.1.el6ev.iso
lrwxrwxrwx 1 root root        76 May  9 21:56 rhev-hypervisor-advanced.iso -> /usr/share/rhev-hypervisor/rhev-hypervisor-advanced-6.4-20130508.1.el6ev.iso
lrwxrwxrwx 1 root root        57 May  9 21:56 rhev-hypervisor.iso -> /usr/share/rhev-hypervisor/rhevh-6.4-20130501.0.el6_4.iso
-rw-r--r-- 1 root root         8 Mar 19 04:53 vdsm-compatibility-6.4-20130318.1.el6_4.txt
-rw-r--r-- 1 root root         8 May  2 08:18 vdsm-compatibility-6.4-20130501.0.el6_4.txt
-rw-r--r-- 1 root root         8 May  8 23:04 vdsm-compatibility-6.4-20130508.1.el6ev.txt
lrwxrwxrwx 1 root root        70 May  9 21:56 vdsm-compatibility.txt -> /usr/share/rhev-hypervisor/vdsm-compatibility-6.4-20130508.1.el6ev.txt
-rw-r--r-- 1 root root        21 Mar 19 04:53 version-6.4-20130318.1.el6_4.txt
-rw-r--r-- 1 root root        21 May  2 08:18 version-6.4-20130501.0.el6_4.txt
-rw-r--r-- 1 root root        21 May  8 23:04 version-6.4-20130508.1.el6ev.txt
lrwxrwxrwx 1 root root        59 May  9 21:56 version.txt -> /usr/share/rhev-hypervisor/version-6.4-20130508.1.el6ev.txt


Version-Release number of selected component (if applicable):
RHEV-M SF16
RHEV-M Si28.1
rhev-hypervisor-advanced-6.4-20130508.1.el6ev

How reproducible:
100%

Steps to Reproduce:
1. rpm -ivh rhev-hypervisor-advanced-6.4-20130508.1.el6ev.noarch.rpm
2. register RHEV-H to RHEV-M and set it to UP.
3. Maintain RHEV-H.
4. Upgrade RHEV-H via RHEV-M.
5. Focus on upgrade drop-down list.
  
Actual results:
1. RHEV-M only list the base build image. 
2. RHEV-H advanced images can't be listed in upgrade drop-down list.

Expected results:
RHEV-M can list all RHEV-H images in upgrade drop-down list.

Additional info:
Comment 1 cshao 2013-05-09 03:02:54 EDT
Created attachment 745558 [details]
3.2 cluster
Comment 2 cshao 2013-05-09 03:03:37 EDT
Created attachment 745559 [details]
engine.log
Comment 3 cshao 2013-05-09 04:58:25 EDT
Add keyword "TestBlocker" because RHEV-H QE can't do upgrade testing via RHEV-M due to this bug.
Comment 4 Itamar Heim 2013-05-09 18:06:08 EDT
I'm more concerned if this is not a regression for all rhev-m 3.0 and 3.1 customers?
Comment 5 cshao 2013-05-09 22:17:06 EDT
(In reply to comment #4)
> I'm more concerned if this is not a regression for all rhev-m 3.0 and 3.1
> customers?

For RHEV-H base build, all RHEV-M can list base image in upgrade drop-down list. So this is not a regression bug.

For RHEV-H advanced build, the first build start from rhev-hypervisor-advanced-3.2-201300306.0, until now RHEV-H QE can't do upgrade testing via RHEV-M due to bug 950271 and 924665.

Recently I noticed that bug has been fixed so we try to do some upgrade testing via RHEV-M, but actually, RHEV-M can't list RHEV-H advanced images in upgrade drop-down list, and then we have to report a bug for trace this issue.
 
So I think this is not a regression bug for RHEV-H advanced build because we never done this testing before.

If there is anything wrong please correct me.
Thanks!
Comment 6 Barak 2013-05-12 04:53:57 EDT
This happens due to a change in the installation path of rhev-hypervisor-advanced.
It was discussed on Bug 950271 - and it was agreed that the the path should remain despite the package name change (exactly because of the backwards compatibility issues)

Moving to rhev-hypervisor-advanced just to make sure this is not missed.
Comment 8 Mike Burns 2013-05-14 12:02:36 EDT
Ok, finally traced what the base issue is.  RHEV-M (all 3.x versions) looks for rhevh-*iso and does a number of validations based on version, vdsm-compatibility, etc.  These checks eliminate isos that do not contain version information.

RHEV-ADV was installing an iso that matched rhevh-*iso but it did not include the version in the name.  The iso with the version number was name rhev-hypervisor-advanced-<version>.iso.

A new symlink is introduced in the installation that will match the required format:

e.g. rhevh-adv-6.4-20130514.0.el6ev.iso
Comment 12 Mike Burns 2013-05-21 10:00:29 EDT
This bug refers to the rhev-hypevisor-advanced component.  This component was supposed to be introduced in RHEV 3.2.  It was later decided to drop the inclusion of this component in favor of the existing rhev-hypervisor6 component in RHEL.  

Because we're dropping the component, this bug is not valid any longer.  It only ever appeared in the rhev-hypervisor-advanced component.

Note You need to log in before you can comment on or make changes to this bug.