Bug 961222 - lvmetad is nondeterministically losing PVs
lvmetad is nondeterministically losing PVs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Rockai
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 03:46 EDT by Zdenek Kabelac
Modified: 2013-07-26 04:47 EDT (History)
11 users (show)

See Also:
Fixed In Version: lvm2-2.02.99-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-26 04:46:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log from failing test (113.80 KB, text/plain)
2013-05-09 03:47 EDT, Zdenek Kabelac
no flags Details
Another failing log test (70.32 KB, text/plain)
2013-05-09 03:47 EDT, Zdenek Kabelac
no flags Details

  None (edit)
Description Zdenek Kabelac 2013-05-09 03:46:03 EDT
Description of problem:

I do not have better descriptions of the problem, but for now some tests from lvm2 test-suite seems to be failing with lvmetad with some non-zero probability. The cause is not yet known - i.e. 'make check_lvmetad T=shell/tags.sh' seems to be failing in 1 of 5 test execution.

Version-Release number of selected component (if applicable):
upstream git 2013-05-09

How reproducible:


Steps to Reproduce:
1. repeat execution of make check_lvmetad T=shell/tags.sh until it fails
2. using VERBOSE=1 seems to help (changing timings)
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Zdenek Kabelac 2013-05-09 03:47:13 EDT
Created attachment 745564 [details]
Log from failing test
Comment 2 Zdenek Kabelac 2013-05-09 03:47:55 EDT
Created attachment 745565 [details]
Another failing log test
Comment 3 Zdenek Kabelac 2013-06-05 03:25:26 EDT
Supposedly fixed by patchset from June 1st.

https://www.redhat.com/archives/lvm-devel/2013-June/msg00000.html

I'm no longer seeing these problems.

Note You need to log in before you can comment on or make changes to this bug.