Bug 961233 - Suspend does not work from Gnome Shell menu
Suspend does not work from Gnome Shell menu
Status: CLOSED DUPLICATE of bug 960782
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 04:09 EDT by Ulrich Hobelmann
Modified: 2013-05-13 02:02 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 02:02:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulrich Hobelmann 2013-05-09 04:09:24 EDT
Description of problem:
Clicking suspend in the Gnome Shell user status menu does not work. (Likewise: hibernation, when the alternate status menu extension is installed.)

Version-Release number of selected component (if applicable):
gnome-shell 3.8.1-4.fc19 x86_64

Steps to Reproduce:
1. Open the user menu.
2. Press Alt.
3. Click suspend.
  
Actual results:
The lock screen appears and the screen dims to minimum brightness.

Expected results:
The computer suspends completely.

Additional info:
pm-suspend works, so it's not the other components. dmesg doesn't seem to provide any info. Looks like the hardware layer doesn't even get the memo.
Comment 1 Florian Müllner 2013-05-10 13:21:23 EDT
(In reply to comment #0)
> Steps to Reproduce:
> 1. Open the user menu.
> 2. Press Alt.
> 3. Click suspend.
>   
> Actual results:
> The lock screen appears and the screen dims to minimum brightness.

OK, so this doesn't sound like a gnome-shell issue then. The "suspend" menu item asks logind to suspend, and nothing else. The screen being locked means that logind signals us that we are about to suspend, so everything is working fine up to that point. What happens after we (successfully!) request suspending is out of our control, so reassigning to systemd.
Comment 2 Zbigniew Jędrzejewski-Szmek 2013-05-10 13:36:33 EDT
What systemd version do you have? If you have systemd-203, does it help if you create an empty file /etc/systemd/sleep.conf (sudo touch /etc/systemd/sleep.conf)?
Comment 3 Philipp Dreimann 2013-05-11 16:59:29 EDT
The latest updates fixed the issue for me without touching sleep.conf.
Comment 4 Ulrich Hobelmann 2013-05-12 12:33:01 EDT
Same here. With systemd-204-2 it works.
Comment 5 Michal Schmidt 2013-05-13 02:02:08 EDT

*** This bug has been marked as a duplicate of bug 960782 ***

Note You need to log in before you can comment on or make changes to this bug.