Bug 961250 - Able to trigger host UUID generation through gluster cli command
Able to trigger host UUID generation through gluster cli command
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: krishnan parthasarathi
Shruti Sampat
:
Depends On:
Blocks: 971661
  Show dependency treegraph
 
Reported: 2013-05-09 04:53 EDT by Kanagaraj
Modified: 2016-04-18 06:07 EDT (History)
14 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.10rhs
Doc Type: Enhancement
Doc Text:
Feature: This feature allows the admin to get the uuid of the node (on which the command is executed). Usage: gluster system:: uuid get Reason: This is required because we generate uuid of a node in a lazy manner. ie, we generate a uuid for the node, only on the first volume or peer operation, when the node requires an external identity. Result (if any): With this command, we can force[1] the uuid generation, without a volume or peer operation performed. The uuid is persisted at /var/lib/glusterd/glusterd.info
Story Points: ---
Clone Of:
: 971661 975684 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:39:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kanagaraj 2013-05-09 04:53:37 EDT
Description of problem:
UUID of the host is not generated(or deferred) till the time an another host is peer probed or a volume is created. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:

Through should be a gluster cli command to trigger the UUID generation when needeed.

Additional info:

 In RHS-C, currently we are using IP/name(fqdn) of the host for all our operations and uniquely identify a particular host. But we are hitting lot issues due to the hosts having multiple interfaces and hence multiple ip addresses. More specifically when the hosts are peer probed through cli using different interface/bridge/ip and but added to engine with a different ip. So we have decided to go with the gluster UUID of the host for most of the operations and also to uniquely identify a particular host. The uuid will be fetched when the user adds the node to the rhsc and then stored in the database forever. In this case the vdsm reads the uuid file and returns the uuid to engine
Comment 3 Shruti Sampat 2013-06-19 07:54:25 EDT
Verified as fixed in glusterfs-3.4.0.10rhs. UUID being generated and persisted in /var/lib/glusterd/glusterd.info on running the command - 

# gluster system:: uuid get
Comment 4 Scott Haines 2013-09-23 18:39:42 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 5 Scott Haines 2013-09-23 18:43:47 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.