This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 961254 - required-package list shows sssd-tools
required-package list shows sssd-tools
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: realmd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Stef Walter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 04:59 EDT by Kaushik Banerjee
Modified: 2013-05-26 23:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: realmd-0.14.1-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-26 23:25:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kaushik Banerjee 2013-05-09 04:59:01 EDT
Description of problem:
required-package list shows sssd-tools

Version-Release number of selected component (if applicable):
realmd-0.14.0-1

How reproducible:
Always

Steps to Reproduce:
1. # realm discover sssdad.com
sssdad.com
  type: kerberos
  realm-name: SSSDAD.COM
  domain-name: sssdad.com
  configured: kerberos-member
  server-software: active-directory
  client-software: sssd
  required-package: sssd-tools
  required-package: sssd
  required-package: adcli
  required-package: samba-common
  login-formats: SSSDAD\%U
  login-policy: allow-realm-logins

2. Observe the required-package list.

  
Actual results:
"required-package: sssd-tools" is not needed. And sssd-tools is not installed on my system.

Expected results:


Additional info:
Comment 1 Stef Walter 2013-05-13 01:02:27 EDT
Confirming. Looks like sss_cache has been added to the main 'sssd' package in f19.
Comment 2 Jakub Hrozek 2013-05-13 05:34:22 EDT
(In reply to comment #1)
> Confirming. Looks like sss_cache has been added to the main 'sssd' package
> in f19.

Yes, it was. Sorry, I didn't realize I should have notified the realmd developers about that.
Comment 3 Stef Walter 2013-05-13 12:51:19 EDT
Upstream patch available, and will be in 0.14.1
Comment 4 Fedora Update System 2013-05-13 13:49:27 EDT
realmd-0.14.1-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/realmd-0.14.1-1.fc19
Comment 5 Fedora Update System 2013-05-13 23:47:09 EDT
Package realmd-0.14.1-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing realmd-0.14.1-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8135/realmd-0.14.1-1.fc19
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2013-05-26 23:25:02 EDT
realmd-0.14.1-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.