Bug 961258 - SY quickstart camel-jms-binding not deployable from JBDS, CLI works
SY quickstart camel-jms-binding not deployable from JBDS, CLI works
Status: CLOSED NOTABUG
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Examples, SwitchYard (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: kconner
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 05:16 EDT by ppecka
Modified: 2015-08-02 19:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-10 10:55:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (222.58 KB, image/png)
2013-05-09 12:16 EDT, Len DiMaggio
no flags Details

  None (edit)
Description ppecka 2013-05-09 05:16:02 EDT
Description of problem:
Deployment of camel-jms-binding in JBDS via Run as / Run on Server / Finish. Fails to deploy quickstart. After unsuccessful attempt, i've tried CLI (maven from command line) which works as flawlessly. And then again unsuccessful via JBDS




Steps to Reproduce:
1. cp src/test/resources/switchyard-quickstart-camel-jms-binding-hornetq-jms.xml ${AS7}/standalone/deployments
2. start server
3. add user guest
4. Run as / Run on Server / Finish.

  
Actual results:
[0m[0m11:05:54,123 INFO  [org.jboss.as] (Controller Boot Thread) JBAS015874: JBoss SOA 6.0.0.Alpha-redhat-1 (AS 7.2.0.Final-redhat-4) started in 16405ms - Started 1164 of 1273 services (107 services are passive or on-demand)
[0m[0m11:07:24,409 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-5) JBAS015876: Starting deployment of "switchyard-quickstart-camel-jms-binding.jar" (runtime-name: "switchyard-quickstart-camel-jms-binding.jar")
[0m[0m11:07:24,436 INFO  [org.jboss.weld.deployer] (MSC service thread 1-1) JBAS016002: Processing weld deployment switchyard-quickstart-camel-jms-binding.jar
[0m[0m11:07:24,466 INFO  [org.jboss.weld.deployer] (MSC service thread 1-7) JBAS016005: Starting Services for CDI deployment: switchyard-quickstart-camel-jms-binding.jar
[0m[0m11:07:24,468 INFO  [org.switchyard] (MSC service thread 1-7) Deploying SwitchYard application 'switchyard-quickstart-camel-jms-binding.jar'
[0m[0m11:07:24,478 INFO  [org.jboss.weld.deployer] (MSC service thread 1-4) JBAS016008: Starting weld service for deployment switchyard-quickstart-camel-jms-binding.jar
[0m[0m11:07:24,483 INFO  [org.switchyard] (MSC service thread 1-6) Starting SwitchYard service
[0m[0m11:07:24,683 INFO  [org.apache.camel.management.ManagementStrategyFactory] (MSC service thread 1-6) JMX enabled.
[0m[0m11:07:24,699 INFO  [org.switchyard.security.SecurityProvider] (MSC service thread 1-6) Using SecurityProvider implementation: org.switchyard.security.jboss.JBossJaasSecurityProvider
[0m[0m11:07:24,702 INFO  [org.switchyard.common.camel.SwitchYardCamelContext] (MSC service thread 1-6) Apache Camel 0.8.1.Final (CamelContext: camel-1) is starting
[0m[0m11:07:24,702 INFO  [org.apache.camel.management.DefaultManagementLifecycleStrategy] (MSC service thread 1-6) StatisticsLevel at All so enabling load performance statistics
[0m[0m11:07:24,797 INFO  [org.apache.camel.impl.converter.DefaultTypeConverter] (MSC service thread 1-6) Loaded 179 type converters
[0m[0m11:07:24,814 INFO  [org.switchyard.common.camel.SwitchYardCamelContext] (MSC service thread 1-6) Total 0 routes, of which 0 is started.
[0m[0m11:07:24,815 INFO  [org.switchyard.common.camel.SwitchYardCamelContext] (MSC service thread 1-6) Apache Camel 0.8.1.Final (CamelContext: camel-1) started in 0.113 seconds
[0m[0m11:07:24,953 INFO  [org.apache.camel.impl.converter.DefaultTypeConverter] (MSC service thread 1-6) Loaded 179 type converters
[0m[0m11:07:25,125 INFO  [org.switchyard.common.camel.SwitchYardCamelContext] (MSC service thread 1-6) Apache Camel 0.8.1.Final (CamelContext: camel-1) is shutting down
[0m[0m11:07:25,126 INFO  [org.apache.camel.impl.converter.DefaultTypeConverter] (MSC service thread 1-6) TypeConverterRegistry utilization[attempts=0, hits=0, misses=0, failures=0] mappings[total=179, misses=0]
[0m[0m11:07:25,127 INFO  [org.switchyard.common.camel.SwitchYardCamelContext] (MSC service thread 1-6) Apache Camel 0.8.1.Final (CamelContext: camel-1) is shutdown in 0.002 seconds. Uptime 0.426 seconds.
[0m[31m11:07:25,128 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-6) MSC000001: Failed to start service jboss.deployment.unit."switchyard-quickstart-camel-jms-binding.jar".SwitchYardService: org.jboss.msc.service.StartException in service jboss.deployment.unit."switchyard-quickstart-camel-jms-binding.jar".SwitchYardService: org.switchyard.exception.SwitchYardException: Unknown Service name '{urn:switchyard-quickstart:camel-jms-binding:0.1.0}GreetingService'.
	at org.switchyard.as7.extension.services.SwitchYardService.start(SwitchYardService.java:85)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145) [rt.jar:1.7.0_15]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615) [rt.jar:1.7.0_15]
	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_15]
Caused by: org.switchyard.exception.SwitchYardException: Unknown Service name '{urn:switchyard-quickstart:camel-jms-binding:0.1.0}GreetingService'.
	at org.switchyard.component.bean.deploy.BeanComponentActivator.activateService(BeanComponentActivator.java:85)
	at org.switchyard.deploy.internal.Deployment.deployImplementations(Deployment.java:460)
	at org.switchyard.deploy.internal.Deployment.start(Deployment.java:140)
	at org.switchyard.as7.extension.deployment.SwitchYardDeployment.start(SwitchYardDeployment.java:106)
	at org.switchyard.as7.extension.services.SwitchYardService.start(SwitchYardService.java:78)
	... 5 more

[0m[31m11:07:25,134 ERROR [org.jboss.as.server] (DeploymentScanner-threads - 1) JBAS015870: Deploy of deployment "switchyard-quickstart-camel-jms-binding.jar" was rolled back with the following failure message: 
{"JBAS014671: Failed services" => {"jboss.deployment.unit.\"switchyard-quickstart-camel-jms-binding.jar\".SwitchYardService" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"switchyard-quickstart-camel-jms-binding.jar\".SwitchYardService: org.switchyard.exception.SwitchYardException: Unknown Service name '{urn:switchyard-quickstart:camel-jms-binding:0.1.0}GreetingService'.
    Caused by: org.switchyard.exception.SwitchYardException: Unknown Service name '{urn:switchyard-quickstart:camel-jms-binding:0.1.0}GreetingService'."}}
[0m[0m11:07:25,138 INFO  [org.jboss.weld.deployer] (MSC service thread 1-6) JBAS016009: Stopping weld service for deployment switchyard-quickstart-camel-jms-binding.jar
[0m[0m11:07:25,146 INFO  [org.jboss.as.server.deployment] (MSC service thread 1-2) JBAS015877: Stopped deployment switchyard-quickstart-camel-jms-binding.jar (runtime-name: switchyard-quickstart-camel-jms-binding.jar) in 12ms
[0m

Expected results:
quickstart deploys gracefully
Comment 1 Len DiMaggio 2013-05-09 12:16:11 EDT
Hey Petr,

I repeated your steps and did not see any problem - see attached screenshot.

Question: Did you attempt to run the deployed application? Or did you run the HornetQClient.java client? (I ran the client.)
Comment 2 Len DiMaggio 2013-05-09 12:16:50 EDT
Created attachment 745724 [details]
Screenshot
Comment 3 ppecka 2013-05-10 10:55:08 EDT
not able to reproduce this issue again

Note You need to log in before you can comment on or make changes to this bug.