This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 961497 - Laptop won't suspend
Laptop won't suspend
Status: CLOSED DUPLICATE of bug 960782
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Sven Lankes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 14:03 EDT by Fred van Zwieten
Modified: 2013-05-10 17:45 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-10 17:45:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport (806.75 KB, application/x-xz)
2013-05-09 14:10 EDT, Fred van Zwieten
no flags Details
Log output (12.50 KB, text/plain)
2013-05-10 01:23 EDT, Patrick Talbert
no flags Details

  None (edit)
Description Fred van Zwieten 2013-05-09 14:03:56 EDT
Description of problem:
Laptop won't suspend when closing lid nor when manually suspend from menu

Version-Release number of selected component (if applicable):
Fedora 19 Alpha with all updates up to now

How reproducible:
Close lid or manually suspend

Steps to Reproduce:
1. close lid
2.
3.
  
Actual results:
Gnome Shell switches to lock screen and screen brightness goes to minimum

Expected results:
normal suspend

Additional info:
Laptop is HP Probook 6540b
Comment 1 Fred van Zwieten 2013-05-09 14:10:31 EDT
Created attachment 745764 [details]
sosreport
Comment 2 Patrick Talbert 2013-05-10 01:22:56 EDT
poweradmin is the wrong component for this bug, I believe. I am not sure if it should be upower or something else.

Using a TC3 F19 install today on a Lenovo x230 I have the same issue. Closing the laptop lid does lock the screen, but it does not suspend the device.

I can run pm-suspend and successfully suspend. The upowerd.service is running. I have attached a bit of logging, if it is any use...
Comment 3 Patrick Talbert 2013-05-10 01:23:42 EDT
Created attachment 745899 [details]
Log output
Comment 4 Fred van Zwieten 2013-05-10 16:55:11 EDT
Changed to upower
Comment 5 Patrick Talbert 2013-05-10 16:56:58 EDT
Today's update from systemd-203-2 to 204-2 seems to have resolved this issue for me.
Comment 6 Fred van Zwieten 2013-05-10 17:11:05 EDT
OK, so the component seems to be systemd. I don't have 204 yet. Waiting for the mirrors. As soon as it's in I will test and confirm (or not).
Comment 7 Fred van Zwieten 2013-05-10 17:11:30 EDT
OK, so the component seems to be systemd. I don't have 204 yet. Waiting for the mirrors. As soon as it's in I will test and confirm (or not).
Comment 8 Michal Schmidt 2013-05-10 17:45:00 EDT

*** This bug has been marked as a duplicate of bug 960782 ***

Note You need to log in before you can comment on or make changes to this bug.