Bug 961556 - Traceback when doing a text install using a kickstart with a non-existent package group
Traceback when doing a text install using a kickstart with a non-existent pac...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Samantha N. Bueno
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 19:58 EDT by Adam Williamson
Modified: 2013-11-10 19:00 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-02 09:33:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2013-05-09 19:58:11 EDT
So I have this kickstart that specifies these packages:

%packages
@core
@online-docs
%end

The @online-docs group apparently doesn't exist any more, though.

So I tried doing an F19 Beta TC3 DVD install using this kickstart, in text mode (so kernel parameters 'text inst.ks=http://www.happyassassin.net/extras/ordered_unattended.ks'). It gets through partitioning, *then* evaluates the package groups and notes that online-docs doesn't exist (this seems odd? shouldn't it check first?). It asks me if I want to continue, skipping that group. I say 'yes'.

Then I see:

Progress

** (anaconda:827): WARNING **: Could not open X display

it sticks there for a while, and then I get a traceback. Trying to report the traceback via libreport fails, I guess this is broken from text mode; I'll file a separate bug on that. I'll attach the logs and stuff for this bug manually.

If I adjust the kickstart so that package group isn't listed - so the entire installation can proceed unattended - then it succeeds. I suppose it might be the case that this bug happens any time a text kickstart install has to prompt the user for something, but I'm not sure.
Comment 1 Adam Williamson 2013-05-09 20:05:36 EDT
anaconda 19.24-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 52, in add
    raise KeyError
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/hubs/progress.py", line 107, in refresh
    self.instclass)))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/tui/simpleline/base.py", line 280, in _do_redraw
    input_needed = screen.refresh(args)
KeyError

Local variables in innermost frame:
self: <pyanaconda.threads.ThreadManager object at 0x7f47c0d78f10>
obj: <AnacondaThread(AnaInstallThread, initial daemon)>
Comment 2 Adam Williamson 2013-05-09 20:06:47 EDT
It's a bit hard to attach the logs because anaconda.log is gigantic, and contains thousands of:

23:56:35,393 DEBUG anaconda: running handleException
23:56:35,393 DEBUG anaconda: Gtk cannot be initialized
23:56:35,393 DEBUG anaconda: In a non-main thread, sending a message with exception data
23:56:35,393 DEBUG anaconda: running handleException
23:56:35,393 DEBUG anaconda: Gtk cannot be initialized
23:56:35,393 DEBUG anaconda: In a non-main thread, sending a message with exception data

over and over and over.

I've left the ks in question up at http://www.happyassassin.net/extras/ordered_unattended.ks , the bug should be trivially reproducible just by passing the same parameters I passed.
Comment 3 Samantha N. Bueno 2013-05-13 09:33:05 EDT
Hmm, I'm getting a bit of a different tb:

anaconda 19.24-1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1194, in _selectYumGroup
    raise NoSuchGroup(groupid)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1299, in _applyYumSelections
    self._selectYumGroup("core")
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1373, in checkSoftwareSelection
    self._applyYumSelections()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1460, in preInstall
    self.checkSoftwareSelection()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 127, in doInstall
    payload.preInstall(packages=packages, groups=payload.languageGroups())
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 141, in run
    threading.Thread.run(self, *args, **kwargs)
NoSuchGroup: core

Local variables in innermost frame:
default: True
self: <pyanaconda.packaging.yumpayload.YumPayload object at 0x7f972f9a2f10>
optional: False
pkg_types: ['mandatory', 'default']
groupid: core
Comment 4 Samantha N. Bueno 2013-07-02 09:33:49 EDT
I'm not seeing this anymore with F19, so closing.
Comment 5 Brian J. Murrell 2013-11-10 19:00:56 EST
I think this needs re-opening.  I just experienced this on current F19.

Note You need to log in before you can comment on or make changes to this bug.