Bug 961588 - Checking "Remember me" should work in Firefox
Checking "Remember me" should work in Firefox
Status: CLOSED DUPLICATE of bug 958194
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
2.3
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Damian Jansen
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-09 22:46 EDT by Ding-Yi Chen
Modified: 2014-03-26 20:31 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-26 20:31:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2013-05-09 22:46:09 EDT
Description of problem:
When sign in with Chrome, checking the checkbox "Remember me" make the browser remember user name and password for next sign in.

However in Firefox, checking the checkbox seems has no such effect.

Version-Release number of selected component (if applicable):
Zanata version 3.0.0-SNAPSHOT (20130510-0036)

How reproducible:
Always

Steps to Reproduce:
1. Using Firefox
2. Sign In with "Remember me" checked.
3. Sign out
4. Click *Sign In* to visit the Sign in page.
  
Actual results:
User name and password were not remembered.

Expected results:
User name and password are remembered.

Additional info:
This problem does not seem to occur in Chrome.
Comment 1 Sean Flanigan 2013-10-21 22:07:06 EDT
Actually, in Zanata "Remember me" is only supposed to remember the username using a cookie, not the password:
  http://docs.jboss.org/seam/2.3.1.Final/reference/html/security.html#d0e8787

We leave remembering the password up to the browser's password manager, which should not be affected by the "Remember me" option.
Comment 2 Ding-Yi Chen 2013-10-21 22:25:08 EDT
How about modify the label as "Remember username", so users are unlikely to be confused?
Comment 3 Sean Flanigan 2013-10-21 22:26:58 EDT
Yes, good idea.
Comment 4 Ding-Yi Chen 2013-10-22 03:02:00 EDT
Note that this feature is removed at Zanata version 3.0.3
Comment 5 Ding-Yi Chen 2014-03-26 20:31:13 EDT

*** This bug has been marked as a duplicate of bug 958194 ***

Note You need to log in before you can comment on or make changes to this bug.