Bug 961614 - Headpin Nightly : headpin cli commands failing manually, as well as using automation
Headpin Nightly : headpin cli commands failing manually, as well as using aut...
Status: CLOSED NOTABUG
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello-configure (Show other bugs)
Nightly
x86_64 Linux
high Severity medium
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 01:32 EDT by Tazim Kolhar
Modified: 2016-04-25 20:55 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-10 09:02:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tazim Kolhar 2013-05-10 01:32:38 EDT
Description of problem:
Headpin nightly cli commands failing

Version-Release number of selected component (if applicable):

# rpm -qa | grep katello
katello-headpin-1.4.2-1.git.222.82e7958.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-common-1.4.2-1.git.222.82e7958.el6.noarch
katello-headpin-all-1.4.2-1.git.222.82e7958.el6.noarch
katello-cli-1.4.2-1.git.39.6fb67c1.el6.noarch
katello-glue-candlepin-1.4.2-1.git.222.82e7958.el6.noarch
katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-glue-elasticsearch-1.4.2-1.git.222.82e7958.el6.noarch
katello-cli-common-1.4.2-1.git.39.6fb67c1.el6.noarch
signo-katello-0.0.7-1.el6.noarch
katello-configure-1.4.3-1.el6.noarch
katello-repos-1.4.2-1.el6.noarch

How reproducible:
# yum install -y katello-headpin-all
# katello-configure --deployment=headpin --user-pass=****

Steps to Reproduce:
1.# headpin --username "admin" --password **** org create --name "orgMain-1368161573"
Not Found: /headpin//api/organizations/

2.Headpin Automation Cli TestReport
  http://hudson.rhq.lab.eng.bos.redhat.com:8080/hudson/view/qe-headpin/job/official-headpin-cli/89/ReportNG_Report/
  
Actual results:
headpin cli command execution failed

Expected results:
headpin cli command execution successful

Additional info:
Comment 1 Adam Price 2013-05-10 08:45:21 EDT
cannot reproduce
Comment 2 Adam Price 2013-05-10 08:47:12 EDT
[root@nightlyinstall ~]# rpm -qa | grep "katello\|candlepin\|thumbslug"
katello-headpin-all-1.4.2-1.git.296.fb52d4c.el6.noarch
katello-cli-1.4.2-1.git.43.81cff0b.el6.noarch
katello-glue-candlepin-1.4.2-1.git.296.fb52d4c.el6.noarch
katello-certs-tools-1.4.2-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-repos-1.4.2-1.el6.noarch
thumbslug-selinux-0.0.27-1.el6.noarch
signo-katello-0.0.7-1.el6.noarch
katello-selinux-1.4.3-1.git.3.ce8227b.el6.noarch
candlepin-0.8.6-1.el6.noarch
thumbslug-0.0.27-1.el6.noarch
katello-common-1.4.2-1.git.296.fb52d4c.el6.noarch
katello-headpin-1.4.2-1.git.296.fb52d4c.el6.noarch
katello-configure-1.4.3-1.git.10.7818db8.el6.noarch
candlepin-tomcat6-0.8.6-1.el6.noarch
katello-glue-elasticsearch-1.4.2-1.git.296.fb52d4c.el6.noarch
katello-cli-common-1.4.2-1.git.43.81cff0b.el6.noarch

[root@nightlyinstall ~]# headpin -u admin -p admin org create --name acme
Successfully created org [ acme ]
[root@nightlyinstall ~]# headpin -u admin -p admin environment create --name dev --org acme --prior Library                      
Successfully created environment [ dev ]
Comment 3 Tazim Kolhar 2013-05-10 09:01:32 EDT
the nightly was setup in morning my time and hence the fix was not available
during my time.

Ivan retried katello-configure again with fix

I have successful setup now 
Thanks

Note You need to log in before you can comment on or make changes to this bug.