Bug 961624 - Dashboard filter(s) in jBPM Dashboard need to be reconfigured for better clarity
Dashboard filter(s) in jBPM Dashboard need to be reconfigured for better clarity
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: BAM (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER2
: 6.0.0
Assigned To: Roger Martínez
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 01:58 EDT by Jan Hrcek
Modified: 2014-08-06 16:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Not all jBPM dashboard properties were displayed in the filter. Consequence: The filter does not show some properties being filtered, for example when applying chart drill down. Fix: Added all filtrable properties to the filter configuration Result: When applying chart drill down, filter always shows the property which is being filtered.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:08:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hrcek 2013-05-10 01:58:25 EDT
Description of problem:
Some properties that are displayed by KPI panels in jBPM Dashboard are not enabled in Dashboard filter panel.
As a result, it is possible to do drill down based on data displayed in KPI panels (e.g. click some date in chart "Tasks started by date")  BUT then there is no indication, that some filter is active. It is possible to clear the filter by clicking "Clear" in the Dashboard Filter panel to delete all filters - but this is not at all obvious, because no indication is given to the user, that some filter is active.

Version-Release number of selected component (if applicable):
6.0.0 DR4

How reproducible:
Always

Steps to Reproduce:
1. Download dashboard-builder from github and run quickstart demo as described in the "Quickstart" section
	cd dashboard-builder/scripts
	./buildandrun_h2.sh
2. Fill in the dashbuilder datasource with sample jBPM data (as described in  https://github.com/droolsjbpm/dashboard-builder/blob/master/modules/README.md#jbpm-process-dashboard)
3. Browse to http://localhost:8080/dashbuilder/ and login with root/root
4. Using administration menu at the top navigate to Workspace: jBPM Dashboard, Page: Process dashboard
5. Select some chart with property, that is not enabled in the Dashboard filter - e.g. in the panel "Number of task instances" click some bar (e.g. bar for Task 1).

  
Actual results:
The click on "Task 1" bar activates the drill-down, but the filtered property is not visible in the Dashboard filter. Now although the data displayed in some KPI panels are limited to only data related to Task 1, it is not indicated in the DashboardFilter that filter is active and no explicit way is given to the user to cancel the filter (browser back button doesn't work in this context) - only "Clear" button, but nothing points the user that he can use this button.

Expected results:
I see 2 possibilities:
1) the filter should be reconfigured to enable all the properties of the charts on the page, so that they are displayed in "Filtered properties" of the Dashboard Filter panel, when the drill-down is activated. I realize, that this would probably call for a bit larger reconfiguration of the application involving also the configuration of Data providers. Because there are some properties obtained from different Data providers that have the same name (e.g. both providers "jBPM Process Summary" and "jBPM Task Summary" contain property named "Start date" - in this case the properties should be renamed to "Process start date" and "Task start date" respectively).

2) the other option that I can imagine would be to put some generic indication, that some filter is activated even for properties, that are not enabled in the Dashboard filter. E.g.:
Filtered properties:
    filter is active
    (click Clear to cancel the filter)


Additional info:
Property names from jBPM related data providers should be revised for better clarity. For example "Name" should be renamed to "Process name" to avoid confusion with user name etc.
Comment 1 Roger Martínez 2013-07-19 11:34:02 EDT
Hi,

The property names for jBPM related data providers, they had been reviewed too and renamed for better clarity.

About filter properties:

- Actually we accept the first option: reconfigure filter properties. So, filter properties had been reconfigured and for the jBPM dashboard.

- About the second option, it's a good idea, a new feature request has been created in order to achieve that goal: display all filtered properties in a dashboard. See https://issues.jboss.org/browse/JBPM-4045

Regards,
Comment 3 Jan Hrcek 2013-09-06 04:34:44 EDT
Verified with BPMS 6.0.0 ER2
Comment 4 lcarlon 2013-09-23 21:14:15 EDT
Marked doc text as '-' as this is a new feature and should not be included in the resolved issues of the release notes.

Note You need to log in before you can comment on or make changes to this bug.