Bug 961629 - rpm: exit status 127 for glusterfs-georep
rpm: exit status 127 for glusterfs-georep
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterfs (Show other bugs)
2.1
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Avra Sengupta
Saurabh
:
Depends On:
Blocks: 850514
  Show dependency treegraph
 
Reported: 2013-05-10 02:27 EDT by Saurabh
Modified: 2016-01-19 01:11 EST (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.31rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:35:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-05-10 02:27:21 EDT
Description of problem:

[root@bigbend4 ~]# ./rpm-install.sh 
Retrieving http://download.devel.redhat.com/brewroot/packages/glusterfs/3.4.0.5rhs/1.el6rhs/x86_64/glusterfs-3.4.0.5rhs-1.el6rhs.x86_64.rpm
Preparing...                ########################################### [100%]
   1:glusterfs              ########################################### [100%]
Retrieving http://download.devel.redhat.com/brewroot/packages/glusterfs/3.4.0.5rhs/1.el6rhs/x86_64/glusterfs-fuse-3.4.0.5rhs-1.el6rhs.x86_64.rpm
Preparing...                ########################################### [100%]
   1:glusterfs-fuse         ########################################### [100%]
Retrieving http://download.devel.redhat.com/brewroot/packages/glusterfs/3.4.0.5rhs/1.el6rhs/x86_64/glusterfs-geo-replication-3.4.0.5rhs-1.el6rhs.x86_64.rpm
Preparing...                ########################################### [100%]
   1:glusterfs-geo-replicati########################################### [100%]
warning: %post(glusterfs-geo-replication-3.4.0.5rhs-1.el6rhs.x86_64) scriptlet failed, exit status 127
Retrieving http://download.devel.redhat.com/brewroot/packages/glusterfs/3.4.0.5rhs/1.el6rhs/x86_64/glusterfs-server-3.4.0.5rhs-1.el6rhs.x86_64.rpm
Preparing...                ########################################### [100%]
   1:glusterfs-server       ########################################### [100%]
Retrieving http://download.devel.redhat.com/brewroot/packages/glusterfs/3.4.0.5rhs/1.el6rhs/x86_64/glusterfs-rdma-3.4.0.5rhs-1.el6rhs.x86_64.rpm
Preparing...                ########################################### [100%]
   1:glusterfs-rdma         ########################################### [100%]
[root@bigbend4 ~]# 
[root@bigbend4 ~]# rpm -qa | grep glusterfs
glusterfs-server-3.4.0.5rhs-1.el6rhs.x86_64
glusterfs-3.4.0.5rhs-1.el6rhs.x86_64
glusterfs-geo-replication-3.4.0.5rhs-1.el6rhs.x86_64
glusterfs-rdma-3.4.0.5rhs-1.el6rhs.x86_64
org.apache.hadoop.fs.glusterfs-glusterfs-0.20.2_0.2-1.noarch
glusterfs-fuse-3.4.0.5rhs-1.el6rhs.x86_64
[root@bigbend4 ~]# 
[root@bigbend4 ~]# 
[root@bigbend4 ~]# cat rpm-install.sh 
#!/bin/bash

rpm -ivh http://download.devel.redhat.com/brewroot/packages/glusterfs/3.4.0.5rhs/1.el6rhs/x86_64/glusterfs-3.4.0.5rhs-1.el6rhs.x86_64.rpm
rpm -ivh http://download.devel.redhat.com/brewroot/packages/glusterfs/3.4.0.5rhs/1.el6rhs/x86_64/glusterfs-fuse-3.4.0.5rhs-1.el6rhs.x86_64.rpm
rpm -ivh http://download.devel.redhat.com/brewroot/packages/glusterfs/3.4.0.5rhs/1.el6rhs/x86_64/glusterfs-geo-replication-3.4.0.5rhs-1.el6rhs.x86_64.rpm
rpm -ivh http://download.devel.redhat.com/brewroot/packages/glusterfs/3.4.0.5rhs/1.el6rhs/x86_64/glusterfs-server-3.4.0.5rhs-1.el6rhs.x86_64.rpm
rpm -ivh http://download.devel.redhat.com/brewroot/packages/glusterfs/3.4.0.5rhs/1.el6rhs/x86_64/glusterfs-rdma-3.4.0.5rhs-1.el6rhs.x86_64.rpm
[root@bigbend4 ~]#
Comment 2 Amar Tumballi 2013-05-13 05:59:36 EDT
geo-rep RPMs are not yet ready for testing yet, and hence marking it as depends on for tracker bug.
Comment 4 Avra Sengupta 2013-09-06 03:10:56 EDT
Fixed in the latest version.
Comment 6 Scott Haines 2013-09-23 18:35:30 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.