Bug 961669 - removal of a brick from 1 x 2 replicate volume failed but the volume type is changed to distribute
removal of a brick from 1 x 2 replicate volume failed but the volume type is ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: glusterd (Show other bugs)
mainline
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Ravishankar N
:
: 957005 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 04:49 EDT by Ravishankar N
Modified: 2014-07-11 22:15 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-11 22:15:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ravishankar N 2013-05-10 04:49:45 EDT
Description of problem:

Tried to remove a brick from 1 x 2 replicate volume when one of the brick in the replicate volume is offline , the remove brick operation failed. But the volume type got changed to distribute. 

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.Create a 1 x 2 replicate volume. (2 storage nodes and 1 brick on each node)

2.create fuse mount. create files and directories from mount point.
 
3.Bring down brick2 offline.

4.Try to remove the online brick. 
  
Actual results:
The remove brick operation fails when gluster remove-brick 'commit' is given. But the volume type got changed to "Distribute"

Expected results:
The volume type should not change when the remove brick operation itself has failed.

Additional info:
Reference:Bug 923135
Comment 1 Anand Avati 2013-05-10 04:55:51 EDT
REVIEW: http://review.gluster.org/4975 (glusterd: remove-brick: prevent removal from a replicate volume.) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 2 Anand Avati 2013-05-13 01:54:04 EDT
REVIEW: http://review.gluster.org/4975 (glusterd: remove-brick: prevent removal from a replicate volume.) posted (#3) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 3 Anand Avati 2013-05-13 04:33:48 EDT
COMMIT: http://review.gluster.org/4975 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 0d415f7f8c08edc7b7af88567bb5ec4803defc94
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Thu May 9 16:14:33 2013 +0000

    glusterd: remove-brick: prevent removal from a replicate volume.
    
    Prevent the removal of brick(s) from a plain replicate volume and
    display the error message at the CLI.
    
    Change-Id: I8e182404564147329d8cd364b7c7931d19f14570
    BUG: 961669
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/4975
    Reviewed-by: Vijay Bellur <vbellur@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 4 Anand Avati 2013-07-04 08:25:33 EDT
REVIEW: http://review.gluster.org/5289 (glusterd: add conditional checks for remove-brick in a replicate volume) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 6 Anand Avati 2013-07-19 09:29:31 EDT
REVIEW: http://review.gluster.org/5364 (glusterd: add conditional checks for remove-brick in a dist-rep volume) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 7 Anand Avati 2013-08-12 00:24:04 EDT
REVIEW: http://review.gluster.org/5566 (glusterd: add check in remove-brick start variant) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 8 Anand Avati 2013-08-21 13:46:41 EDT
COMMIT: http://review.gluster.org/5566 committed in master by Anand Avati (avati@redhat.com) 
------
commit 51c6fa7a354826744de98a1c5c747955ae65850c
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Fri Jul 19 14:23:32 2013 +0000

    glusterd: add check in remove-brick start variant
    
    The 'start' variant of the remove-brick command only applies at the dht
    level wherein we can remove  all the bricks of a sub-volume (and remove
    multiple such sub-volumes) but not select bricks of it.
    
    This patch disallows removing individual replica bricks of multiple
    sub-volumes (i.e. reducing the replcia count of the volume) using
    remove-brick 'start'. The preferred method for such an operation is to use
    commit force.
    
    This patch also reverts the check to prevent removal of bricks from a
    replicate volume (commit 0d415f7)
    
    BUG: 961669
    Change-Id: I447ad27f73a0963b5e09fb317bf7267a7a5a6147
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/5566
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 9 Anand Avati 2013-09-25 05:00:45 EDT
REVIEW: http://review.gluster.org/6001 (glusterd: refactoring patch for Bug ID: 961669) posted (#1) for review on master by susant palai (spalai@redhat.com)
Comment 10 Anand Avati 2013-09-25 05:12:00 EDT
REVIEW: http://review.gluster.org/6001 (glusterd: refactoring patch for Bug ID: 961669) posted (#2) for review on master by susant palai (spalai@redhat.com)
Comment 11 Anand Avati 2013-09-25 05:15:51 EDT
REVIEW: http://review.gluster.org/6001 (glusterd: refactoring patch for Bug ID: 961669) posted (#3) for review on master by susant palai (spalai@redhat.com)
Comment 13 Niels de Vos 2014-07-11 12:01:26 EDT
*** Bug 957005 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.