Bug 961681 - nfs: showmount fails to give the information
nfs: showmount fails to give the information
Status: CLOSED CURRENTRELEASE
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
high Severity high
: ---
: ---
Assigned To: rjoseph
Saurabh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 05:20 EDT by Saurabh
Modified: 2016-01-19 01:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-14 08:18:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-05-10 05:20:40 EDT
Description of problem:
showmount <ip or hostname of server>
gives the response with the ip of the clients that have nfs mount from the server.

Version-Release number of selected component (if applicable):
glusterfs-3.4.0.5rhs-1.el6rhs.x86_64

How reproducible:
alwyas, on this build, not earlier

Steps to Reproduce:
1. create a volume , start a volume using rhs nodes (a b c d)
2. nfs mount the volume from node "a" on clients (c1 c2)
3. showmount <ip of "a"> on any machine
  
Actual results:
should display the list of clients that mounts,

[root@bigbend1 ~]# showmount 10.70.37.155
Hosts on 10.70.37.155:


Expected results:
in similar fashion as kernel nfs mount does it,
[root@rhel6 ~]# showmount 10.70.34.114
Hosts on 10.70.34.114:
10.10.49.184
10.10.49.32
10.10.49.38
10.10.50.112
10.10.51.149
10.10.52.106
10.10.52.127
10.10.53.171
10.10.53.79
10.10.61.144
10.16.70.11


Additional info:
Comment 2 rjoseph 2013-05-21 06:31:40 EDT
Tested on the latest code and glusterfs-3.4.0.8rhs-1.el6rhs.x86_64 both of them shows the correct behaviour.
Bug is not reproduced.

Apart from mounting any other operation should I do to reproduce the problem?
Comment 3 rjoseph 2013-05-22 03:05:57 EDT
Working fine on latest build.
Comment 4 rjoseph 2013-06-05 06:16:01 EDT
In the following test I am able reproduce the bug.

1. create a volume , start a volume using rhs nodes (a b c d)
2. nfs mount the volume from node "a" on clients (c1 c2)
3. showmount <ip of "a"> on any machine 
      --> This works fine shows IP of c1 and c2

Let's say on c1 nfs is mounted on /mnt/c1 and on c2 /mnt/c2
4. cd /mnt/c1 on c1
5. umount /mnt/c1 on c1 
      ---> Here unmount will with "device is busy"
6. check showmount <ip pf "a">   
      ---> c1 is removed from the entry even though it is still mounted.


The problem is that NFS client is sending unmount even if the client fails with "device is busy". 
The same behaviour can be seen in NFS kernel implementation.

Note You need to log in before you can comment on or make changes to this bug.