Bug 961706 - Auto install RHEV-H failed with "storage_init=/dev/sda,/dev/sda" parameter.
Auto install RHEV-H failed with "storage_init=/dev/sda,/dev/sda" parameter.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.4
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 06:45 EDT by haiyang,dong
Modified: 2014-01-21 14:33 EST (History)
14 users (show)

See Also:
Fixed In Version: ovirt-node-3.0.1-5.el6
Doc Type: Bug Fix
Doc Text:
The hypervisor failed to install when multiple devices were used. The cause of this was that sometimes, the canonical name of a device wasn't used. The canonical name of a device is now used everywhere, so the hypervisor can now be installed successfully with multiple devices.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 14:33:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached the ovirt.log (14.66 KB, application/octet-stream)
2013-05-10 06:45 EDT, haiyang,dong
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17477 None None None Never

  None (edit)
Description haiyang,dong 2013-05-10 06:45:08 EDT
Created attachment 746052 [details]
attached the ovirt.log

Description of problem:
Auto install RHEV-H will success with the follow parameter:
BOOTIF=eth0 storage_init=/dev/mapper/1ATA*9911,/dev/mapper/1ATA*9911 firstboot

so it also should be successful with follow parameter:
BOOTIF=eth0 storage_init=/dev/sda,/dev/sda firstboot

but actually it failed with "storage_init=/dev/sda,/dev/sda" parameter

maybe the root cause happen in the line 73 of the follow code in storage.py
 55         if "OVIRT_INIT" in OVIRT_VARS:
 56             OVIRT_VARS["OVIRT_INIT"] = OVIRT_VARS["OVIRT_INIT"].strip(",")
 57             if "," in OVIRT_VARS["OVIRT_INIT"]:
 58                 disk_count = 0
 59                 init = OVIRT_VARS["OVIRT_INIT"].strip(",").split(",")
 60                 for disk in init:
 61                     skip = False
 62                     if disk_count < 1:
 63                         self.ROOTDRIVE = translate_multipath_device(disk)
 64                         if len(init) == 1:
 65                             self.HOSTVGDRIVE = translate_multipath_device(disk)
 66                         disk_count = disk_count + 1
 67                     else:
 68                         for hostvg in self.HOSTVGDRIVE.split(","):
 69                             if hostvg == disk:
 70                                 skip = True
 71                                 break
 72                         if not skip:
 73                             self.HOSTVGDRIVE += "%s," % disk
 74             else:
 75                 self.ROOTDRIVE = translate_multipath_device(
 76                                     OVIRT_VARS["OVIRT_INIT"])
 77                 self.HOSTVGDRIVE = translate_multipath_device(
 78                                     OVIRT_VARS["OVIRT_INIT"])

changing it into the follow code can resole this issue:

 55         if "OVIRT_INIT" in OVIRT_VARS:
 56             OVIRT_VARS["OVIRT_INIT"] = OVIRT_VARS["OVIRT_INIT"].strip(",")
 57             if "," in OVIRT_VARS["OVIRT_INIT"]:
 58                 disk_count = 0
 59                 init = OVIRT_VARS["OVIRT_INIT"].strip(",").split(",")
 60                 for disk in init:
 61                     skip = False
 62                     translated_disk = translate_multipath_device(disk) 
 63                     if disk_count < 1:
 64                         self.ROOTDRIVE = translated_disk
 65                         if len(init) == 1:
 66                             self.HOSTVGDRIVE = translated_disk
 67                         disk_count = disk_count + 1
 68                     else:
 69                         for hostvg in self.HOSTVGDRIVE.split(","):
 70                             if hostvg == translated_disk:
 71                                 skip = True
 72                                 break
 73                         if not skip:
 74                             self.HOSTVGDRIVE += "%s," % translated_disk
 75             else:
 76                 self.ROOTDRIVE = translate_multipath_device(
 77                                     OVIRT_VARS["OVIRT_INIT"])
 78                 self.HOSTVGDRIVE = translate_multipath_device(
 79                                     OVIRT_VARS["OVIRT_INIT"])



Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.4-20130501.0.el6_4

How reproducible:
100% 
 
Steps to Reproduce:
1.Auto install rhev-h with 
with "BOOTIF=eth0 storage_init=/dev/sda,/dev/sda firstboot" parameter

Actual result:
After Step 1, Auto install RHEV-H failed with "storage_init=/dev/sda,/dev/sda" parameter          
                                                  
Expect result:
Because Auto install RHEV-H will success with "storage_init=/dev/mapper/1ATA*9911,/dev/mapper/1ATA*9911" parameter,
so it also should be successful with "storage_init=/dev/sda,/dev/sda" parameter.

Additional info:
Comment 2 RHEL Product and Program Management 2013-10-13 23:37:05 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 5 haiyang,dong 2013-10-21 22:17:53 EDT
Test version:
rhev-hypervisor6-6.5-20131017.0.iso
ovirt-node-3.0.1-4.el6

auto install was successful with follow parameter:
BOOTIF=eth0 storage_init=/dev/sda,/dev/sda firstboot
so this bug has been fixed.
Comment 7 haiyang,dong 2013-10-27 02:20:53 EDT
Test version:
rhevh-6.5-20131024.1.0.iso
ovirt-node-3.0.1-6.el6.noarch

auto install was successful with follow parameter:
BOOTIF=eth0 storage_init=/dev/sda,/dev/sda firstboot

so this bug has been fixed, change it into "VERIFIED".
Comment 9 Cheryn Tan 2013-11-07 19:29:50 EST
This bug is currently attached to errata RHBA-2013:15277. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 12 errata-xmlrpc 2014-01-21 14:33:46 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0033.html

Note You need to log in before you can comment on or make changes to this bug.