Bug 961728 - SELinux is preventing /usr/sbin/httpd from 'remove_name' accesses on the directory apr-tmp.TXcwOM.
SELinux is preventing /usr/sbin/httpd from 'remove_name' accesses on the dire...
Status: CLOSED DUPLICATE of bug 961710
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d639a0a89a68bcf9f8aa8033fb0...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 06:56 EDT by Nicolas Mailhot
Modified: 2013-05-10 11:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-10 11:24:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2013-05-10 06:56:00 EDT
Description of problem:
SELinux is preventing /usr/sbin/httpd from 'remove_name' accesses on the directory apr-tmp.TXcwOM.

*****  Plugin catchall (100. confidence) suggests  ***************************

If vous pensez que httpd devrait être autorisé à accéder remove_name sur apr-tmp.TXcwOM directory par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep httpd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:certwatch_t:s0-s0:c0.c1023
Target Context                system_u:object_r:tmp_t:s0
Target Objects                apr-tmp.TXcwOM [ dir ]
Source                        httpd
Source Path                   /usr/sbin/httpd
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           httpd-2.4.4-5.fc20.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-41.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.0-0.rc0.git21.1.fc20.x86_64
                              #1 SMP Tue May 7 19:47:51 UTC 2013 x86_64 x86_64
Alert Count                   3
First Seen                    2013-05-08 12:36:02 CEST
Last Seen                     2013-05-10 03:10:02 CEST
Local ID                      ba81af64-4216-4329-a30e-7f014e3d3bd1

Raw Audit Messages
type=AVC msg=audit(1368148202.170:9358): avc:  denied  { remove_name } for  pid=1593 comm="httpd" name="apr-tmp.TXcwOM" dev="tmpfs" ino=2494533 scontext=system_u:system_r:certwatch_t:s0-s0:c0.c1023 tcontext=system_u:object_r:tmp_t:s0 tclass=dir


type=AVC msg=audit(1368148202.170:9358): avc:  denied  { unlink } for  pid=1593 comm="httpd" name="apr-tmp.TXcwOM" dev="tmpfs" ino=2494533 scontext=system_u:system_r:certwatch_t:s0-s0:c0.c1023 tcontext=system_u:object_r:tmp_t:s0 tclass=file


type=SYSCALL msg=audit(1368148202.170:9358): arch=x86_64 syscall=unlink success=yes exit=0 a0=7fd4216b1d88 a1=7fd4216b1d10 a2=7fd41eca9a10 a3=7fffffcc3a90 items=0 ppid=1592 pid=1593 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=318 tty=(none) comm=httpd exe=/usr/sbin/httpd subj=system_u:system_r:certwatch_t:s0-s0:c0.c1023 key=(null)

Hash: httpd,certwatch_t,tmp_t,dir,remove_name

audit2allow

#============= certwatch_t ==============
allow certwatch_t tmp_t:dir remove_name;
allow certwatch_t tmp_t:file unlink;

audit2allow -R
require {
	type tmp_t;
	type certwatch_t;
	class file unlink;
}

#============= certwatch_t ==============
allow certwatch_t tmp_t:file unlink;
files_delete_tmp_dir_entry(certwatch_t)


Additional info:
hashmarkername: setroubleshoot
kernel:         3.10.0-0.rc0.git24.1.fc20.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-10 11:24:21 EDT

*** This bug has been marked as a duplicate of bug 961710 ***

Note You need to log in before you can comment on or make changes to this bug.