Bug 961734 - SELinux is preventing /usr/sbin/httpd from read, execute access on the file /usr/sbin/suexec.
SELinux is preventing /usr/sbin/httpd from read, execute access on the file /...
Status: CLOSED DUPLICATE of bug 961710
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:a6d7b522365601c5eb276719a2f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 06:56 EDT by Nicolas Mailhot
Modified: 2013-05-10 11:24 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-10 11:24:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2013-05-10 06:56:42 EDT
Description of problem:
SELinux is preventing /usr/sbin/httpd from read, execute access on the file /usr/sbin/suexec.

*****  Plugin catchall (100. confidence) suggests  ***************************

If vous pensez que httpd devrait être autorisé à accéder read execute sur suexec file par défaut.
Then vous devriez rapporter ceci en tant qu'anomalie.
Vous pouvez générer un module de stratégie local pour autoriser cet accès.
Do
autoriser cet accès pour le moment en exécutant :
# grep httpd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:certwatch_t:s0-s0:c0.c1023
Target Context                system_u:object_r:httpd_suexec_exec_t:s0
Target Objects                /usr/sbin/suexec [ file ]
Source                        httpd
Source Path                   /usr/sbin/httpd
Port                          <Inconnu>
Host                          (removed)
Source RPM Packages           httpd-2.4.4-5.fc20.x86_64
Target RPM Packages           httpd-2.4.4-5.fc20.x86_64
Policy RPM                    selinux-policy-3.12.1-41.fc20.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.10.0-0.rc0.git21.1.fc20.x86_64
                              #1 SMP Tue May 7 19:47:51 UTC 2013 x86_64 x86_64
Alert Count                   3
First Seen                    2013-05-08 12:36:03 CEST
Last Seen                     2013-05-10 03:10:03 CEST
Local ID                      3f43e979-1b47-4dea-84c6-26564c2f1cc5

Raw Audit Messages
type=AVC msg=audit(1368148203.142:9360): avc:  denied  { read execute } for  pid=1593 comm="httpd" name="suexec" dev="dm-0" ino=2815277 scontext=system_u:system_r:certwatch_t:s0-s0:c0.c1023 tcontext=system_u:object_r:httpd_suexec_exec_t:s0 tclass=file


type=SYSCALL msg=audit(1368148203.142:9360): arch=x86_64 syscall=access success=yes exit=0 a0=7fd41711bb13 a1=5 a2=14fdf a3=1 items=0 ppid=1592 pid=1593 auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=318 tty=(none) comm=httpd exe=/usr/sbin/httpd subj=system_u:system_r:certwatch_t:s0-s0:c0.c1023 key=(null)

Hash: httpd,certwatch_t,httpd_suexec_exec_t,file,read,execute

audit2allow

#============= certwatch_t ==============
allow certwatch_t httpd_suexec_exec_t:file { read execute };

audit2allow -R
require {
	type certwatch_t;
}

#============= certwatch_t ==============
apache_exec_suexec(certwatch_t)


Additional info:
hashmarkername: setroubleshoot
kernel:         3.10.0-0.rc0.git24.1.fc20.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-10 11:24:34 EDT

*** This bug has been marked as a duplicate of bug 961710 ***

Note You need to log in before you can comment on or make changes to this bug.