Bug 961777 - [abrt] [ INFO: possible recursive locking detected ]
[abrt] [ INFO: possible recursive locking detected ]
Status: CLOSED DUPLICATE of bug 958937
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:bf28d76ed2fbd3686f5d95a8f29...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 07:08 EDT by Nicolas Mailhot
Modified: 2013-05-13 21:29 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 21:29:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dmesg (190.52 KB, text/plain)
2013-05-10 07:08 EDT, Nicolas Mailhot
no flags Details

  None (edit)
Description Nicolas Mailhot 2013-05-10 07:08:33 EDT
Additional info:
[ INFO: possible recursive locking detected ]
3.10.0-0.rc0.git24.1.fc20.x86_64 #1 Not tainted
---------------------------------------------
pulseaudio/1124 is trying to acquire lock:
 (&(&substream->self_group.lock)->rlock/1){......}, at: [<ffffffffa01e14f3>] snd_pcm_action_group+0xa3/0x240 [snd_pcm]
but task is already holding lock:
 (&(&substream->self_group.lock)->rlock/1){......}, at: [<ffffffffa01e14f3>] snd_pcm_action_group+0xa3/0x240 [snd_pcm]
other info that might help us debug this:
 Possible unsafe locking scenario:
       CPU0
       ----
  lock(&(&substream->self_group.lock)->rlock/1);
  lock(&(&substream->self_group.lock)->rlock/1);
 *** DEADLOCK ***
 May be due to missing lock nesting notation
4 locks held by pulseaudio/1124:
 #0:  (snd_pcm_link_rwlock){......}, at: [<ffffffffa01e31c7>] snd_pcm_drop+0x57/0xe0 [snd_pcm]
 #1:  (&(&substream->self_group.lock)->rlock){......}, at: [<ffffffffa01e31cf>] snd_pcm_drop+0x5f/0xe0 [snd_pcm]
 #2:  (&(&substream->group->lock)->rlock){......}, at: [<ffffffffa01e2ff1>] snd_pcm_action+0x31/0xa0 [snd_pcm]
 #3:  (&(&substream->self_group.lock)->rlock/1){......}, at: [<ffffffffa01e14f3>] snd_pcm_action_group+0xa3/0x240 [snd_pcm]
stack backtrace:
CPU: 1 PID: 1124 Comm: pulseaudio Not tainted 3.10.0-0.rc0.git24.1.fc20.x86_64 #1
Hardware name: Gigabyte Technology Co., Ltd. EP45-DS5/EP45-DS5, BIOS F12 09/30/2008
 ffff8801082c4dc0 ffff880097b53be0 ffffffff81719788 ffff880097b53ca0
 ffffffff810db2ef 0000000000005d30 000000010000000c 0000000100000000
 00025c9200000000 4b925d131098a4c5 ffffffff82213400 ffff8801082c5790
Call Trace:
 [<ffffffff81719788>] dump_stack+0x19/0x1b
 [<ffffffff810db2ef>] __lock_acquire+0x1a1f/0x1b30
 [<ffffffff810d9bc5>] ? __lock_acquire+0x2f5/0x1b30
 [<ffffffff810dbbf2>] lock_acquire+0xa2/0x1f0
 [<ffffffffa01e14f3>] ? snd_pcm_action_group+0xa3/0x240 [snd_pcm]
 [<ffffffff81721164>] _raw_spin_lock_nested+0x44/0x80
 [<ffffffffa01e14f3>] ? snd_pcm_action_group+0xa3/0x240 [snd_pcm]
 [<ffffffffa01e14f3>] snd_pcm_action_group+0xa3/0x240 [snd_pcm]
 [<ffffffffa01e3024>] snd_pcm_action+0x64/0xa0 [snd_pcm]
 [<ffffffffa01e31f0>] snd_pcm_drop+0x80/0xe0 [snd_pcm]
 [<ffffffffa01e4d98>] snd_pcm_common_ioctl1+0x8d8/0xbe0 [snd_pcm]
 [<ffffffff812eb85d>] ? avc_has_perm_flags+0x16d/0x350
 [<ffffffff812eb719>] ? avc_has_perm_flags+0x29/0x350
 [<ffffffffa01e5233>] snd_pcm_playback_ioctl1+0x193/0x2a0 [snd_pcm]
 [<ffffffffa01e5370>] snd_pcm_playback_ioctl+0x30/0x40 [snd_pcm]
 [<ffffffff811efe05>] do_vfs_ioctl+0x305/0x530
 [<ffffffff812ee1eb>] ? selinux_file_ioctl+0x5b/0x110
 [<ffffffff811f00b1>] SyS_ioctl+0x81/0xa0
 [<ffffffff8172afd9>] system_call_fastpath+0x16/0x1b
Comment 1 Nicolas Mailhot 2013-05-10 07:08:40 EDT
Created attachment 746124 [details]
File: dmesg
Comment 2 Nikola Pajkovsky 2013-05-13 21:29:51 EDT

*** This bug has been marked as a duplicate of bug 958937 ***

Note You need to log in before you can comment on or make changes to this bug.