Bug 961793 - MultiApp demo exception during deployment
MultiApp demo exception during deployment
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Examples (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity high
: ER6
: ---
Assigned To: Keith Babo
Jiri Sedlacek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 08:12 EDT by Pavel Drozd
Modified: 2015-08-02 19:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
If the user deploys the order-service part of the MultiApp demo, they will encounter a SwitchYard Start Service exception.
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Drozd 2013-05-10 08:12:42 EDT
Description of problem:
Exception occurs during deployment of the order-customer part of multiApp

Steps to Reproduce:
1. Deploy each of the following to a SwitchYard AS7 runtime:
    * multiApp/artifacts/target/OrderService.jar
    * multiApp/order-service/target/switchyard-quickstart-demo-multi-order-service.jar
    * multiApp/order-consumer/target/switchyard-quickstart-demo-multi-order-consumer.jar
    * multiApp/web/target/switchyard-quickstart-demo-multi-web.war   

Actual results:
0m13:43:57,295 INFO  [org.switchyard.common.camel.SwitchYardCamelContext] (MSC service thread 1-3) Apache Camel 0.8.1.Final (CamelContext: camel-6) is shutdown in 0.015 seconds. Uptime 0.431 seconds.
[0m[31m13:43:57,296 ERROR [org.jboss.msc.service.fail] (MSC service thread 1-3) MSC000001: Failed to start service jboss.deployment.unit."switchyard-quickstart-demo-multi-order-service.jar".SwitchYardService: org.jboss.msc.service.StartException in service jboss.deployment.unit."switchyard-quickstart-demo-multi-order-service.jar".SwitchYardService: org.switchyard.component.soap.WebServicePublishException: javax.xml.ws.WebServiceException: JBWS022087: Failed to read vfs:/content/OrderService.jar/orderTypes.xsd: JBWS022088: Unexpected element parsing vfs:/content/OrderService.jar/orderTypes.xsd: schema
	at org.switchyard.as7.extension.services.SwitchYardService.start(SwitchYardService.java:85)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746) [jboss-msc-1.0.4.GA-redhat-1.jar:1.0.4.GA-redhat-1]
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110) [rt.jar:1.7.0_09]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603) [rt.jar:1.7.0_09]
	at java.lang.Thread.run(Thread.java:722) [rt.jar:1.7.0_09]
Caused by: org.switchyard.component.soap.WebServicePublishException: javax.xml.ws.WebServiceException: JBWS022087: Failed to read vfs:/content/OrderService.jar/orderTypes.xsd: JBWS022088: Unexpected element parsing vfs:/content/OrderService.jar/orderTypes.xsd: schema
	at org.switchyard.component.soap.endpoint.JBossWSEndpointPublisher.publish(JBossWSEndpointPublisher.java:73)
	at org.switchyard.component.soap.InboundHandler.start(InboundHandler.java:104)
	at org.switchyard.deploy.internal.Deployment.deployServiceBindings(Deployment.java:520)
	at org.switchyard.deploy.internal.Deployment.start(Deployment.java:141)
	at org.switchyard.as7.extension.deployment.SwitchYardDeployment.start(SwitchYardDeployment.java:106)
	at org.switchyard.as7.extension.services.SwitchYardService.start(SwitchYardService.java:78)
	... 5 more
Caused by: javax.xml.ws.WebServiceException: JBWS022087: Failed to read vfs:/content/OrderService.jar/orderTypes.xsd: JBWS022088: Unexpected element parsing vfs:/content/OrderService.jar/orderTypes.xsd: schema
	at org.jboss.ws.common.deployment.SOAPAddressWSDLParser.parse(SOAPAddressWSDLParser.java:140)
	at org.jboss.ws.common.deployment.SOAPAddressWSDLParser.parse(SOAPAddressWSDLParser.java:121)
	at org.jboss.ws.common.deployment.SOAPAddressWSDLParser.<init>(SOAPAddressWSDLParser.java:81)
	at org.jboss.wsf.stack.cxf.metadata.MetadataBuilder.getCurrentSOAPAddressWSDLParser(MetadataBuilder.java:305)
	at org.jboss.wsf.stack.cxf.metadata.MetadataBuilder.processAddressRewrite(MetadataBuilder.java:281)
	at org.jboss.wsf.stack.cxf.metadata.MetadataBuilder.build(MetadataBuilder.java:89)
	at org.jboss.wsf.stack.cxf.deployment.aspect.DescriptorDeploymentAspect.generateMetadataFromDeployment(DescriptorDeploymentAspect.java:141)
	at org.jboss.wsf.stack.cxf.deployment.aspect.DescriptorDeploymentAspect.start(DescriptorDeploymentAspect.java:75)
	at org.jboss.ws.common.deployment.DeploymentAspectManagerImpl.deploy(DeploymentAspectManagerImpl.java:131)
	at org.jboss.as.webservices.publish.EndpointPublisherImpl.publish(EndpointPublisherImpl.java:123)
	at org.jboss.as.webservices.publish.EndpointPublisherImpl.publish(EndpointPublisherImpl.java:102)
	at org.jboss.as.webservices.publish.EndpointPublisherImpl.publish(EndpointPublisherImpl.java:95)
	at org.switchyard.component.soap.endpoint.JBossWSEndpoint.publish(JBossWSEndpoint.java:74)
	at org.switchyard.component.soap.endpoint.JBossWSEndpointPublisher.publish(JBossWSEndpointPublisher.java:68)
	... 10 more
Caused by: java.lang.IllegalStateException: JBWS022088: Unexpected element parsing vfs:/content/OrderService.jar/orderTypes.xsd: schema
	at org.jboss.ws.common.deployment.SOAPAddressWSDLParser.parse(SOAPAddressWSDLParser.java:179)
	at org.jboss.ws.common.deployment.SOAPAddressWSDLParser.parse(SOAPAddressWSDLParser.java:136)
	... 23 more

[0m[31m13:43:57,304 ERROR [org.jboss.as.server] (DeploymentScanner-threads - 1) JBAS015870: Deploy of deployment "switchyard-quickstart-demo-multi-order-service.jar" was rolled back with the following failure message: 
{"JBAS014671: Failed services" => {"jboss.deployment.unit.\"switchyard-quickstart-demo-multi-order-service.jar\".SwitchYardService" => "org.jboss.msc.service.StartException in service jboss.deployment.unit.\"switchyard-quickstart-demo-multi-order-service.jar\".SwitchYardService: org.switchyard.component.soap.WebServicePublishException: javax.xml.ws.WebServiceException: JBWS022087: Failed to read vfs:/content/OrderService.jar/orderTypes.xsd: JBWS022088: Unexpected element parsing vfs:/content/OrderService.jar/orderTypes.xsd: schema
    Caused by: org.switchyard.component.soap.WebServicePublishException: javax.xml.ws.WebServiceException: JBWS022087: Failed to read vfs:/content/OrderService.jar/orderTypes.xsd: JBWS022088: Unexpected element parsing vfs:/content/OrderService.jar/orderTypes.xsd: schema
    Caused by: javax.xml.ws.WebServiceException: JBWS022087: Failed to read vfs:/content/OrderService.jar/orderTypes.xsd: JBWS022088: Unexpected element parsing vfs:/content/OrderService.jar/orderTypes.xsd: schema
    Caused by: java.lang.IllegalStateException: JBWS022088: Unexpected element parsing vfs:/content/OrderService.jar/orderTypes.xsd: schema"}}
Comment 1 Pavel Drozd 2013-05-15 03:18:46 EDT
Correction:
Exception occurs during deployment of the order-service part of multiApp
Comment 5 Anne-Louise Tangring 2013-11-11 13:10:42 EST
Re-test, please.
Comment 6 Pavel Drozd 2013-11-12 04:57:10 EST
Verified in ER6

Note You need to log in before you can comment on or make changes to this bug.