Bug 961798 - Missing keyboard mappings for Finnish keyboard
Missing keyboard mappings for Finnish keyboard
Status: CLOSED DUPLICATE of bug 956686
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.1.0
All Windows
unspecified Severity medium
: ---
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 08:16 EDT by Ken Booth
Modified: 2015-09-22 09 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-10 08:30:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken Booth 2013-05-10 08:16:09 EDT
Description of problem:
  When using the Windows 7 Spice client connecting to a RHEL guest, the Finnish keys are not mapped correctly.

Version-Release number of selected component (if applicable):
  Spice client says its version is "Virtual Machine Viewer 0.5.3"

How reproducible:
  100%

Steps to Reproduce:
1. Install Windows 7 on a guest or bare-metal system
2. Install RHEL 6.4 guest in RHEV
3. Use the physical console on the Windows 7 system (or Spice console from Fedora) - Do NOT use rdekstop
4. Add Finnish keyboard in the Windows control panel
5. Start Notepad and then select Finnish on the Windows task bar
6. Verify that the correct Finnish characters appear when pressing appropriate key combinations
7. Use IE9/IE10 to connect to RHEV
8. Start a SPICE console on a RHEL 6.4 guest
9. Run system-config-keyboard and set the keyboard as Finnish-Latin1
10. Open a GUI text editor (or even gnome-termina)
11. Verify that the Finnish characters dont appear when pressing appropriate key combinations
  
Actual results:
Pressing right-Alt-Gr with 2,7,8,9,0, the key right of zero, the key left of RETURN on the same line as QWERTY, and the key right of the Left-SHIFT, produces no characters
Pressing right-Alt-Gr with 5 produces a character with unicode coding 0xe280b0

Expected results:
Pressing right-Alt-Gr with 2,7,8,9,0, the key right of zero, the key left of RETURN on the same line as QWERTY, and the key right of the Left-SHIFT, should produce @ { [ ] } \ ~ |
Pressing right-Alt-Gr with 5 should produce the Euro symbol


Additional info:
Comment 1 Marc-Andre Lureau 2013-05-10 08:30:39 EDT
this is a dup of 956686

*** This bug has been marked as a duplicate of bug 956686 ***

Note You need to log in before you can comment on or make changes to this bug.