Bug 961922 - Error updating topic using the new UI: You have entered some invalid input
Error updating topic using the new UI: You have entered some invalid input
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: pressgang-ccms-dev
sgilda
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 14:35 EDT by sgilda
Modified: 2013-05-29 17:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-29 17:07:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sgilda 2013-05-10 14:35:37 EDT
Description of problem:
To recreate:
Edit topic 14154 (http://skynet.usersys.redhat.com:8080/pressgang-ccms-ui/#SearchResultsAndTopicView;query;topicIds=14154)
Remove the extra word 'to' in this sentence: "The WebLogic <filename>plan.xml</filename> deployment descriptor file to provides a way"..
Click 'Save'
I get an Error dialog box with the following text, yet I am able to save changes in the old UI.

Error dialog text:
You have entered some invalid input. This is usually because a mandatory field is missing, or a unique field has been duplicated. The message below provides more information.

<html><head><title>JBoss Web/7.0.13.Final - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 400 - org.codehaus.jackson.map.exc.UnrecognizedPropertyException: Unrecognized field &quot;contentSpecs_OTM&quot; (Class org.jboss.pressgang.ccms.rest.v1.entities.RESTTopicV1), not marked as ignorable
 at [Source: org.apache.catalina.connector.CoyoteInputStream@59f931cb; line: 1, column: 269] (through reference chain: org.jboss.pressgang.ccms.rest.v1.entities.RESTTopicV1[&quot;contentSpecs_OTM&quot;])</h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u>org.codehaus.jackson.map.exc.UnrecognizedPropertyException: Unrecognized field &quot;contentSpecs_OTM&quot; (Class org.jboss.pressgang.ccms.rest.v1.entities.RESTTopicV1), not marked as ignorable
 at [Source: org.apache.catalina.connector.CoyoteInputStream@59f931cb; line: 1, column: 269] (through reference chain: org.jboss.pressgang.ccms.rest.v1.entities.RESTTopicV1[&quot;contentSpecs_OTM&quot;])</u></p><p><b>description</b> <u>The request sent by the client was syntactically incorrect (org.codehaus.jackson.map.exc.UnrecognizedPropertyException: Unrecognized field &quot;contentSpecs_OTM&quot; (Class org.jboss.pressgang.ccms.rest.v1.entities.RESTTopicV1), not marked as ignorable
 at [Source: org.apache.catalina.connector.CoyoteInputStream@59f931cb; line: 1, column: 269] (through reference chain: org.jboss.pressgang.ccms.rest.v1.entities.RESTTopicV1[&quot;contentSpecs_OTM&quot;])).</u></p><HR size="1" noshade="noshade"><h3>JBoss Web/7.0.13.Final</h3></body></html>
Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthew Casperson 2013-05-10 21:48:54 EDT
Fixed in 201305111136

It looks like the REST server was updated with a version that did not include the content spec classes. The UI was still using a version of the library that did include these classes.

I have removed all reference to the content spec classes in the UI code, which should fix this issue.
Comment 2 sgilda 2013-05-13 08:08:30 EDT
Tested this fix and it works fine.

Note You need to log in before you can comment on or make changes to this bug.