Bug 962031 - IOError: [Errno 30] Read-only file system: '/mnt/sysimage/anaconda-yum.yumtx'
IOError: [Errno 30] Read-only file system: '/mnt/sysimage/anaconda-yum.yumtx'
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
abrt_hash:bdc7207392575689493cd1815e6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-10 23:54 EDT by Reartes Guillermo
Modified: 2013-05-14 20:35 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-14 20:35:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda.log (76.51 KB, text/plain)
2013-05-10 23:54 EDT, Reartes Guillermo
no flags Details
File: backtrace (709 bytes, text/plain)
2013-05-10 23:54 EDT, Reartes Guillermo
no flags Details
File: environ (760 bytes, text/plain)
2013-05-10 23:54 EDT, Reartes Guillermo
no flags Details
File: ifcfg.log (567 bytes, text/plain)
2013-05-10 23:54 EDT, Reartes Guillermo
no flags Details
File: lsblk_output (4.89 KB, text/plain)
2013-05-10 23:54 EDT, Reartes Guillermo
no flags Details
File: nmcli_dev_list (3.31 KB, text/plain)
2013-05-10 23:54 EDT, Reartes Guillermo
no flags Details
File: packaging.log (789.15 KB, text/plain)
2013-05-10 23:54 EDT, Reartes Guillermo
no flags Details
File: program.log (57.82 KB, text/plain)
2013-05-10 23:54 EDT, Reartes Guillermo
no flags Details
File: storage.log (946.40 KB, text/plain)
2013-05-10 23:55 EDT, Reartes Guillermo
no flags Details
File: syslog (86.09 KB, text/plain)
2013-05-10 23:55 EDT, Reartes Guillermo
no flags Details
File: anaconda-tb (1.97 MB, text/plain)
2013-05-10 23:55 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2013-05-10 23:54:28 EDT
Description of problem:
I don't know what happened, i was no exepecting this failure.
I was tracking an issue with raid but got this.
The following was filed automatically by anaconda:
anaconda 19.25-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 6501, in save_ts
    f = open(filename, 'w')
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1532, in install
    self._yum.save_ts(ts_file)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 137, in doInstall
    payload.install()
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
IOError: [Errno 30] Read-only file system: '/mnt/sysimage/anaconda-yum.yumtx'

Version-Release number of selected component:
anaconda-19.25-1

Additional info:
cmdline:        /usr/bin/python  /sbin/anaconda
cmdline_file:   initrd=initrd.img inst.stage2=hd:LABEL=Fedora\x2019-Beta-TC4\x20x86_64 quiet BOOT_IMAGE=vmlinuz 
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         3.9.0-301.fc19.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        19-Beta-TC4

Truncated backtrace:
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 168, in run
    threading.Thread.run(self, *args, **kwargs)
  File "/usr/lib64/python2.7/threading.py", line 766, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 137, in doInstall
    payload.install()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1532, in install
    self._yum.save_ts(ts_file)
  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 6501, in save_ts
    f = open(filename, 'w')
IOError: [Errno 30] Read-only file system: '/mnt/sysimage/anaconda-yum.yumtx'
Comment 1 Reartes Guillermo 2013-05-10 23:54:32 EDT
Created attachment 746461 [details]
File: anaconda.log
Comment 2 Reartes Guillermo 2013-05-10 23:54:35 EDT
Created attachment 746462 [details]
File: backtrace
Comment 3 Reartes Guillermo 2013-05-10 23:54:37 EDT
Created attachment 746463 [details]
File: environ
Comment 4 Reartes Guillermo 2013-05-10 23:54:39 EDT
Created attachment 746464 [details]
File: ifcfg.log
Comment 5 Reartes Guillermo 2013-05-10 23:54:41 EDT
Created attachment 746465 [details]
File: lsblk_output
Comment 6 Reartes Guillermo 2013-05-10 23:54:43 EDT
Created attachment 746466 [details]
File: nmcli_dev_list
Comment 7 Reartes Guillermo 2013-05-10 23:54:52 EDT
Created attachment 746467 [details]
File: packaging.log
Comment 8 Reartes Guillermo 2013-05-10 23:54:59 EDT
Created attachment 746468 [details]
File: program.log
Comment 9 Reartes Guillermo 2013-05-10 23:55:11 EDT
Created attachment 746469 [details]
File: storage.log
Comment 10 Reartes Guillermo 2013-05-10 23:55:19 EDT
Created attachment 746470 [details]
File: syslog
Comment 11 Reartes Guillermo 2013-05-10 23:55:43 EDT
Created attachment 746471 [details]
File: anaconda-tb
Comment 12 Brian Lane 2013-05-14 20:35:45 EDT
Something went wrong with your raid array and it was remounted read-only. Not much we can do about that.

03:51:54,503 DEBUG kernel:[  304.502556] SELinux: initialized (dev md126, type ext4), uses xattr
03:51:54,591 DEBUG kernel:[  304.591177] SELinux: initialized (dev tmpfs, type tmpfs), uses transition SIDs
03:51:58,877 ALERT kernel:[  308.876973] md/raid10:md125: Disk failure on sda1, disabling device.
03:51:58,877 ALERT kernel:[  308.876973] md/raid10:md125: Operation continuing on 3 devices.
03:51:58,877 ALERT kernel:[  308.876979] md/raid10:md125: Disk failure on sdb1, disabling device.
03:51:58,877 ALERT kernel:[  308.876979] md/raid10:md125: Operation continuing on 2 devices.
03:51:59,055 ALERT kernel:[  309.055829] md/raid10:md125: Disk failure on sdc1, disabling device.
03:51:59,055 ALERT kernel:[  309.055829] md/raid10:md125: Operation continuing on 1 devices.
03:51:59,055 ALERT kernel:[  309.055835] md/raid10:md125: Disk failure on sdd1, disabling device.
03:51:59,055 ALERT kernel:[  309.055835] md/raid10:md125: Operation continuing on 0 devices.
03:51:59,055 ERR kernel:[  309.055855] md125: WRITE SAME failed. Manually zeroing.
03:51:59,605 ERR kernel:[  309.605888] Buffer I/O error on device md125, logical block 557056
03:51:59,605 WARNING kernel:[  309.605892] lost page write due to I/O error on md125
03:51:59,605 ERR kernel:[  309.605895] JBD2: Error -5 detected when updating journal superblock for md125-8.
03:51:59,605 ERR kernel:[  309.605991] Aborting journal on device md125-8.
03:51:59,605 ERR kernel:[  309.605994] Buffer I/O error on device md125, logical block 557056
03:51:59,605 WARNING kernel:[  309.605996] lost page write due to I/O error on md125
03:51:59,605 ERR kernel:[  309.605998] JBD2: Error -5 detected when updating journal superblock for md125-8.
03:51:59,606 ERR kernel:[  309.606527] Buffer I/O error on device md125, logical block 0
03:51:59,606 WARNING kernel:[  309.606529] lost page write due to I/O error on md125
03:51:59,606 CRIT kernel:[  309.606532] EXT4-fs error (device md125): __ext4_journal_start_sb:60: Detected aborted journal
03:51:59,606 CRIT kernel:[  309.606535] EXT4-fs (md125): Remounting filesystem read-only
03:51:59,606 ERR kernel:[  309.606537] EXT4-fs (md125): previous I/O error to superblock detected
03:51:59,606 ERR kernel:[  309.606539] Buffer I/O error on device md125, logical block 0
03:51:59,606 WARNING kernel:[  309.606540] lost page write due to I/O error on md125

Note You need to log in before you can comment on or make changes to this bug.