Bug 962166 - Packaging bug: xsd files should not be in devel package. They're required at run time.
Packaging bug: xsd files should not be in devel package. They're required at ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gupnp-av (Show other bugs)
19
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Peter Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-12 04:47 EDT by Ankur Sinha (FranciscoD)
Modified: 2013-05-24 16:39 EDT (History)
2 users (show)

See Also:
Fixed In Version: gupnp-av-0.12.1-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-24 16:39:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch that moves xsd files to base package from devel package (1.06 KB, patch)
2013-05-12 05:04 EDT, Ankur Sinha (FranciscoD)
no flags Details | Diff

  None (edit)
Description Ankur Sinha (FranciscoD) 2013-05-12 04:47:24 EDT
Description of problem:
The gupnp-av-devel contains xsd files which are required at run-time by different applications, for example: rygel. These files should be in the gnupnp-av package, not in the devel package.

Version-Release number of selected component (if applicable):
gupnp-av-0.12.1-1.fc19.x86_64

  
[ankur@ankur-pc  ~]$ rpm -ql gupnp-av-devel | egrep xsd
/usr/share/gupnp-av/av.xsd
/usr/share/gupnp-av/didl-lite-v2.xsd
/usr/share/gupnp-av/simpledc20021212.xsd
/usr/share/gupnp-av/upnp.xsd
/usr/share/gupnp-av/xml.xsd
[ankur@ankur-pc  ~]$
Comment 1 Ankur Sinha (FranciscoD) 2013-05-12 05:04:50 EDT
Created attachment 746792 [details]
Patch that moves xsd files to base package from devel package

I tested the update path too, since I had the devel package installed. The patch seems sufficient. Would be good to re-test and check it once though :)
Comment 2 Fedora Update System 2013-05-12 16:14:54 EDT
gupnp-av-0.12.1-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gupnp-av-0.12.1-2.fc19
Comment 3 Fedora Update System 2013-05-13 11:02:47 EDT
Package gupnp-av-0.12.1-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gupnp-av-0.12.1-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-8040/gupnp-av-0.12.1-2.fc19
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-05-24 16:39:34 EDT
gupnp-av-0.12.1-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.