Bug 962186 - SELinux is preventing /usr/sbin/cupsd from 'write' accesses on the directory /.
SELinux is preventing /usr/sbin/cupsd from 'write' accesses on the directory /.
Status: CLOSED DUPLICATE of bug 962185
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-05-12 07:59 EDT by Frank Murphy
Modified: 2013-05-13 07:09 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-05-13 07:09:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Frank Murphy 2013-05-12 07:59:07 EDT
Description of problem:
SELinux is preventing /usr/sbin/cupsd from 'write' accesses on the directory /.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that cupsd should be allowed write access on the  directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
allow this access for now by executing:
# grep cupsd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:autofs_t:s0
Target Objects                / [ dir ]
Source                        cupsd
Source Path                   /usr/sbin/cupsd
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           cups-1.5.4-20.fc18.x86_64
Target RPM Packages           filesystem-3.1-2.fc18.x86_64
Policy RPM                    selinux-policy-3.11.1-92.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.2-0.rc1.200.fc18.x86_64 #1 SMP
                              Fri May 10 16:44:27 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-05-12 12:55:51 IST
Last Seen                     2013-05-12 12:55:51 IST
Local ID                      583083d7-7cec-425b-be36-bc889aa3d507

Raw Audit Messages
type=AVC msg=audit(1368359751.329:77): avc:  denied  { write } for  pid=1477 comm="cupsd" name="/" dev="autofs" ino=18092 scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:autofs_t:s0 tclass=dir

type=SYSCALL msg=audit(1368359751.329:77): arch=x86_64 syscall=mkdir success=no exit=EACCES a0=7f581b1cfd64 a1=1fd a2=0 a3=7fff2c8e1750 items=0 ppid=1 pid=1477 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=cupsd exe=/usr/sbin/cupsd subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023 key=(null)

Hash: cupsd,cupsd_t,autofs_t,dir,write


#============= cupsd_t ==============
allow cupsd_t autofs_t:dir write;

audit2allow -R
require {
	type cupsd_t;

#============= cupsd_t ==============

Additional info:
reporter:       libreport-
hashmarkername: setroubleshoot
kernel:         3.9.2-0.rc1.200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-05-13 07:09:29 EDT

*** This bug has been marked as a duplicate of bug 962185 ***

Note You need to log in before you can comment on or make changes to this bug.