Bug 962231 - anaconda issues a spurious 'not asking for VNC' due to ram size message when 'text' or 'vnc' boot parameters are used
anaconda issues a spurious 'not asking for VNC' due to ram size message when ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-12 15:58 EDT by Reartes Guillermo
Modified: 2013-08-08 10:41 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-08 10:41:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot F19b TC4 showing vnc working and the fake error message (29.15 KB, image/png)
2013-05-12 15:58 EDT, Reartes Guillermo
no flags Details
screenshot F19b TC4 showing vnc / text mode dialog (this does not work with 512mb) (26.22 KB, image/png)
2013-05-12 16:09 EDT, Reartes Guillermo
no flags Details
anaconda.log (2.36 KB, text/plain)
2013-05-14 21:14 EDT, Reartes Guillermo
no flags Details
program.log (16.60 KB, text/plain)
2013-05-14 21:14 EDT, Reartes Guillermo
no flags Details
storage.log (46.54 KB, text/plain)
2013-05-14 21:15 EDT, Reartes Guillermo
no flags Details
syslog (81.44 KB, text/plain)
2013-05-14 21:15 EDT, Reartes Guillermo
no flags Details
anaconda.log (2.59 KB, text/plain)
2013-05-14 21:19 EDT, Reartes Guillermo
no flags Details
program.log (16.67 KB, text/plain)
2013-05-14 21:19 EDT, Reartes Guillermo
no flags Details
storage.log (46.52 KB, text/plain)
2013-05-14 21:20 EDT, Reartes Guillermo
no flags Details
syslog (82.44 KB, text/plain)
2013-05-14 21:20 EDT, Reartes Guillermo
no flags Details
vncserver.log (1.36 KB, text/plain)
2013-05-14 21:20 EDT, Reartes Guillermo
no flags Details
anaconda.log (2.49 KB, text/plain)
2013-05-14 21:24 EDT, Reartes Guillermo
no flags Details
program.log (16.67 KB, text/plain)
2013-05-14 21:24 EDT, Reartes Guillermo
no flags Details
storage.log (46.52 KB, text/x-log)
2013-05-14 21:25 EDT, Reartes Guillermo
no flags Details
syslog (81.06 KB, text/plain)
2013-05-14 21:25 EDT, Reartes Guillermo
no flags Details
vncserver.log (1.36 KB, text/x-log)
2013-05-14 21:26 EDT, Reartes Guillermo
no flags Details

  None (edit)
Description Reartes Guillermo 2013-05-12 15:58:00 EDT
Created attachment 746975 [details]
screenshot F19b TC4 showing vnc working and the fake error message

Description of problem:

A spurious message about not enough ram for vnc is shown.
If 'vnc' boot parameter is specified, vnc starts ok, after
the message.

Version-Release number of selected component (if applicable):
F19b TC4

How reproducible:
always

Steps to Reproduce:
See below.
  
Actual results:
an error message, harmless when 'vnc' boot parameter is specified.
confusing, when no boot parameter is used, it might lead to think
that there is not enough ram to use vnc and do not try further.


Expected results:
no error or warning should be issued if not really necessary.

Additional info:

F18 Release:

* KVM Guest (512mb RAM) boot-parameter: NONE
  --> GRAPHICAL MODE --> Anaconda starts up in this mode. 
  --> VNC Server ------> N/A
  --> TEXT MODE -------> N/A

* KVM Guest (512mb RAM) boot-parameter: text 
  --> GRAPHICAL MODE --> N/A 
  --> VNC Server ------> Not Offered / Skipped
  --> TEXT MODE -------> Anaconda stars up in this mode.
  
* KVM Guest (512mb RAM) boot-parameter: vnc 
  --> GRAPHICAL MODE --> N/A 
  --> VNC Server ------> Anaconda shows an ip to connect to. (no password).
  
* KVM Guest (512mb RAM) boot-parameter: vnc vncpassword=password
  --> GRAPHICAL MODE --> N/A 
  --> VNC Server ------> Anaconda shows an ip to connect to. (with specified password).
  

F19b TC4:

* KVM Guest (512mb RAM) boot-parameter: NONE
  --> GRAPHICAL MODE --> Anaconda starts up in this mode. 
  --> VNC Server ------> N/A
  --> TEXT MODE -------> N/A

* KVM Guest (512mb RAM) boot-parameter: text 
  --> GRAPHICAL MODE --> N/A 
  --> VNC Server ------> VNC is tried first, but fails with not enough RAM.
  --> TEXT MODE -------> After failed VNC, Anaconda stars up in this mode.
  
* KVM Guest (512mb RAM) boot-parameter: vnc 
  --> GRAPHICAL MODE --> N/A 
  --> VNC Server ------> Anaconda reports not enough ram for VNC, but 
anaconda starts it anyway. Shows ip to connect to. (no password).
  
* KVM Guest (512mb RAM) boot-parameter: vnc vncpassword=password
  --> GRAPHICAL MODE --> N/A 
  --> VNC Server ------> Anaconda reports not enough ram for VNC, but 
anaconda starts it anyway. Shows ip to connect to. (with specified password).
Comment 1 Reartes Guillermo 2013-05-12 16:09:13 EDT
Created attachment 746990 [details]
screenshot F19b TC4 showing vnc / text mode dialog (this does not work with 512mb)

Additional Info:

* KVM [X86_64] Guest (535mb RAM) boot-parameter: text
  --> GRAPHICAL MODE --> Anaconda starts up in this mode. 
  --> VNC Server ------> No error message, dialog offers either VNC or Text Mode
  --> TEXT MODE -------> No error message, dialog offers either VNC or Text Mode

I wonder if this really does not fit in 512mb.

for this to work: 


* 535mb ram for. X86_64 F19b TC4 
* 528mb ram for  i386 F19b TC4
Comment 2 Reartes Guillermo 2013-05-12 16:46:43 EDT
Comment #1 is incorrect:

screenshot F19b TC4 showing vnc / text mode dialog (this does not work with 512mb)

Additional Info:

* KVM [X86_64] Guest (535mb RAM) boot-parameter: text
> --> GRAPHICAL MODE --> N/A 
  --> VNC Server ------> No error message, dialog offers either VNC or Text Mode
  --> TEXT MODE -------> No error message, dialog offers either VNC or Text Mode

I wonder if this really does not fit in 512mb.

for this to work: 


* 535mb ram for. X86_64 F19b TC4 
* 528mb ram for  i386 F19b TC4
Comment 3 Brian Lane 2013-05-14 20:51:29 EDT
Please switch to tty1 and attach the logs from /tmp/*log to this bug as individual text/plain files.

In general the logs are much more useful than screenshots.
Comment 4 Reartes Guillermo 2013-05-14 21:14:23 EDT
Created attachment 747979 [details]
anaconda.log

KVM Guest (512mb RAM) boot-parameter: text
Comment 5 Reartes Guillermo 2013-05-14 21:14:44 EDT
Created attachment 747980 [details]
program.log

KVM Guest (512mb RAM) boot-parameter: text
Comment 6 Reartes Guillermo 2013-05-14 21:15:12 EDT
Created attachment 747981 [details]
storage.log

KVM Guest (512mb RAM) boot-parameter: text
Comment 7 Reartes Guillermo 2013-05-14 21:15:48 EDT
Created attachment 747982 [details]
syslog
Comment 8 Reartes Guillermo 2013-05-14 21:19:01 EDT
Created attachment 747983 [details]
anaconda.log

KVM Guest (512mb RAM) boot-parameter: vnc
Comment 9 Reartes Guillermo 2013-05-14 21:19:27 EDT
Created attachment 747984 [details]
program.log
Comment 10 Reartes Guillermo 2013-05-14 21:20:00 EDT
Created attachment 747985 [details]
storage.log

KVM Guest (512mb RAM) boot-parameter: vnc
Comment 11 Reartes Guillermo 2013-05-14 21:20:26 EDT
Created attachment 747986 [details]
syslog
Comment 12 Reartes Guillermo 2013-05-14 21:20:52 EDT
Created attachment 747987 [details]
vncserver.log
Comment 13 Reartes Guillermo 2013-05-14 21:24:19 EDT
Created attachment 747988 [details]
anaconda.log

KVM [X86_64] Guest (535mb RAM) boot-parameter: text
Comment 14 Reartes Guillermo 2013-05-14 21:24:48 EDT
Created attachment 747989 [details]
program.log

KVM [X86_64] Guest (535mb RAM) boot-parameter: text
Comment 15 Reartes Guillermo 2013-05-14 21:25:19 EDT
Created attachment 747990 [details]
storage.log

KVM [X86_64] Guest (535mb RAM) boot-parameter: text
Comment 16 Reartes Guillermo 2013-05-14 21:25:45 EDT
Created attachment 747991 [details]
syslog

KVM [X86_64] Guest (535mb RAM) boot-parameter: text
Comment 17 Reartes Guillermo 2013-05-14 21:26:05 EDT
Created attachment 747992 [details]
vncserver.log

KVM [X86_64] Guest (535mb RAM) boot-parameter: text
Comment 18 Brian Lane 2013-05-15 13:43:31 EDT
Ends up the blivet total_memory wasn't rounding up like Anaconda's total_memory.
Comment 19 Adam Williamson 2013-05-29 21:47:39 EDT
This was ACK'ed:

https://lists.fedorahosted.org/pipermail/anaconda-patches/2013-May/004186.html

but doesn't yet appear to have been pushed, did you forget about it bcl? Doesn't look too critical for F19 so I won't bother marking as FE, but OTOH it seems pretty safe so if you want to sneak it in there, no objections.
Comment 20 Reartes Guillermo 2013-05-30 11:36:51 EDT
I tried this with 'text' and 'vnc' with a 512mb guest (only x86_64) and there was no more spurious messages about memory. It just works. (F19b RC4).
Comment 21 David Shea 2013-08-08 10:41:59 EDT
Looks like this change was pushed with python-blivet-0.14-1

Note You need to log in before you can comment on or make changes to this bug.