Bug 962239 - Broken dependency to jsch
Broken dependency to jsch
Status: CLOSED DUPLICATE of bug 879999
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Krzysztof Daniel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-12 17:28 EDT by Gerard Ryan
Modified: 2014-01-12 19:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 09:05:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gerard Ryan 2013-05-12 17:28:10 EDT
Description of problem:
When building with tycho on rawhide (maybe f19 also?), the following error is thrown:

[ERROR]   Missing requirement: org.eclipse.platform.feature.group 4.3.0.v20130507-1107 requires 'com.jcraft.jsch [0.1.46.v201101211721]' but it could not be found

Version-Release number of selected component (if applicable):
eclipse-4.3.0-0.42.fc20
(and i guess jsch-0.1.50-1.fc20)

How reproducible:
n/a

Steps to Reproduce:
1. Try to build eclipse-m2e-core package (maybe lots of other packages also
2. ???
3. Don't profit
  
Actual results:
Failure

Expected results:
Success
Comment 1 Krzysztof Daniel 2013-05-13 02:34:03 EDT
Hey Gerard,
Thanks for the bug report. I started updating platform on Friday and it required new jsch and sat4j, so I built those. Unfortunately the new Eclipse build is broken so I have not pushed it. I hope to fix it this week.

As a temporary solution I have untagged the jsch build from f20 koji.
Comment 2 Krzysztof Daniel 2013-05-13 04:01:21 EDT
Changing bug title to reflect the real problem - Platform does require a very specific version and there is nothing we can do about that. In this case the problem is that the version is not in the buildroot.
Comment 3 Krzysztof Daniel 2013-05-13 09:05:52 EDT

*** This bug has been marked as a duplicate of bug 879999 ***

Note You need to log in before you can comment on or make changes to this bug.