Bug 962263 - remove config reloading support from beaker
remove config reloading support from beaker
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: scheduler (Show other bugs)
0.12
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: beaker-dev-list
ImplementationQuality
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-12 23:31 EDT by Dan Callaghan
Modified: 2018-02-05 19:41 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-19 19:12:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2013-05-12 23:31:16 EDT
On SIGHUP beakerd reloads its configuration. This support was originally added at a time when beakerd wasn't rotating its own logs, and it didn't shut itself down cleanly (threads were killed in the middle of processing recipes).

Now that those reasons no longer apply, we should remove the reload support because it causes a lot of extra complexity, particularly in dealing with logging configuration.

See http://gerrit.beaker-project.org/1647 for some discussion.
Comment 1 Dan Callaghan 2013-09-19 19:12:43 EDT
SIGHUP handling was removed as part of bug 963542, released with Beaker 0.14.

Note You need to log in before you can comment on or make changes to this bug.