Bug 962278 - RFE: C++ Hot Rod Client
RFE: C++ Hot Rod Client
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Grid 6
Classification: JBoss
Component: Documentation (Show other bugs)
6.1.0
Unspecified Unspecified
unspecified Severity unspecified
: GA
: 6.2.0
Assigned To: Rakesh
Mandar Joshi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 01:29 EDT by Misha H. Ali
Modified: 2015-08-31 22:58 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-15 19:02:15 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Misha H. Ali 2013-05-13 01:29:12 EDT
Document the new C++ Hot Rod Client for JBoss Data Grid.
Comment 2 Misha H. Ali 2013-10-22 23:42:14 EDT
Requested pointers to any notes about how this is used in JDG. Waiting for Mircea to respond.
Comment 3 Mircea Markus 2013-10-30 11:13:28 EDT
There's no community documentation for this yet. Once community documentation will be available, we can build on top of that. Related jira: HRCPP-55
Comment 4 Mircea Markus 2013-11-18 19:53:24 EST
Here's the CPP client community documentation: https://github.com/infinispan/cpp-client/blob/master/documentation/index.adoc
Comment 6 Misha H. Ali 2013-11-20 07:36:08 EST
Updated bug subject. I'll update the relevant status doc and docs plan page later.

Mandar, this means that we do not need the tech preview note in each topic for this feature. Please follow the workflow we outlined for the leveldb bug and develop this content on a priority basis. Flag me for a quick review when you're done.
Comment 7 Misha H. Ali 2013-11-26 23:22:48 EST
Assigning this to Bob to take some load off Mandar.

Bobb, please propose the new topics for this feature and submit to me for review by Monday EOD.

Do not create the topics yet, just create a full draft on the etherpad with correct spelling, grammar and headings.
Comment 9 Rakesh 2013-12-02 14:33:35 EST
-Detailed installation instructions not available yet. 
-Download links not available yet.
Comment 10 Misha H. Ali 2013-12-02 20:57:52 EST
Added feedback.
Comment 11 Misha H. Ali 2013-12-02 23:23:39 EST
Bobb, when you're done, please work with Tristan for this material. He has been asked by Divya to coordinate with the writers about how this information should be presented best.
Comment 12 Rakesh 2013-12-03 14:20:47 EST
Implemented feedback. Requested Tristan to review the pad.
Comment 14 Rakesh 2013-12-09 05:56:20 EST
Feedback implemented. Requested explanation on an extract of the draft.
Comment 15 Rakesh 2013-12-09 14:28:26 EST
- Emailed Tristan for "Shared/Dynamic Library" explanation. 
- Extract explanation received from Tristan.
- Processed and added the info in the draft. Updated.
- Gemma added Interoperability topic in the draft.
Comment 16 Rakesh 2013-12-12 02:56:27 EST
Created the following topics on Docbuilder:


* Hot Rod C ++ Client Introduction [26079]
* Hot Rod C++ Client Formats [26080]
* Hot Rod C ++ Client Download [26081]
* Hot Rod C ++ Client Installation [26082]
* Hot Rod C ++ Client Configuration [26083]
* Hot Rod  C ++ Client API [26084]
* Hot Rod C ++ Client Requisites [26085]
Comment 18 Rakesh 2013-12-12 12:02:33 EST
Please ignore the above sections. Updated ones are as follows:

11.6.15. Hot Rod C ++ Client
11.6.16. Hot Rod C ++ Client Formats
11.6.17. Hot Rod C ++ Client Download
11.6.18. Hot Rod C ++ Client Installation
11.6.19. Hot Rod C ++ Client Configuration
11.6.20. Hot Rod C ++ Client API
11.6.21. Hot Rod C ++ Client Requisites
Comment 21 Rakesh 2013-12-13 09:35:39 EST
The sections are reorganized as follows in the Developer guide:

11.7. Hot Rod C ++ Client

    11.7.1. Hot Rod C ++ Client Formats
    11.7.2. Hot Rod C ++ Client Download
    11.7.3. Hot Rod C ++ Client Installation
    11.7.4. Hot Rod C ++ Client Configuration
    11.7.5. Hot Rod C ++ Client API
    11.7.6. Hot Rod C ++ Client Requisites
Comment 23 Rakesh 2013-12-13 14:38:12 EST
Have to discuss this in the JDG team meeting on Monday.
Comment 24 gsheldon 2013-12-15 21:13:42 EST
Following up Java Hot Rod client in the following bug:

https://bugzilla.redhat.com/show_bug.cgi?id=1043334
Comment 28 Rakesh 2013-12-30 08:19:30 EST
Emailed Tristan for the Hot Rod cpp client location in the JDG 6.2 distribution.
Comment 29 Misha H. Ali 2014-01-05 20:35:45 EST
What is the status, Bobb? If Tristan is away, you need to find out this information from other sources.
Comment 30 Rakesh 2014-01-06 00:31:12 EST
(In reply to Misha H. Ali from comment #29)
> What is the status, Bobb? If Tristan is away, you need to find out this
> information from other sources.

Divya specified Tristan as the source for this info. I Will pursue Tristan today again and fetch that bit. If in vain, I will check some other avenues. Just this last bit of info is needed to complete the topic.
Comment 31 Rakesh 2014-01-06 07:33:23 EST
Martin provided the HT cpp client location. It is included in a separate zip file: jboss-datagrid-6.2.0.CR1-hotrod-cpp-client-RHEL6-x86_64.zip. Users need to unzip it.
Comment 34 Martin Gencur 2014-01-06 08:48:29 EST
The zip file with Cpp client is not called jboss-datagrid-6.2.0.CR1-hotrod-cpp-client-PLATFORM.zip  We should probably use something more generic (as discussed over IRC) such as "jboss-datagrid-<version>-hotrod-cpp-client-<platform>.zip", literally.

I'll provide more feedback on the docs for Cpp client later today.
Comment 35 Martin Gencur 2014-01-06 09:49:42 EST
Additional feedback for the Cpp client's docu and for the whole docu too:

* 11.8.3. Hot Rod C ++ Client Installation

We don't have this split available:

For Red Hat Enterprise Linux 6, the following x86_64 RPMs split is available:
* infinispan-cpp-client (Shared library)
* infinispan-cpp-client-devel (Static library and header files for development)
* infinispan-cpp-client-devel-docs (API documentation in HTML format)

(btw, we should not mention "RPM" at all, we ship only zip files, not RPMs)

* 11.7.2. Hot Rod Java Client Installation

I don't see anything in this chapter.

* 11.8.4. Hot Rod C ++ Client Configuration

I don't think we can specify "marshaller" in this version of Cpp client yet. -> Please remove this sentence:
"Marshaller used to convert between the in-memory representation and the binary format necessary for transmission over the wire."

* The chapters need re-ordering:

Chapters 11.10., 11.11 should be placed right after 11.6. so that protocol-specific topics are in one place and not interleaved by Java and Cpp clients.

* Chapters 11.7.4 and 12 should be consolidated and placed at the place of 11.7.4. We don't need a separate chapter 
for RemoteCache interface (chapter 12). It's placed at a wrong place and partially repeats 11.7.4
Comment 36 Rakesh 2014-01-07 01:38:42 EST
(In reply to Martin Gencur from comment #35)
> Additional feedback for the Cpp client's docu and for the whole docu too:
> 
> * 11.8.3. Hot Rod C ++ Client Installation
> 
> We don't have this split available:
> 
> For Red Hat Enterprise Linux 6, the following x86_64 RPMs split is available:
> * infinispan-cpp-client (Shared library)
> * infinispan-cpp-client-devel (Static library and header files for
> development)
> * infinispan-cpp-client-devel-docs (API documentation in HTML format)
> 
> (btw, we should not mention "RPM" at all, we ship only zip files, not RPMs)
> 
> * 11.7.2. Hot Rod Java Client Installation
> 
> I don't see anything in this chapter.
> 
> * 11.8.4. Hot Rod C ++ Client Configuration
> 
> I don't think we can specify "marshaller" in this version of Cpp client yet.
> -> Please remove this sentence:
> "Marshaller used to convert between the in-memory representation and the
> binary format necessary for transmission over the wire."
> 
> * The chapters need re-ordering:
> 
> Chapters 11.10., 11.11 should be placed right after 11.6. so that
> protocol-specific topics are in one place and not interleaved by Java and
> Cpp clients.
> 
> * Chapters 11.7.4 and 12 should be consolidated and placed at the place of
> 11.7.4. We don't need a separate chapter 
> for RemoteCache interface (chapter 12). It's placed at a wrong place and
> partially repeats 11.7.4

Martin, do u suggest removing 11.7.2. Hot Rod Java Client Installation entirely?
Comment 37 Rakesh 2014-01-07 01:49:11 EST
(In reply to Rakesh from comment #36)
> (In reply to Martin Gencur from comment #35)
> > Additional feedback for the Cpp client's docu and for the whole docu too:
> > 
> > * 11.8.3. Hot Rod C ++ Client Installation
> > 
> > We don't have this split available:
> > 
> > For Red Hat Enterprise Linux 6, the following x86_64 RPMs split is available:
> > * infinispan-cpp-client (Shared library)
> > * infinispan-cpp-client-devel (Static library and header files for
> > development)
> > * infinispan-cpp-client-devel-docs (API documentation in HTML format)
> > 
> > (btw, we should not mention "RPM" at all, we ship only zip files, not RPMs)
> > 
> > * 11.7.2. Hot Rod Java Client Installation
> > 
> > I don't see anything in this chapter.
> > 
> > * 11.8.4. Hot Rod C ++ Client Configuration
> > 
> > I don't think we can specify "marshaller" in this version of Cpp client yet.
> > -> Please remove this sentence:
> > "Marshaller used to convert between the in-memory representation and the
> > binary format necessary for transmission over the wire."
> > 
> > * The chapters need re-ordering:
> > 
> > Chapters 11.10., 11.11 should be placed right after 11.6. so that
> > protocol-specific topics are in one place and not interleaved by Java and
> > Cpp clients.
> > 
> > * Chapters 11.7.4 and 12 should be consolidated and placed at the place of
> > 11.7.4. We don't need a separate chapter 
> > for RemoteCache interface (chapter 12). It's placed at a wrong place and
> > partially repeats 11.7.4
> 
> Martin, do u suggest removing 11.7.2. Hot Rod Java Client Installation
> entirely?

Sorry Martin, I meant section 11.8.3. Hot Rod C ++ Client Installation. Do u suggest removing it?
Comment 38 Martin Gencur 2014-01-07 03:02:35 EST
Chapter 11.8.3 is wrong. We should provide instructions for installation but they would be different. I guess ttarrant is the right person to ask.
Comment 41 Martin Gencur 2014-01-07 07:54:57 EST
The topic "Hot Rod Operation Values" is placed correctly now. However, the consolidation of the two topics was not very good. You just placed them together, right? But now there's redundant information. Please give it another try, thanks.
Comment 44 Rakesh 2014-01-07 14:16:18 EST
Removing 11.10.2. Hot Rod C ++ Client Download topic. 

ttarrant> Bobb|away, aside from unzipping the archives, there is no "installation" per se

Tristan acked removing the Installation topic.
Comment 45 Rakesh 2014-01-07 14:50:22 EST
(In reply to Martin Gencur from comment #41)
> The topic "Hot Rod Operation Values" is placed correctly now. However, the
> consolidation of the two topics was not very good. You just placed them
> together, right? But now there's redundant information. Please give it
> another try, thanks.

Mircea, I tried to locate the redundant info in the topic but I could not meet success. Could you point toward the redundant areas? I see 2 code snippets, one is the example API and second is configuring a new RemoteCacheManager. Any inputs on this will be helpful.
Comment 46 Rakesh 2014-01-07 14:52:49 EST
(In reply to Rakesh from comment #45)
> (In reply to Martin Gencur from comment #41)
> > The topic "Hot Rod Operation Values" is placed correctly now. However, the
> > consolidation of the two topics was not very good. You just placed them
> > together, right? But now there's redundant information. Please give it
> > another try, thanks.
> 
> Mircea, I tried to locate the redundant info in the topic but I could not
> meet success. Could you point toward the redundant areas? I see 2 code
> snippets, one is the example API and second is configuring a new
> RemoteCacheManager. Any inputs on this will be helpful.

Apologies for the mistyped name. It is referred to Martin and not Mircea.
Comment 47 Martin Gencur 2014-01-08 03:38:55 EST
OK. I had another look at the docs and here is my proposal:

* Personally, I'd remove the following paragraphs in chapter 11.9.3. because they just repeat what was already said:
The paragraph starting with "The RemoteCache Interface allows clients outside" and the rest of this chapter, including the 
Configuration Explanation.

The configuration explanation could be possibly added to chapter 11.9.2. because the configuration snippet is there too.

* 11.9.2. Hot Rod Java Client Configuration

The topic "Configuring the Hot Rod Java client using a properties file" is incomplete.

The properties must be placed in a file called hotrod-client.properties and the file must be placed on classpath. What's more,
users can only use the following two constructors in order to use the aforementioned configuration file:
new RemoteCacheManager(boolean start)
new RemoteCacheManager()

(the file is then looked up automatically)

The Example 11.2 should not contain this at the beginning:

"[source]

----
Comment 48 Rakesh 2014-01-08 15:23:07 EST
Martin, I have ported your feedback on HT Java client to Bug 1043334 as the Java client is being documented there. 

I have implemented your feedback for cpp client in Comment 42, please review.
Comment 49 Martin Gencur 2014-01-09 03:29:42 EST
In chapter 11.10.2, I see jboss-datagrid-hotrod-cpp-client-<platform>.zip instead of jboss-datagrid-<version>-hotrod-cpp-client-<platform>.zip 
Please be careful when doing these simple changes.
Comment 50 Rakesh 2014-01-09 03:43:52 EST
Martin, there is some weird behaviour in the docbuilder. You need to refresh the document once again to see the actual rendering. This happened to me as well. The XML elements are set right to show "jboss-datagrid-<version>-hotrod-cpp-client-<platform>.zip." Request you to check it once again and refresh the doc to see the actual output.
Comment 51 Martin Gencur 2014-01-09 03:48:13 EST
Rakesh, thanks for the heads up. It really changed after I refreshed again. Sorry. Anyway, I'm just nitpicking now...could you add a dash between "<version>hotrod" in the file name? It's missing there.
Comment 52 Rakesh 2014-01-09 03:57:08 EST
NP Martin! Okay, added a dash, now the output looks like "jboss-datagrid-<version>-hotrod-cpp-client-<platform>.zip" :)
Comment 53 Martin Gencur 2014-01-09 04:01:29 EST
Thanks:)
Comment 54 Misha H. Ali 2014-01-15 19:02:15 EST
The fix for this bug is now generally released and available here:

https://access.redhat.com/site/documentation/en-US/Red_Hat_JBoss_Data_Grid/6.2/index.html

Note You need to log in before you can comment on or make changes to this bug.