Bug 962286 - nfs: default value displayed in help always null
nfs: default value displayed in help always null
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: rjoseph
Saurabh
:
Depends On:
Blocks: 967445
  Show dependency treegraph
 
Reported: 2013-05-13 01:59 EDT by Saurabh
Modified: 2016-01-19 01:11 EST (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.12rhs-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 967445 (view as bug list)
Environment:
Last Closed: 2013-09-23 18:39:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2013-05-13 01:59:49 EDT
Description of problem:
the default value for all nfs options is displayed as "(null)"
while taking help from 
gluster volume set help cmd

Where as for other options this is not the case.

Version-Release number of selected component (if applicable):
glusterfs-3.4.0.6rhs-1.el6rhs.x86_64

How reproducible:
always

Steps to Reproduce:
1. gluster volume set help
2.
3.
  
Actual results:
Option: nfs.enable-ino32
Default Value: (null)
Description: For nfs clients or apps that do not support 64-bit inode numbers, use this option to make NFS return 32-bit inode numbers instead. Disabled by default, so NFS returns 64-bit inode numbers.

Option: nfs.mem-factor
Default Value: (null)
Description: Use this option to make NFS be faster on systems by using more memory. This option specifies a multiple that determines the total amount of memory used. Default value is 15. Increase to use more memory in order to improve performance for certain use cases.Please consult gluster-users list before using this option.

Option: nfs.export-dirs
Default Value: (null)
Description: By default, all subvolumes of nfs are exported as individual exports. There are cases where a subdirectory or subdirectories in the volume need to be exported separately. Enabling this option allows any directory on a volumes to be exported separately. Directory exports are enabled by default.

Option: nfs.export-volumes
Default Value: (null)
Description: Enable or disable exporting whole volumes, instead if used in conjunction with nfs3.export-dir, can allow setting up only subdirectories as exports. On by default.

Option: nfs.addr-namelookup
Default Value: (null)
Description: Users have the option of turning on name lookup for incoming client connections using this option. Use this option to turn on name lookups during address-based authentication. Turning this on will enable you to use hostnames in rpc-auth.addr.* filters. In some setups, the name server can take too long to reply to DNS queries resulting in timeouts of mount requests. By default,  name lookup is off

Option: nfs.dynamic-volumes
Default Value: (null)
Description: Internal option set to tell gnfs to use a different scheme for encoding file handles when DVM is being used.

Option: nfs.register-with-portmap
Default Value: (null)
Description: For systems that need to run multiple nfs servers, only one registration is possible with portmap service. Use this option to turn off portmap registration for Gluster NFS. On by default

Option: nfs.rpc-auth-unix
Default Value: (null)
Description: Disable or enable the AUTH_UNIX authentication type for a particular exported volume overriding defaults and general setting for AUTH_UNIX scheme. Must always be enabled for better interoperability.However, can be disabled if needed. Enabled bydefault.

Option: nfs.rpc-auth-null
Default Value: (null)
Description: Disable or enable the AUTH_NULL authentication type for a particular exported volume overriding defaults and general setting for AUTH_NULL. Must always be enabled. This option is here only to avoid unrecognized option warnings.

Option: nfs.rpc-auth-allow
Default Value: (null)
Description: Allow a comma separated list of addresses and/or hostnames to connect to the server. By default, all connections are allowed. This allows users to define a rule for a specific exported volume.

Option: nfs.rpc-auth-reject
Default Value: (null)
Description: Reject a comma separated list of addresses and/or hostnames from connecting to the server. By default, all connections are allowed. This allows users todefine a rule for a specific exported volume.

Option: nfs.ports-insecure
Default Value: (null)
Description: Allow client connections from unprivileged ports. By default only privileged ports are allowed. Use this option to enable or disable insecure ports for a specific subvolume and to override the global setting  set by the previous option.

Option: nfs.transport-type
Default Value: tcp
Description: Specifies the nfs transport type. Valid transport types are 'tcp' and 'rdma'.

Option: nfs.trusted-sync
Default Value: (null)
Description: All writes and COMMIT requests are treated as async. This implies that no write requests are guaranteed to be on server disks when the write reply is received at the NFS client. Trusted sync includes  trusted-write behaviour. Off by default.

Option: nfs.trusted-write
Default Value: (null)
Description: On an UNSTABLE write from client, return STABLE flag to force client to not send a COMMIT request. In some environments, combined with a replicated GlusterFS setup, this option can improve write performance. This flag allows user to trust Gluster replication logic to sync data to the disks and recover when required. COMMIT requests if received will be handled in a default manner by fsyncing. STABLE writes are still handled in a sync manner. Off by default.

Option: nfs.volume-access
Default Value: (null)
Description: Type of access desired for this subvolume:  read-only, read-write(default)

Option: nfs.export-dir
Default Value: (null)
Description: By default, all subvolumes of nfs are exported as individual exports. There are cases where a subdirectory or subdirectories in the volume need to be exported separately. This option can also be used in conjunction with nfs3.export-volumes option to restrict exports only to the subdirectories specified through this option. Must be an absolute path.

Option: nfs.disable
Default Value: (null)
Description: This option is used to start or stop NFS serverfor individual volume.

Option: nfs.nlm
Default Value: (null)
Description: This option, if set to 'off', disables NLM server by not registering the service with the portmapper. Set it to 'on' to re-enable it. Default value: 'on'

Option: nfs.mount-udp
Default Value: (null)
Description: set the option to 'on' to enable mountd on UDP. Required for some Solaris and AIX NFS clients. The need for enabling this option often depends on the usage of NLM.


Expected results:
the "Default Value:" should actually say default values rather null

Also, we should display in help which one is a GLOBAL option

Additional info:

This is been there from long, should have improved by now.
Comment 2 Amar Tumballi 2013-05-16 04:59:37 EDT
Rajesh, it would be good exercise for you to fix the 'default' value string for all these options (look at nfs.c - xlators/nfs/server/src/).
Comment 3 Saurabh 2013-06-27 00:13:23 EDT
Default value as "no" does seem to be conventional, it should either True/False or On/Off

Option: nfs.enable-ino32
Default Value: no
Description: For nfs clients or apps that do not support 64-bit inode numbers, use this option to make NFS return 32-bit inode numbers instead. Disabled by default, so NFS returns 64-bit inode numbers.

The default values for the below options is "blank"
Option: nfs.export-dir
Default Value: 
Description: By default, all subvolumes of nfs are exported as individual exports. There are cases where a subdirectory or subdirectories in the volume need to be exported separately. This option can also be used in conjunction with nfs3.export-volumes option to restrict exports only to the subdirectories specified through this option. Must be an absolute path.
Comment 4 Saurabh 2013-06-27 00:13:41 EDT
Default value as "no" does not seem to be conventional, it should either True/False or On/Off

Option: nfs.enable-ino32
Default Value: no
Description: For nfs clients or apps that do not support 64-bit inode numbers, use this option to make NFS return 32-bit inode numbers instead. Disabled by default, so NFS returns 64-bit inode numbers.

The default values for the below options is "blank"
Option: nfs.export-dir
Default Value: 
Description: By default, all subvolumes of nfs are exported as individual exports. There are cases where a subdirectory or subdirectories in the volume need to be exported separately. This option can also be used in conjunction with nfs3.export-volumes option to restrict exports only to the subdirectories specified through this option. Must be an absolute path.
Comment 5 rjoseph 2013-06-27 00:37:13 EDT
As per gluster code following values of boolean is supported

1/0
on/off
yes/no
true/false
enable/disable

Do we have any documented convention for the help message which I can refer?
Comment 6 rjoseph 2013-07-03 04:10:50 EDT
As I said in my previous comment all the above mentioned values are supported therefore I used the one which makes more sense. 

> The default values for the below options is "blank"
This is intentional. export-dir should provide an absolute path. Therefore it does not make any sense to have some default value. By default it is blank, i.e. no export-dir is provided.
Comment 8 Scott Haines 2013-09-23 18:39:45 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 9 Scott Haines 2013-09-23 18:43:47 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.