Bug 962395 - [abrt] evolution-2.28.3-30.el6: node_get_next: Process /usr/bin/evolution was killed by signal 11 (SIGSEGV)
[abrt] evolution-2.28.3-30.el6: node_get_next: Process /usr/bin/evolution was...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: evolution (Show other bugs)
6.4
x86_64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Matthew Barnes
Desktop QE
abrt_hash:d27277e4ce586998cd77db06968...
:
Depends On: 883010
Blocks:
  Show dependency treegraph
 
Reported: 2013-05-13 06:51 EDT by David Jaša
Modified: 2013-06-04 13:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-04 13:42:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: maps (104.36 KB, text/plain)
2013-05-13 06:51 EDT, David Jaša
no flags Details
File: var_log_messages (315 bytes, text/plain)
2013-05-13 06:51 EDT, David Jaša
no flags Details
File: open_fds (38.87 KB, text/plain)
2013-05-13 06:51 EDT, David Jaša
no flags Details
File: environ (1.52 KB, text/plain)
2013-05-13 06:51 EDT, David Jaša
no flags Details
File: dso_list (26.19 KB, text/plain)
2013-05-13 06:51 EDT, David Jaša
no flags Details
File: limits (1.29 KB, text/plain)
2013-05-13 06:51 EDT, David Jaša
no flags Details
File: sosreport.tar.xz (1.39 MB, text/plain)
2013-05-13 06:52 EDT, David Jaša
no flags Details
File: backtrace (97.08 KB, text/plain)
2013-05-13 06:52 EDT, David Jaša
no flags Details
File: build_ids (9.77 KB, text/plain)
2013-05-13 06:52 EDT, David Jaša
no flags Details
File: cgroup (88 bytes, text/plain)
2013-05-13 06:52 EDT, David Jaša
no flags Details

  None (edit)
Description David Jaša 2013-05-13 06:51:36 EDT
Description of problem:
evolution crashed after typing unicode word to list of keywords in attachment reminder plug-in

Version-Release number of selected component:
evolution-2.28.3-30.el6

Additional info:
libreport version: 2.0.9
abrt_version:   2.0.8
backtrace_rating: 4
cmdline:        evolution -c mail
crash_function: node_get_next
kernel:         2.6.32-358.el6.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 node_get_next at gsequence.c
: #1 g_sequence_iter_next at gsequence.c
: #2 gtk_list_store_iter_next at gtkliststore.c
: #3 clue_foreach_check_isempty at attachment-reminder.c
: #4 gtk_tree_model_foreach_helper at gtktreemodel.c
: #5 IA__gtk_tree_model_foreach at gtktreemodel.c
: #6 clue_add_clicked at attachment-reminder.c
: #11 gtk_real_button_released at gtkbutton.c
: #16 gtk_button_button_release at gtkbutton.c
: #17 _gtk_marshal_BOOLEAN__BOXED at gtkmarshalers.c
Comment 1 David Jaša 2013-05-13 06:51:41 EDT
Created attachment 747179 [details]
File: maps
Comment 2 David Jaša 2013-05-13 06:51:46 EDT
Created attachment 747180 [details]
File: var_log_messages
Comment 3 David Jaša 2013-05-13 06:51:49 EDT
Created attachment 747181 [details]
File: open_fds
Comment 4 David Jaša 2013-05-13 06:51:51 EDT
Created attachment 747182 [details]
File: environ
Comment 5 David Jaša 2013-05-13 06:51:54 EDT
Created attachment 747183 [details]
File: dso_list
Comment 6 David Jaša 2013-05-13 06:51:57 EDT
Created attachment 747184 [details]
File: limits
Comment 7 David Jaša 2013-05-13 06:52:12 EDT
Created attachment 747185 [details]
File: sosreport.tar.xz
Comment 8 David Jaša 2013-05-13 06:52:15 EDT
Created attachment 747186 [details]
File: backtrace
Comment 9 David Jaša 2013-05-13 06:52:18 EDT
Created attachment 747187 [details]
File: build_ids
Comment 10 David Jaša 2013-05-13 06:52:20 EDT
Created attachment 747188 [details]
File: cgroup
Comment 12 Milan Crha 2013-05-13 13:19:25 EDT
Incomplete upstream bug report [1] about the same, with exactly the same description. The reporter was unable to reproduce this, same as I, thus I guess it depends on exact words being added.

David, could you fine-tune the steps for a reproducer, the best including the way you add the word (click, key-press), please?

[1] https://bugzilla.gnome.org/show_bug.cgi?id=579881
Comment 13 Milan Crha 2013-05-13 13:22:51 EDT
(Briefly looking into the code, the whole clue_foreach_check_isempty() looks suspicious.)
Comment 14 David Jaša 2013-05-14 06:58:18 EDT
(In reply to comment #12)
> Incomplete upstream bug report [1] about the same, with exactly the same
> description. The reporter was unable to reproduce this, same as I, thus I
> guess it depends on exact words being added.

I couldn't reproduce on a second try using the same words. It must be triggered by something else.

> 
> David, could you fine-tune the steps for a reproducer, the best including
> the way you add the word (click, key-press), please?

I clicked "Přidat" (add), then I clicked into the blank field, typed "příloha" (maybe without some letters on right), I clicked the empty space below IIRC (or hit Enter). At this point, this row in tree view didn't display the text typed but I was able to switch it to editing mode but now no text appeared after I typed and evo crashed about 30 s later.

> 
> [1] https://bugzilla.gnome.org/show_bug.cgi?id=579881
Comment 15 Milan Crha 2013-06-04 13:42:07 EDT
This is obsolete by the rebase (bug #883010), the code in question (the crashing one) is gone in 2.32.3.

Note You need to log in before you can comment on or make changes to this bug.